Subject: Re: [Geopriv] New indoor location - standards needed

From: "Marc Linsner (mlinsner)" <[email-masked]>
Date: Wed, 3 Dec 2014 19:34:38 +0000

Since GeoPriv was just closed downŠ..we can continue this dialog on the
ECRIT list as one has to assume that is where the work would get done.

-Marc-

-----Original Message-----
From: Henning Schulzrinne <[email-masked]>
Date: Tuesday, November 25, 2014 at 12:32 PM
To: "[email-masked]" <[email-masked]>
Subject: [Geopriv] New indoor location - standards needed

>See
>
>http://apps.fcc.gov/ecfs/document/view?id=60000986637
>
>In particular, the need for standards is called out in two areas:
>
>- for the National Emergency Address Database (NEAD)
>
>- for delivery of barometric pressure information to obtain z-axis
>(altitude) information.
>
>The FCC is not a party to the agreement. It seems at least plausible that
>existing GEOPRIV work, such as HELD, or RFC 7105, can be extended to meet
>those needs. I'd appreciate hearing opinions on technical options from
>the WG.
>
>Henning
>
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/geopriv

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 3 Dec 2014 20:33:46 +0000

1)	The GEOPRIV list remains open while you want to exchange ideas.

2)	When you are ready to do work, and it does not meet the scope of existing chartered work ing groups, then it should be DISPATCHED.

3)	At some point ECRIT should complete the work it is chartered to do and close down.

Regards

Keith 

> From: Geopriv [mailto:[email-masked]] On Behalf Of 
> Marc Linsner (mlinsner)
> Sent: 03 December 2014 19:35
> To: Henning Schulzrinne; [email-masked]
> Subject: Re: [Geopriv] New indoor location - standards needed
> 
> Since GeoPriv was just closed downŠ..we can continue this 
> dialog on the ECRIT list as one has to assume that is where 
> the work would get done.
> 
> -Marc-
> 
> >The FCC is not a party to the agreement. It seems at least plausible 
> >that existing GEOPRIV work, such as HELD, or RFC 7105, can 
> be extended 
> >to meet those needs. I'd appreciate hearing opinions on technical 
> >options from the WG.
> >
> >Henning
> >

---

From: Randall Gellens <[email-masked]>
Date: Wed, 3 Dec 2014 21:40:32 -0800

I agree that there does appear to be standards work that may be 
needed, with a role for the IETF.  However, before we in the IETF in 
general or geopriv (or ecrit) in particular jump in with specific 
proposals, I think we need to understand the requirements and overall 
architecture.  Since we are discussing protocols to be used with 
cellular calls, we need to work with the cellular industry to be sure 
that what we develop meets their needs and will be used.

To my knowledge, there has been very little discussion, much less 
agreement, by an industry-specific SDO such as ATIS (since we are 
talking about the U.S.). Once this is done, the objectives for the 
IETF, as well as industry groups, will become clear.  In addition the 
FCC has not issued any new mandate as of yet and is still in an NPRM 
process.

Therefore, I think we need to wait until discussions on the 
requirements and architecture have further progressed by the industry 
groups.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
There is no unhappiness like the misery of sighting land (and work) again
after a cheerful, careless voyage.                          -- Mark Twain

---

From: "Militeau, Christian" <[email-masked]>
Date: Thu, 4 Dec 2014 12:10:41 -0700

Randy,

I agree with your assessment. ATIS (along with NENA and APCO) is in the process of initiating planning to support standards development.
Once ATIS has agreed on something, then it will be more clear on what the IETF needs to do for standards support.
It is anticipated that there will be communications among SDOs (ATIS, 3GPP, IETF, IEEE, etc.) to discuss the support of a standards development plan and possibly coordination like we have done in the past with the Emergency Services Coordination Group.

Regards,
Christian 

-----Original Message-----
From: Geopriv [mailto:[email-masked]] On Behalf Of Randall Gellens
Sent: Wednesday, December 03, 2014 10:41 PM
To: geopriv
Cc: Marc Linsner (mlinsner); DRAGE, Keith (Keith)
Subject: Re: [Geopriv] New indoor location - standards needed

I agree that there does appear to be standards work that may be needed, with a role for the IETF.  However, before we in the IETF in general or geopriv (or ecrit) in particular jump in with specific proposals, I think we need to understand the requirements and overall architecture.  Since we are discussing protocols to be used with cellular calls, we need to work with the cellular industry to be sure that what we develop meets their needs and will be used.

To my knowledge, there has been very little discussion, much less agreement, by an industry-specific SDO such as ATIS (since we are talking about the U.S.). Once this is done, the objectives for the IETF, as well as industry groups, will become clear.  In addition the FCC has not issued any new mandate as of yet and is still in an NPRM process.

Therefore, I think we need to wait until discussions on the requirements and architecture have further progressed by the industry groups.

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: --------------- There is no unhappiness like the misery of sighting land (and work) again
after a cheerful, careless voyage.                          -- Mark Twain

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 4 Dec 2014 19:15:28 +0000

I see the problem differently.

While mobiles using licensed spectrum are clearly the biggest problem, any device that has a WiFi interface could use this mechanism to get a good location for an emergency call.  It isn’t using anything intrinsic to 3G/4G/5G systems.  It’s not a US-only problem.  Because you are linking multiple, independent networks, you need something like the IETF to do that work.

Brian

> On Dec 4, 2014, at 2:10 PM, Militeau, Christian <[email-masked]> wrote:
> 
> Randy,
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 4 Dec 2014 19:28:28 +0000

I suspect there's a general interest in having standards that are technology-neutral and international, and move with some urgency, whether induced by voluntary commitments or just the sense that the sooner we solve (or reduce) the problem, the sooner people will see improved emergency services.

Also, having specific technology examples may accelerate the work by others, just as (one hopes) the availability of ECRIT and GEOPRIV work simplified and sped up the NENA i3 work.

As far as I can tell, there are (at least) two low-level needs for communication location-related data:

(1) barometric data

(2) Wi-Fi measurement data (visible APs and RSS)

For (1), GML seems to offer some support, namely the "Observation" tag. Copying from GML 3.2.1, for a temperature example:

<gml:Observation>
 <gml:validTime>
 <gml:TimeInstant>
 <gml:timePosition>2002-11-12T09:12:00</gml:timePosition>
 </gml:TimeInstant>
 </gml:validTime>
 <gml:using xlink:href="http://www.my.org/sensors/thermometer4"/>
 <gml:target xlink:href="http://www.environment.org/stations/l456"/>
 <gml:resultOf>
 <gml:Quantity uom="#C">18.4</gml:Quantity>
 </gml:resultOf>
</gml:Observation>

GEOPRIV has discussed solutions for #2, but that discussion seems to have faded a bit.

(I don't see the need to wait for the conclusion of the FCC regulatory process. It's often helpful to have a notion of what's possible and the complications before rules are made, for example. Plus, this is not a US-only problem.)

Henning

________________________________________
From: Geopriv [[email-masked]] on behalf of Rosen, Brian [[email-masked]]
Sent: Thursday, December 04, 2014 2:15 PM
To: Militeau, Christian
Cc: geopriv; Marc Linsner; DRAGE, Keith (Keith); Randall Gellens
Subject: Re: [Geopriv] New indoor location - standards needed

Brian

---

From: Randall Gellens <[email-masked]>
Date: Thu, 4 Dec 2014 11:38:40 -0800

At 7:15 PM +0000 12/4/14, Brian Rosen wrote:

>  While mobiles using licensed spectrum are clearly the biggest 
> problem, any device that has a WiFi interface could use this 
> mechanism to get a good location for an emergency call.  It isn't 
> using anything intrinsic to 3G/4G/5G systems.  It's not a US-only 
> problem.  Because you are linking multiple, independent networks, 
> you need something like the IETF to do that work.

The concept of using the macro cell with which the device is 
associated intrinsically links the problem to cellular devices, as 
you mentioned in your earlier message:

At 6:51 PM +0000 11/25/14, Brian Rosen wrote:
>  So, what is needed is a way to connect the WiFi networks in a way 
> where you can reasonably query only those networks that might 
> reasonably have that MAC address.  I think that's probably based on 
> serving cell site.  The NAED would know which WiFi networks were 
> inside the serving cell area, and it would query (all of) them to 
> see which one has the MAC address, and thus the location (if 
> nothing else, the location of the AP that is serving the MAC).

>>  I agree with your assessment. ATIS (along with NENA and APCO) is 
>> in the process of initiating planning to support standards 
>> development.
>>  Once ATIS has agreed on something, then it will be more clear on 
>> what the IETF needs to do for standards support.
>>  It is anticipated that there will be communications among SDOs 
>> (ATIS, 3GPP, IETF, IEEE, etc.) to discuss the support of a 
>> standards development plan and possibly coordination like we have 
>> done in the past with the Emergency Services Coordination Group.
>>
>>  Regards,
>>  Christian
>>
>> needed, with a role for the IETF.  However, before we in the IETF 
>> in general or geopriv (or ecrit) in particular jump in with 
>> specific proposals, I think we need to understand the requirements 
>> and overall architecture.  Since we are discussing protocols to be 
>> used with cellular calls, we need to work with the cellular 
>> industry to be sure that what we develop meets their needs and 
>> will be used.
>>
>> IETF, as well as industry groups, will become clear.  In addition 
>> the FCC has not issued any new mandate as of yet and is still in 
>> an NPRM process.
>>
>> requirements and architecture have further progressed by the 
>> industry groups.
>>
>>  --
>>  Randall Gellens
>>  -------------- Randomly selected tag: --------------- There is no 
>> unhappiness like the misery of sighting land (and work) again

-------------- Randomly selected tag: ---------------
A plane is a bad place for an all-out sleep, but a good place to
begin rest and recovery from the trip to the faraway places you've
been, a decompression chamber between Here and There. Though a
plane is not the ideal place really to think, reassess or
reevaluate things, it is a great place to have the illusion of
doing so, and often the illusion will suffice.
                      --Shana Alexander, The Feminine Eye, 1970.

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 4 Dec 2014 19:40:11 +0000

Most systems have a ³coarse² location mechanism available.

---

From: Randall Gellens <[email-masked]>
Date: Thu, 4 Dec 2014 11:40:02 -0800

>  GEOPRIV has discussed solutions for #2, but that discussion seems 

SUPL seems a natural fit for #2, and possibly for #2 as well.

-------------- Randomly selected tag: ---------------
It takes a wonderful brain and exquisite senses to produce a few
stupid ideas.                                        --Santayana

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 4 Dec 2014 19:49:57 +0000

might work, but SUPL isn’t deployed outside 3G/4G networks, so I suspect that’s not what we would recommend.

Brian
> On Dec 4, 2014, at 2:40 PM, Randall Gellens <[email-masked]> wrote:
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 4 Dec 2014 20:43:00 +0000

For SUPL, wouldn't OMA, rather than ATIS, be the right body to do the work?

>From what I know, SUPL also uses GML, so coordination would probably be helpful (e.g., to ensure that the conventions for SIP geolocation and HELD are closely similar to the MLP/SUPL ones.). A quick look at the MLP spec shows no immediately applicable elements (beyond altitude, obviously) for both #1 and #2.

________________________________________
From: Rosen, Brian [[email-masked]]
Sent: Thursday, December 04, 2014 2:49 PM
To: Randall Gellens
Cc: Henning Schulzrinne; geopriv
Subject: Re: [Geopriv] New indoor location - standards needed

Brian

---

From: Randall Gellens <[email-masked]>
Date: Thu, 4 Dec 2014 14:33:39 -0800

At 7:49 PM +0000 12/4/14, Brian Rosen wrote:

>  might work, but SUPL isn't deployed outside 3G/4G networks, so I 
> suspect that's not what we would recommend.

>  For SUPL, wouldn't OMA, rather than ATIS, be the right body to do the work?

This illustrates why we need coordination among the involved SDOs and 
why the IETF shouldn't jump prematurely to propose a protocol.  We 
don't want ATIS and the IETF developing mutually incompatible 
approaches.

-------------- Randomly selected tag: ---------------
Knowledge always desires increase; it is like fire, which must
first be kindled by some external agent, but which will afterwards
propagate itself.                       --Dr. Samuel Johnson

---

From: Robin Wilton <[email-masked]>
Date: Fri, 5 Dec 2014 10:49:55 +0000

Thanks, Brian, 

This nicely captures a thought that I had been trying to formulate.

For instance, I saw the discussion of using barometric data to estimate vertical location… and thought of existing work to triangulate the position of mobile handsets by using the relative strength of other types of network signal (wifi being the obvious one). As far as I’m aware, that is already technically possible and deployed - though not necessarily to an IETF specification.  

So while it’s interesting to consider the various options (barometric data, wifi triangulation, correlation with nearby ‘locatable’ devices, etc), the trick for the IETF is to convene interested parties at the right level of abstraction to define something that is independent of particular mechanisms.

My 2c...

Yrs.,
Robin