Subject: Re: [grobj] [BEHAVE] What is a site? [Re: [Softwires]Some Thought about theAutomatic Tunnel Address

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 29 Sep 2009 14:10:48 -0700

Brian,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian E Carpenter
> Sent: Tuesday, September 29, 2009 1:05 PM
> To: Dong Zhang
> Cc: [email-masked]; Templin, Fred L; [email-masked]; [email-masked]
> Subject: [BEHAVE] What is a site? [Re: [Softwires]Some Thought about theAutomatic Tunnel Address
> 
> On 2009-09-29 19:28, Dong Zhang wrote:
> ...
> >> Part of the problem with site-local was that the scope was ambiguous.
> > Agree.
> >> the term is not rooted in a discrete object with a position in the
> >> topology, contrast with autonomous system or prefix.
> > Just because of this point, it would better confirm the scope of
> > "site" when talking about it in case misunderstanding and confusion.
> 
> It may be impossible. Actually I'd be very interested to hear any comments
> about the approach to defining address scope that we have taken in
> draft-carpenter-behave-referral-object. Maybe what we call a "limited scope"
> is a site? This should be discussed at a BOF in Hiroshima. Comments on the
> grobj mailing list please:
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/grobj .

I'm not sure it is impossible to define "site"; a site is
just a logical or physical partition (bounded by site border
routers) within a connected routing region. As long as the
nodes within the site remain associated with their site
border routers, they are still within the same site.

Back to site-locals, my understanding was that RFC4193
ULAs were introduced in part to accommodate sites that
partition or merge. As long as each site border router
configures and advertises a its own ULA prefix, there
would be no ambiguity regarding the scope over which
the ULA applies.

Fred
[email-masked] 
 
>     Brian
> 
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 30 Sep 2009 11:01:26 +1300

> would be no ambiguity regarding the scope over which

That can change if you use the ULA over a VPN to another "site",
or if the scope is chopped up with a NAT. I think it's rather
a different thing for a human to understand what the effective
scope is, compared with all hosts knowing algorithmically the
scope of an arbitrary address. I think Dong Zhang is asking for
an algorithmic definition.

    Brian

---

From: Scott Brim <[email-masked]>
Date: Tue, 29 Sep 2009 18:54:00 -0400

> an algorithmic definition.

That gives you two different viewpoints: that of the tunnel client (of
whatever size) and that of the network transporting the tunnel.  From
the point of view of the client it is in the same "site" as the other
client.  Outside the tunnel IP forwarders see the outer header, and
carry it across a "site" boundary.

The scope is not physical.  A site is defined by shared state and
behaviors that cannot be done outside of a "site" scope.

imho fwiw, ymmv ... swb

---

From: Dong Zhang <[email-masked]>
Date: Wed, 30 Sep 2009 10:29:57 +0800

>an algorithmic definition.
Hmm... Yes.

------------------				 
Dong Zhang
2009-09-30

---

From: Dong Zhang <[email-masked]>
Date: Wed, 30 Sep 2009 10:46:20 +0800

Hi Scott,
>behaviors that cannot be done outside of a "site" scope.
Agree, imho, the nodes who have the same behaviors, policy rules and so on 
compose a "site". It is a logical scope. If so, the unambiguous definition 
of logical partition rule should be unified.

Thanks.
------------------				 
Dong Zhang
2009-09-30

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 30 Sep 2009 08:22:24 -0700

Hi Brian,

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Tuesday, September 29, 2009 3:01 PM
> To: Templin, Fred L
> Cc: Dong Zhang; [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [BEHAVE] What is a site? [Re: [Softwires]Some Thought about theAutomatic Tunnel Address
> 

I think what I was suggesting can be expressed algorithmically.
For a node within a site, as long as its site border routers
are still reachable and as long as its on-link or delegated
prefixes are still valid, then the node is still in the same
site. So, the site simply comprises the set of all nodes which
affiliate with the same set of site border routers in this way.

Additionally, the site is known by a name, e.g., "example.com".
Nodes within the site can resolve this name to determine the
list of site border routers.

Fred