Subject: [grobj] New referral use case: widthraw CGN from the path (draft-boucadair-softwire-cgn-bypass)

From: <[email-masked]>
Date: Thu, 17 Dec 2009 07:05:25 +0100

Dear all,

Please find below a link to a new submitted draft which describes another referral use case (not between end host but between involved CGN devices). The objective is to avoid crossing CGN devices.

Comments are more than welcome.

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 16 décembre 2009 17:30
À : [email-masked]
Objet : I-D Action:draft-boucadair-softwire-cgn-bypass-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Procedure to bypass DS-lite AFTR
	Author(s)       : M. Boucadair
	Filename        : draft-boucadair-softwire-cgn-bypass-00.txt
	Pages           : 16
	Date            : 2009-12-16

This document proposes a solution to avoid the use of two stateful
CGN (a.k.a., AFTR in [I-D.ietf-softwire-dual-stack-lite]) devices
when both participants (a.k.a., B4 element) are located behind
different CGN devices.  For this purpose a new IPv6 extension header,
called Tunnel Endpoint Extension Header (TEEH), is defined.  The
proposed procedure encourages the use of IPv6 between AFTR nodes as a
means to avoid the unnecessary crossing of AFTR devices.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-boucadair-softwire-cgn-bypass-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

W0ludGVybmV0U2hvcnRjdXRdDQpVUkw9ZnRwOi8vZnRwLmlldGYub3JnL2ludGVybmV0LWRyYWZ0
cy9kcmFmdC1ib3VjYWRhaXItc29mdHdpcmUtY2duLWJ5cGFzcy0wMC50eHQNCg==

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 18 Dec 2009 08:41:48 +1300

Hi Med,

Have you thought about how this relates to the definition
of scope (or what RSIP calls an addressing realm)? Any
case where we want to avoid hairpinning is a bit the same,
I think.

Can you extract any additional requirements from this?
I could start work on a problem + requirements draft soon.

Regards
   Brian Carpenter

On 2009-12-17 19:05, [email-masked] wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> grobj mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grobj