Subject: Re: [GROW] Call for WG Adoption - draft-shakir-idr-ops-reqs-for-bgp-error-handling

From: Christopher Morrow <[email-masked]>
Date: Fri, 1 Apr 2011 10:19:00 +0200

(+wg this time, for realz)

On Fri, Apr 1, 2011 at 9:20 AM, Christopher Morrow
<[email-masked]> wrote:
> Given the discussion in the room today, and the overlap of
> readers-of-draft + folk-asking-for-adoption a call to the list is
> appropriate.
>
> For the draft: draft-shakir-idr-ops-reqs-for-bgp-error-handling
>  <http://tools.ietf.org/id/draft-shakir-idr-ops-reqs-for-bgp-error-handling-01.txt>
>
> "BGP-4 is utilised as a key intra- and inter-Autonomous System routing
>   protocol in modern IP networks.  The failure modes as defined by the
>   original protocol standards are based on a number of assumptions
>   around the impact of session failure.  Numerous incidents both in the
>   global Internet routing table and within Service Provider networks
>   have been caused by strict handling of a single invalid UPDATE
>   message causing large-scale failures in one or more Autonomous
>   Systems.
>
>   This memo describes the current use of BGP-4 within Service Provider
>   networks, and outlines a set of requirements for further work to
>   enhance the mechanisms available to a BGP-4 implementation when
>   erroneous data is detected.  Whilst this document does not provide
>   specification of any standard, it is intended as an overview of a set
>   of enhancements to BGP-4 to improve the protocol's robustness to suit
>   its current deployment."
>
> can we have some discussion about adoption in GROW for this at this
> time, please?
>
> Call ends 4/14/2011
>
> Thanks!
> -Chris
> grow-wg-co-chair
>

---

From: Jie Dong <[email-masked]>
Date: Fri, 01 Apr 2011 08:33:25 +0000

Support.

-Jie
________________________________________
From: [email-masked] [[email-masked]] on behalf of Christopher Morrow [[email-masked]]
Sent: Friday, April 01, 2011 16:19
To: [email-masked]; [email-masked]; [email-masked] [email-masked]
Subject: Re: [GROW] Call for WG Adoption -      draft-shakir-idr-ops-reqs-for-bgp-error-handling

> can we have some discussion about adoption in GROW for this at this
_______________________________________________
GROW mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/grow

---

From: Russell Heilling <[email-masked]>
Date: Fri, 1 Apr 2011 10:32:49 +0100

+1 support

-- 
Russell Heilling                        http://perlmonkey.blogspot.com
"The amazing ability of the bee to adapt herself often helps the
 beekeeper to overcome the results of his ignorance." - Brother Adam

---

From: "Smith, Donald" <[email-masked]>
Date: Fri, 1 Apr 2011 09:04:04 -0600

+1 support
(coffee != sleep) & (!coffee == sleep)
 [email-masked]
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Russell Heilling [[email-masked]]
Sent: Friday, April 01, 2011 3:32 AM
To: Christopher Morrow
Cc: [email-masked]; [email-masked] [email-masked]; [email-masked]
Subject: Re: [GROW] Call for WG Adoption -      draft-shakir-idr-ops-reqs-for-bgp-error-handling

+1 support

This communication is the property of Qwest and may contain confidential or
privileged information. Unauthorized use of this communication is strictly
prohibited and may be unlawful.  If you have received this communication
in error, please immediately notify the sender by reply e-mail and destroy
all copies of the communication and any attachments.

---

From: John Scudder <[email-masked]>
Date: Fri, 1 Apr 2011 08:09:13 -0700

Yes please.

--John

---

From: Jakob Heitz <[email-masked]>
Date: Sat, 2 Apr 2011 01:59:15 -0400

Support

--
Jakob Heitz.

---

From: Danny McPherson <[email-masked]>
Date: Sat, 2 Apr 2011 08:56:32 -0400

Support.

-danny

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 02 Apr 2011 15:28:56 +0200

Support.

R.

---

From: Shishio Tsuchiya <[email-masked]>
Date: Sat, 02 Apr 2011 23:17:00 +0900

+1 Support

---

From: Ilya Varlashkin <[email-masked]>
Date: Sun, 3 Apr 2011 22:41:07 +0200

support

/iLya

>> can we have some discussion about adoption in GROW for this at this

/iLya

---

From: <[email-masked]>
Date: Mon, 4 Apr 2011 09:43:07 +0200

Support.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Christopher Morrow
> Sent: Friday, April 01, 2011 10:19 AM
> Subject: Re: [GROW] Call for WG Adoption -draft-shakir-idr-ops-reqs-for-bgp-error-handling
>

---

From: Warren Kumari <[email-masked]>
Date: Mon, 4 Apr 2011 09:21:22 -0400

And another "support"...
On Apr 1, 2011, at 4:19 AM, Christopher Morrow wrote:

>>  <http://tools.ietf.org/id/draft-shakir-idr-ops-reqs-for-bgp-error-handling-01.txt 
>> >
>>

---

From: Carlos Martinez <[email-masked]>
Date: Mon, 4 Apr 2011 18:55:10 +0000

+1 support

On Mon, Apr 4, 2011 at 1:21 PM, Warren Kumari <[email-masked]> wrote:

>>>  <
>>> http://tools.ietf.org/id/draft-shakir-idr-ops-reqs-for-bgp-error-handling-01.txt
>>> >
>>>

---

From: Tom Hodgson <[email-masked]>
Date: Mon, 4 Apr 2011 21:23:22 +0100 (BST)

>> readers-of-draft + folk-asking-for-adoption a call to the list is

Draft expounds our current concerns in this regard well and agree that it 
should be adopted.

-- 
Tom Hodgson
[email-masked]

---

From: Pedro Andres Aranda Gutierrez <[email-masked]>
Date: Tue, 5 Apr 2011 08:09:22 +0200

Support

---

From: Chris White <[email-masked]>
Date: Tue, 5 Apr 2011 05:35:10 -0700

+1

---

From: Colin Petrie <[email-masked]>
Date: Tue, 05 Apr 2011 14:40:26 +0100

Support.

---

From: Christopher Morrow <[email-masked]>
Date: Fri, 15 Apr 2011 09:56:53 -0400

This call ended today, it's successful (working group would like to adopt).

Rob, could you spin a new draft with the right name and submit to the
datatracker pls?

Thanks to everyone for participating!
:)
-Chris

---

From: Rob Shakir <[email-masked]>
Date: Sat, 16 Apr 2011 17:14:38 +0100

> Rob, could you spin a new draft with the right name and submit to the

Hi Chris, GROW,

Thanks very much for supporting this adoption. As I've said before, I think this is a key problem affecting the robustness of networks utilising BGP, and am keen to resolve it!  	

There are a number of comments that have been made to me both in Prague and off-line to IDR/GROW - especially regarding some clarifications of requirements around where the NLRI cannot be recovered from a message. I am hoping to update the draft to address these comments in very near future.

In the meantime, if there are further comments as to clarifications to existing requirements, or requirements that are omitted from the current version - please let me know, so that we can try and make this draft complete.

Many thanks.

Kind regards,
r.