Subject: [GROW] current state of BMP implementations?

From: John Kemp <[email-masked]>
Date: Tue, 05 Nov 2013 09:32:16 -0800

Can anyone summarize the current state
of the Juniper or Quagga work on BMP?

We have the opportunity to work on either
of those platforms and would like to get
our feet wet working with the tools.  Any
guidance is appreciated.

Thanks,
John Kemp
RouteViews
[email-masked]

---

From: Pedro Torres <[email-masked]>
Date: Tue, 5 Nov 2013 15:53:55 -0200

Hello,

I am waiting for that answer too. I am very interested in some open
source implementation.

--
Pedro
PTT-Curitiba

On Tue, Nov 5, 2013 at 3:32 PM, John Kemp
<[email-masked]> wrote:
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 5 Nov 2013 14:07:36 -0500

> of the Juniper or Quagga work on BMP?

BMPv1 support has been available in JUNOS for a while now.
BMPv3 support will be in 13.3.

-- Jeff

---

From: John Kemp <[email-masked]>
Date: Tue, 05 Nov 2013 14:21:59 -0800

> BMPv3 support will be in 13.3.

Anyone publish any client station code?

John Kemp

---

From: Stephen Stuart <[email-masked]>
Date: Tue, 5 Nov 2013 15:34:47 -0800

https://code.google.com/p/bmpreceiver/

Tested against the JUNOS draft -01 sender implementation.

Stephen

On Tue, Nov 5, 2013 at 2:21 PM, John Kemp <[email-masked]
> wrote:

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Tue, 5 Nov 2013 20:06:07 +0000

Hi,

FYI for Cisco, 

BMP development is completed for IOS-XE and IOS classic.

Implementation is based on BMPv7
FCS target Nov 2013 (few more weeks)

One small deviation from the BMPv7 draft: 
We also added few extra BMP statistics: few TCP stats, the goal is to monitor/detect slow peers by monitoring TCP.

Current BMP (cisco) stats and values are: 
32767 : SRTT: the Smooth Round-Trip Timer is a measurement of the average time that it takes a packet to be sent and acknowledged by the remote peer.
32768 : RTTO: the round-trip timeout in milliseconds.
32769 : RTV: the variance of the round-trip time in milliseconds.
32770 :KRTT: the new round-trip (K stands for Karn's algorithm) timeout. It measures the round-trip time, in milliseconds, for packets that have been retransmitted.
32771 :minRTT: the smallest round-trip timeout.
32772 :maxRTT: the largest round-trip timeout.
32773 :ACK hold: the acknowledgment delay timeout used to delay acknowledgements to allow time to add data to the packet.
32774 :Datagrams: the largest data segment in bytes

Working with author to standardize these stats, will update our implementation as soon as standardized. 

BRGDS Bertrand 
Cisco BGP product manager.

From: Jeffrey Haas <[email-masked]>
Subject: Re: [GROW] current state of BMP implementations?
Date: November 5, 2013 8:07:36 PM GMT+01:00
To: John Kemp <[email-masked]>
Cc: [email-masked]

-- Jeff