Subject: [GROW] Alvaro Retana's Discuss on draft-ietf-grow-bgp-gshut-12: (with DISCUSS and COMMENT)

From: Alvaro Retana <[email-masked]>
Date: Wed, 13 Dec 2017 19:27:59 -0800

Alvaro Retana has entered the following ballot position for
draft-ietf-grow-bgp-gshut-12: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-grow-bgp-gshut/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Why is this document not in the Standards Track?  I ask because I think that
the definition of a well-known community (one which has "global significance
and their operations shall be implemented in any community-attribute-aware BGP
speaker" [rfc1997], in other words, everywhere!) should result in a Standards
Track specification, and not in an Informational document.  I couldn't find any
specific justification for the status in the writeups (Shepherd or Ballot), nor
a related discussion in the archive.

To resolve this DISCUSS, I would prefer to see a change in the status, but will
yield to WG consensus (so a pointer to that discussion would be enough).

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Nit:  It would be very nice if the appendices were referenced in the text.

---

From: <[email-masked]>
Date: Thu, 14 Dec 2017 14:55:34 +0000

[+Ben Campbell +Warren Kumari]  (Explicitly adding Ben and Warren who expressed the same comment)

Hi Alvaro,

Thanks for your review and comments.
More inline [Bruno]

> From: Alvaro Retana [mailto:[email-masked]]
 > Sent: Thursday, December 14, 2017 4:28 AM
> 

[Bruno]
Short version: there is no specific reason not to use Standards Track. Authors are fine to change to Standards Track, especially after 3 AD reviews asking for it. Following a discussion with Warren, I'll wait for the IESG telechat before uploading the new version.

Long version:
I think this had been discussed on the mailing list, but I can't find the thread. AFAIR (or dreamt) one WG participant said that Informational was enough and nobody asked for Standard Tracks.
Note that from a technical standpoint, this community may be deployed incrementally, on a per ASBR or even EBGP session basis. Strictly speaking, there is no requirement that all implementations (in the AS and neighboring ASes) recognize this community.
However, we do want to associate a well-defined behavior to this IANA reserved community, so Standard Tracks is fine with me.

Best regards,
--Bruno

 > yield to WG consensus (so a pointer to that discussion would be enough).

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 14 Dec 2017 16:51:01 +0000

Hi Alvaro,
 
 More inline [Bruno2]

 > From: [email-masked] [mailto:[email-masked]]
 > Sent: Thursday, December 14, 2017 3:56 PM
> 

[...]

[Bruno2] Good idea. Thanks.
Done in -13 that I have just uploaded. https://www.ietf.org/rfcdiff?url2=draft-ietf-grow-bgp-gshut-13

Regards,
--Bruno