Subject: [GROW] Genart last call review of draft-ietf-grow-wkc-behavior-03

From: Brian Carpenter via Datatracker <[email-masked]>
Date: Fri, 03 May 2019 21:52:06 -0700

Reviewer: Brian Carpenter
Review result: Ready with Issues

Gen-ART Last Call review of draft-ietf-grow-wkc-behavior-03

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-grow-wkc-behavior-03.txt
Reviewer: Brian Carpenter
Review Date: 2019-05-04
IETF LC End Date: 2019-05-13
IESG Telechat date:  

Summary: Ready, but...
--------

Minor issues:
-------------

This seems *much* more like a BCP than a standard.

In both the Abstract and the 2nd paragraph of the Introduction,
it might be helpful to add something like:
  This document recommends specific action items to limit future inconsistency.

---

From: Randy Bush <[email-masked]>
Date: Fri, 03 May 2019 23:18:13 -0700

>   This document recommends specific action items to limit future inconsistency.

thanks.  done but not (yet) published.

randy

---

From: David Farmer <[email-masked]>
Date: Sat, 4 May 2019 02:38:48 -0500

> IETF LC End Date: 2019-05-13

In my opinion, this document adds new requirements or at least new
considerations for implementations of RFC1997, I think that means it
updates RFC1997. I liked to see it have "Updates: 1997" metadata added and
appropriate statements in the Abstract and Intro. I think this requires and
justifies it being Standards Track.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Randy Bush <[email-masked]>
Date: Sat, 04 May 2019 11:03:12 -0700

> In both the Abstract and the 2nd paragraph of the Introduction,

i have no dog in this fight.  in general, i try to focus on the protein
of the document, and leave grammar tweaks, what form of 2119 to use,
etc. to the rfc editor, and weighty decisions such as this to the iesg.

the bikeshed will, of course, be magenta comic sans :)

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 5 May 2019 11:06:40 +1200

>> justifies it being Standards Track.

That's a consistent approach too. One or the other, I don't care.

But not magenta, never!

    Brian