Subject: [GROW] Working Group Adoption Call: draft-lucente-grow-bmp-tlv-ebit (Ends 02/May/2022)

From: Job Snijders <[email-masked]>
Date: Fri, 8 Apr 2022 16:19:19 +0200

Hi GROW,

At the IETF 113 GROW session Paolo asked whether this working group
could consider adoption for draft-lucente-grow-bmp-tlv-ebit.

This message is a request to the group for feedback on whether this
internet-draft should be adopted.

Title:
   Support for Enterprise-specific TLVs in the BGP Monitoring Protocol
Abstract: 
   Message types defined by the BGP Monitoring Protocol (BMP) do
   provision for data in TLV - Type, Length, Value - format, either in
   the shape of optional TLVs at the end of a BMP message or Stats
   Reports TLVs.  However the space for Type value is unique and
   governed by IANA.  To allow the usage of vendor-specific TLVs, a
   mechanism to define per-vendor Type values is required.  In this
   document we introduce an Enterprise Bit, or E-bit, for such purpose.

The Internet-Draft can be found here: https://datatracker.ietf.org/doc/html/draft-lucente-grow-bmp-tlv-ebit

Please share with the mailing list if you are think this work should be
adopted by GROW, willing to review and/or otherwise contribute to this
draft!

WG Adoption call ends May 2nd, 2022.

Kind regards,

Job

---

From: <[email-masked]>
Date: Fri, 8 Apr 2022 15:06:52 +0000

Dear GROW working group,

I read and support the draft-lucente-grow-bmp-tlv-ebit adoption.

The support of vendor-specific TLVs in the BMP application enables the development of new BMP extensions the same way as enterprise-specific Information Elements did in IPFIX. Therefore I agree with the authors that it is valuable contribution to the community and prevent that unused IANA code points are further misused for these purposes.

Best wishes
Thomas

-----Original Message-----
From: GROW <[email-masked]> On Behalf Of Job Snijders
Sent: Friday, April 8, 2022 4:19 PM
To: [email-masked]
Subject: [GROW] Working Group Adoption Call: draft-lucente-grow-bmp-tlv-ebit (Ends 02/May/2022)

Hi GROW,

At the IETF 113 GROW session Paolo asked whether this working group could consider adoption for draft-lucente-grow-bmp-tlv-ebit.

This message is a request to the group for feedback on whether this internet-draft should be adopted.

Title:

The Internet-Draft can be found here: https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-lucente-grow-bmp-tlv-ebit&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C02a7ebc6d92d424867a208da196ad88b%7C364e5b87c1c7420d9beec35d19b557a1%7C0%7C0%7C637850243938463878%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=nLkBTl1Ps1N8GAx6dnsDRPKGXpzJZpxkm0nUYlHDMHc%3D&amp;reserved=0

Please share with the mailing list if you are think this work should be adopted by GROW, willing to review and/or otherwise contribute to this draft!

Kind regards,

Job

_______________________________________________
GROW mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fgrow&amp;data=04%7C01%7CThomas.Graf%40swisscom.com%7C02a7ebc6d92d424867a208da196ad88b%7C364e5b87c1c7420d9beec35d19b557a1%7C0%7C0%7C637850243938463878%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=odjJD%2FWxPYMikqe32cgcuPe833%2FEYaBQKP45%2FuLeVO0%3D&amp;reserved=0

---

From: Zhuangshunwan <[email-masked]>
Date: Wed, 13 Apr 2022 02:51:17 +0000

Hi GROW WG,

I have read this document and participated in the previous discussion of the proposal. I think it is a very useful document and I support its adoption.

Kindest Regards,
Shunwan

> From: GROW [mailto:[email-masked]] On Behalf Of Job Snijders
> Sent: Friday, April 8, 2022 10:19 PM
> To: [email-masked]
> Subject: [GROW] Working Group Adoption Call:
> draft-lucente-grow-bmp-tlv-ebit (Ends 02/May/2022)
> 
> Hi GROW,
> 
> At the IETF 113 GROW session Paolo asked whether this working group could
> consider adoption for draft-lucente-grow-bmp-tlv-ebit.
> 
> The Internet-Draft can be found here:
> https://datatracker.ietf.org/doc/html/draft-lucente-grow-bmp-tlv-ebit
> 
> https://www.ietf.org/mailman/listinfo/grow

---

From: Benoit Claise <[email-masked]>
Date: Wed, 13 Apr 2022 08:58:51 +0100

Dear all,

I specifically appreciate the reuse of the IPFIX PEN mechanism, which 
facilitates an efficient a collection system for combined data and 
control plane monitoring. Hence support.

Regards, Benoit

On 4/13/2022 3:51 AM, Zhuangshunwan wrote:
> .

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 15 Apr 2022 23:47:12 -0400

Dear Grow WG

I think this is very useful work and I support WG adoption.

I think this idea of vendor specific TLV E bit id very helpful for
interoperability between vendors during early pre standard development
phases when vendors have proprietary features.

This may also help operators to get involved in early development phase
with this circumvention of interoperability.

Kind Regards

Gyan

On Wed, Apr 13, 2022 at 3:59 AM Benoit Claise <benoit.claise=
[email-masked]> wrote:

> > I have read this document and participated in the previous discussion of
> the proposal. I think it is a very useful document and I support its
> adoption.
> >
> > Kindest Regards,
> > Shunwan
> >
> could
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Sun, 17 Apr 2022 03:53:55 +0000

Dear all,

I have read this document and I think this TLV is useful for pre-standard development. I support its adoption. 

Kindest Regards,
Haibo

|-----Original Message-----
|From: GROW [mailto:[email-masked]] On Behalf Of Job Snijders
|Sent: Friday, April 8, 2022 10:19 PM
|To: [email-masked]
|Subject: [GROW] Working Group Adoption Call: draft-lucente-grow-bmp-tlv-ebit
|(Ends 02/May/2022)
|
|Hi GROW,
|
|At the IETF 113 GROW session Paolo asked whether this working group could
|consider adoption for draft-lucente-grow-bmp-tlv-ebit.
|
|This message is a request to the group for feedback on whether this
|internet-draft should be adopted.
|
|Title:
|   Support for Enterprise-specific TLVs in the BGP Monitoring Protocol
|Abstract:
|   Message types defined by the BGP Monitoring Protocol (BMP) do
|   provision for data in TLV - Type, Length, Value - format, either in
|   the shape of optional TLVs at the end of a BMP message or Stats
|   Reports TLVs.  However the space for Type value is unique and
|   governed by IANA.  To allow the usage of vendor-specific TLVs, a
|   mechanism to define per-vendor Type values is required.  In this
|   document we introduce an Enterprise Bit, or E-bit, for such purpose.
|
|The Internet-Draft can be found here:
|https://datatracker.ietf.org/doc/html/draft-lucente-grow-bmp-tlv-ebit
|
|Please share with the mailing list if you are think this work should be adopted by
|GROW, willing to review and/or otherwise contribute to this draft!
|
|WG Adoption call ends May 2nd, 2022.
|
|Kind regards,
|
|Job
|
|_______________________________________________
|GROW mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/grow