Subject: [GROW] Status Check for: draft-cptb-grow-bmp-yang

From: Christopher Morrow <[email-masked]>
Date: Fri, 8 Apr 2022 10:20:18 -0400

Folks,
During our last meeting Camilo gave a presentation on:
 draft-cptb-grow-bmp-yang

I believe the authors' intention was to gauge whether or not the WG wanted
to adopt this work item? So:
  1) Was that the intent?
  2) Did the group also understand that to be the case?
  3) if 1 and 2 I'll kick out a 'wg adoption' call shortly.

-chris
co-chair-persona.

---

From: Camilo Cardona <[email-masked]>
Date: Mon, 11 Apr 2022 13:03:59 -0500

Hello Grow-chairs, grow list,

I confirm It was the authors’ intent to ask for WG adoption for draft-cptb-grow-bmp-yang.

Thanks,
Camilo C.

> On 8 Apr 2022, at 09:20, Christopher Morrow <[email-masked]> wrote:
> 
> Folks,
> I believe the authors' intention was to gauge whether or not the WG wanted to adopt this work item? So:
>   1) Was that the intent?
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: Chenshuanglong <[email-masked]>
Date: Wed, 13 Apr 2022 01:54:54 +0000

Hi all,

I read the draft carefully and it is very useful to define a YANG model for BMP. There are two suggestions.

1. BMP is a protocol that monitors BGP. The current BGP YANG model definition framework is first set the VPN instance, and then the address family and parameter information. However, if the current draft is based on BGP habits, it is more friendly to users who are familiar with BGP configurations. I suggest that it would be better to refer to the BGP YANG model.

2. According to the YANG model defined in the current draft, if you want to monitor the Rib-In and Rib-Out information of 10 peers, you need to configure 10 peer IP addresses for the Rib-In and Rib-Out interfaces respectively. As a result, the packet size increases.

Best Regards
Shuanglong

From: GROW [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: Friday, April 8, 2022 10:20 PM
To: [email-masked] [email-masked] <[email-masked]>; <[email-masked]> <[email-masked]>; [email-masked]
Subject: [GROW] Status Check for: draft-cptb-grow-bmp-yang

Folks,

-chris
co-chair-persona.