Subject: cont'd: Re: q about connection records

From: "Avri Doria" <[email-masked]>
Date: Wed, 13 Jun 2001 21:44:07 -0400

Sent accidentally before completion.

-------- Original Message --------
From: avri doria <[email-masked]>
Subject: Re: q about connection records
To: [email-masked]

Hi,

Re: the more flag

The reference is to the More setting of the result field.  This is 
documented on Page 10.  

It is an editorial error for it to be called the More flag
and should probably be referred to as More in the result field.

Re:  Record count in the connection block.  
You are correct that should be the count of branch records.

Thanks
a.
-- 

Avri Doria
+1 401 663 5024
===============

[email-masked] wrote:
> 
> I just joined the list. I'm doing a 'cleanroom' implementation of GSMPv3
> for a research project here, and am currently trying to implement the
> Report Connection State message. There's a reference in the description
> of "Connection Records" to "the More flag of the last Connection Record
> in a success reponse message.." (this is page 75, the 4th and 5th lines
> above the figure).
> 
> I don't seem to be able to find the text in which the More flag is defined.
> Would someone be so kind as to point me to the relevant para?
> 
> Similarly the Last Branch flag referred to on page 76.
> 
> Not seeing the definition of either flag, I'm finding it difficult
> to figure how many Connection Records and Output Branches.
> 
> (By the way, might it be the case that the Record Count (defined p76)
> refers to the number of Output Branch Records, rather than to the
> number of Connection Records as stated? Since each Connection Record
> has an associated Record Count, I don't see why one would wish to
> replicate this one value multiple times in a response message. Perhaps
> I'm misunderstanding the intent of the spec?)
> 
> Thanks in advance, and sorry for the bother. I assume that I'm just
> overlooking or misunderstanding how this message should be parsed,
> but it's not coming to me after repeated readings and greps of the
> draft.
> 
>                                 Regards, Jim Snyder
>                                 [email-masked]
> 
>                                 AT&T Labs - Research
>                                 Shannon Laboratory
>                                 180 Park Ave.
>                                 Florham Park, NJ 07932
> 
>                                 973-360-8214 (voice)
>                                 973-360-8455 (fax)

---

From: [email-masked]
Date: Wed, 13 Jun 2001 22:32:26 -0400 (EDT)

Avri Doria wrote:
|Re: the more flag
|
|The reference is to the More setting of the result field.  This is 
|documented on Page 10.  
|
|It is an editorial error for it to be called the More flag
|and should probably be referred to as More in the result field.
|
|Re:  Record count in the connection block.  
|You are correct that should be the count of branch records.

Righto, thanks!

What is the Last Branch flag, SVP?

I'm sorry to say that I'm still confused as to how one sorts out the
number of Connection Records contained in a single success message.

For example, suppose the switch wishes to return two connection records,
for whatever reason, and suppose the two CRs fit within an MTU.

How does the controller know that there are two CRs?

			Much obliged,

				Jim Snyder
				[email-masked]

				AT&T Labs - Research