Subject: GSMP VPI/VCI in a multi switch environment

From: "Mauro Cianchi" <[email-masked]>
Date: Fri, 13 Jul 2001 16:44:56 +0200

---------------------- Forwarded by Mauro Cianchi/MAIN/MC1 on 13/07/2001 16.44
---------------------------

From: Fabio Poggi On: 13/07/2001 16.41.02

To:   Mauro Cianchi/MAIN/MC1@MCMAIN
cc:

Subject:  GSMP VPI/VCI in a multi switch environment

Hi all,
I'm reading the <draft-ietf-gsmp-encaps-03>.

In case of ATM encapsulation the defaul VPI/VCI of the GSMP control channel is
VPI=0, VCI=15.
This is valid in case there is a controller managing only one switch.

In case the controller commands more than one switches, are there rules to
assign the VPI/VCI values to the various GSMP control channels from the
controller to the severals switches ?

Thanks a lot.

---

From: Peter Newman <[email-masked]>
Date: Fri, 13 Jul 2001 10:41:32 -0700

ATM links are point-to-point. If you are controlling a switch over an ATM 
link there can only be a single switch at the end of the link to control. 
So VPI=0, VCI=15 is sufficient. If you are controlling multiple switches 
then you'll have multiple links, each with a VPI=0, VCI=15. You can use an 
ATM switch to multiplex all of those control channels onto a single link 
that attaches to the controller. This ATM switch will of course map the 
VCIs in the normal manner. It can choose any VCI it likes on the link to 
the controller. (Of course the controller probably controls this switch too 
-- over VPI=0, VCI=15.)

--Peter

---

From: "Avri Doria" <[email-masked]>
Date: Fri, 13 Jul 2001 14:45:23 -0400

Hi,

the VPI and VCI values for the control connections can be set 
using the mib.
---

from draft-ietf-gsmp-mib-05.txt

 gsmpAtmEncapVpi OBJECT-TYPE
        SYNTAX         AtmVpIdentifier
        MAX-ACCESS read-create
        STATUS         current
        DESCRIPTION
             " The VPI value for the virtual channel over which the
             GSMP session is established, i.e., the GSMP control
             channel for LLC/SNAP encapsulated GSMP messages on an
             ATM data link layer."
        DEFVAL { 0 }
        ::= { gsmpAtmEncapEntry 3 }

    gsmpAtmEncapVci OBJECT-TYPE
        SYNTAX         AtmVcIdentifier
        MAX-ACCESS read-create
        STATUS         current
        DESCRIPTION
             " The VCI value for the virtual channel over which the
             GSMP session is established, i.e., the GSMP control
             channel for LLC/SNAP encapsulated GSMP messages on an
             ATM data link layer."
        DEFVAL { 15 }
        ::= { gsmpAtmEncapEntry 4 }

a.
-- 

Avri Doria
+1 401 663 5024
===============
http://www.aidsride.org/new/northeast/index.htm
Rider : 1063