Subject: Re: [fmc] status of fmc bof / PAAS

From: <[email-masked]>
Date: Mon, 1 Jul 2013 10:34:06 +0200

Hi Dave,
Thanks for the question! As you already suggested we don't want to exclude one of both cases, so we consider both: different flavours of NAT as described in http://tools.ietf.org/html/draft-boucadair-intarea-host-identifier-scenarios-03 as well as e.g. DHCPv6 PD as mentioned in http://www.ietf.org/internet-drafts/draft-sarikaya-fmc-prefix-sharing-usecase-01.txt

Best regards
Dirk
From: David Allan I [mailto:[email-masked]]
Sent: Freitag, 28. Juni 2013 21:44
To: von Hugo, Dirk; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: status of fmc bof / PAAS

HI

When you mention prefix sharing, are you referring to IPv6 PD or NAT... or both...

Thanks
Dave

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 28, 2013 12:45 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [fmc] status of fmc bof / PAAS

Dear all,
Our planned BarBOF meeting in Berlin will presumably be on Monday at lunchtime. We should discuss on the proper problem statement on addressing, identifying and localizing end user terminals - where to scope for starting the work. Two of the most demanded use cases may be the location issue for emergency calls as mandated e.g. by European Commission in M/493 and the BBF where the prefix sharing problem (aka host identifier issue) has been identified.

Solution drafts are also welcome ;-)

Further proposals and comments - also just expression of interest - are strongly encouraged.

Hope to see you in Berlin!

Best regards
Dirk

BTW: PAAS should denote Prefix And Address Sharing
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of von Hugo, Dirk
Sent: Freitag, 14. Juni 2013 17:46
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [fmc] status of fmc bof

Dear all,

as you may remember we had focused the discussion in this list on how an end host can be identified correctly e.g. behind NATed gateways. Due to recent developments we decided to reduce the scope to prefix and address sharing topic and move the BOF to OPS area. We already have drafted a reformulated corresponding text on the wiki (http://trac.tools.ietf.org/bof/trac/wiki/WikiStart) and renamed the provisional BOF request to PAAS.

Please comment on the list, join the discussion and participate in improvement of the BoF request including the problem description and the proposed charter.

Also please think of submitting a solution draft.

Your valuable contributions are very much appreciated.
Thanks!

Best regards
Behcet and Dirk

---

From: David Allan I <[email-masked]>
Date: Mon, 1 Jul 2013 20:10:43 +0000

Hi

I read the prefix sharing use case...

Isn't the answer to this use case straightforward. An RG that supports UEs cannot use SLAAC to distribute the delegated prefix, and needs to issue a unique /64 to each device on the WiFi....it pretty much already is supernetting. So at best a BCP is needed.

Not pretty but keeps the problem from wagging the dog....

Cheers
Dave

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 01, 2013 1:34 AM
To: David Allan I; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: status of fmc bof / PAAS

Hi Dave,

Best regards
Dirk
From: David Allan I [mailto:[email-masked]]
Sent: Freitag, 28. Juni 2013 21:44
To: von Hugo, Dirk; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: status of fmc bof / PAAS

HI

Thanks
Dave

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, June 28, 2013 12:45 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [fmc] status of fmc bof / PAAS

Dear all,

Best regards
Dirk

Dear all,

Best regards
Behcet and Dirk

---

From: Marco Spini <[email-masked]>
Date: Wed, 3 Jul 2013 07:05:44 +0000

Hi Dave

The problem is more general, in fixed spec, it is possible to perform prefix delegation to the RG. In this scenario the RG will assign an IP address out of the IPv6 prefix to any devices without making aware the BNG. The BNG can not start any specific  IP-CAN session to for that specific device&IPv6 address, but there is only 1 single IP-CAN session for the RG. This is similar to IPv4 NAT scenario. Furthermore this is not specific for 3GPP UE, but for any device connected to the RG. IN a convergent scenario this is independent since a single Policy decision is used for both.
The SLAAC is slightly different, but the effect is the same, a device obtains an IP address, but the BNG is not aware of which is the IP address.

When you say that a RG that supports UE needs to issue a unique prefix to each device, how can be done according to you, by pre-configuration or by some other kind of detection?

BR
Marco

From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: lunedì 1 luglio 2013 22:11
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [fmc] status of fmc bof / PAAS

Hi

Cheers
Dave

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, July 01, 2013 1:34 AM
To: David Allan I; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: status of fmc bof / PAAS

Hi Dave,

Best regards
Dirk

HI

Thanks
Dave

Dear all,

Best regards
Dirk

Dear all,

Best regards
Behcet and Dirk

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 17:38:13 +0200

Dear all,
The BarBOF will take place either on Monday or Thursday during lunch break - depending on the available room which shall be scheduled by IETF project management during this week.
We will have presentations on problem statement and 2 solution drafts which have been announced recently thanks to Andrew and Roland!
Discussion may start also on the list  ;-)
We will come back later with the room details!
Thanks!
Best regards
Dirk

From: Marco Spini [mailto:[email-masked]]
Sent: Mittwoch, 3. Juli 2013 09:06
To: David Allan I; von Hugo, Dirk; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: status of fmc bof / PAAS

Hi Dave

BR
Marco

Hi

Cheers
Dave

Hi Dave,

Best regards
Dirk

HI

Thanks
Dave

Dear all,

Best regards
Dirk

Dear all,

Best regards
Behcet and Dirk