Subject: [Hipsec] Re: Numbering of TLVs

From: Petri Jokela <[email-masked]>
Date: Wed, 01 Jun 2005 11:03:11 +0300

> have been spaced to allow for future protocol extensions.  Parameters
> numbered between 0-1023 are used in HIP handshake and update procedures

Was there any reasoning ealier to put them below 512?

> to insert a new parameter between two existing ones, it is numbered to
> split the difference between the two, etc.

Ok. Any objections to the proposed numbering?

> For example:
> 			OLD		NEW
> ESP_INFO		1		65 (2^6+1)
> R1_COUNTER		2		128 (2*2^6)
> LOCATOR		3		193 (3*2^6 + 1, etc.)
> PUZZLE		5		257
> SOLUTION		7		321
> SEQ			11		385
> ACK			13		449
> DIFFIE_HELLMAN 	15		513
> HIP_TRANSFORM  	17		577
> ENCRYPTED   	21		641
> HOST_ID     	35		705
> CERT        	64		768
> NOTIFY      	256		832
> 
> ECHO_REQUEST 	1022		896
> ECHO_RESPONSE 	1024		960
> 
> ESP_TRANSFORM 	2048		2048
> 
> HMAC			65245		61505	
> HMAC_2		65247		61569
> HIP_SIGNATURE_2  	65277		61633
> HIP_SIGNATURE    	65279		61697
> 
> ECHO_REQUEST      65281		63661
> ECHO_RESPONSE     65283		63425
> 
> FROM			65470		63552
> RVS_HMAC		65472		63616
> VIA_RVS		65474		63680

/petri

-- 
Petri Jokela                        Tel:    +358 9 299 2413
Research scientist                  Fax:    +358 9 299 3535
NomadicLab, Ericsson Research       Mobile: +358 44 299 2413
Oy L M Ericsson Ab                  email: [email-masked]

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Wed, 1 Jun 2005 07:56:15 -0700

> -----Original Message-----
> From: Petri Jokela [mailto:[email-masked]] 
> Sent: Wednesday, June 01, 2005 1:03 AM
> To: Henderson, Thomas R
> Cc: [email-masked]
> Subject: Re: Numbering of TLVs
> 
> 

I do not know any such reason.  The below scheme is somewhat arbitrary
too, but one has to draw lines somewhere.

> > ECHO_RESPONSE 	1024		960
Just that these should also be bumped up by 1 (as per previous message
on critical bit for these parameters).

Tom