Subject: [homegate] FW: [v4tov6transition] two questions about address allocation whiledesigning

From: "David Harrington" <[email-masked]>
Date: Mon, 23 Aug 2010 12:01:34 -0400

Hi,

Here is a comment from another non-WG mailing list that seems relevant
to homegate discussions. 

<begin>
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Fred Baker

we have too many names for these things... :-) in v6ops, it's being
called a CPE Router, and in other venues its being called a
residential gateway. I prefer calling it a "CPE Router" because the
same router and the same infrastructure is often used for things that
aren't homes - what are often called Small Office/Home Office (SOHO)
networks
(http://searchmobilecomputing.techtarget.com/definition/Small-Office-H
ome-Office). The next step up is often called Small/Medium Business or
SMB
(http://searchcio-midmarket.techtarget.com/sDefinition/0,,sid183_gci10
05201,00.html), and would have a higher throughput and often higher
cost version of the same CPE. 
<end>

It would be hard to achieve consistent terminology across SDOs, but
can we please develop consistent terminology across IETF WGs at least?

Since there has been considerable discussion of what a home gateway is
and what a home network is, it is obvious different people call
similar things by different names. If you cannot agree on the
terminology, you probably won't agree on the technologies and
practices. I recommend a terminology section (or document) that
reflects already-in-use terminology in the IETF and consensus for WG
terms, as part of the charter deliverables, and then have any WG
documents use consistent terminology. 

dbh

---

From: Fred Baker <[email-masked]>
Date: Mon, 23 Aug 2010 09:18:13 -0700

That was my comment on Tina Tsou's use of "HWG", which I didn't grok, and which she explained was intended to be "HGW" - Home Gateway".

Consider this a +1 for a moderate level of conceptual continuity among folks that are discussing the same thing. If it's a different name, it might be worthwhile having a definition somewhere that says what is different and why it is different.

On Aug 23, 2010, at 9:01 AM, David Harrington wrote:

> _______________________________________________
> homegate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homegate

---

From: "Duncan Bees" <[email-masked]>
Date: Mon, 23 Aug 2010 09:26:55 -0700

On terminology,

Within HGI we have used HG (Home Gateway) for managed home routers used for
residential applications which can include SOHO. The requirements document
for HG thus forming a "residential profile" of requirements.

SBG (Small Business Gateway) is a related profile of requirements for boxes
going a bit further in support for small business. It is in draft within
HGI.

Best Regards
Duncan Bees

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Fred Baker
Sent: August-23-10 9:18 AM
To: David Harrington
Cc: [email-masked]
Subject: Re: [homegate] FW: [v4tov6transition] two questions about address
allocation whiledesigning

That was my comment on Tina Tsou's use of "HWG", which I didn't grok, and
which she explained was intended to be "HGW" - Home Gateway".

Consider this a +1 for a moderate level of conceptual continuity among folks
that are discussing the same thing. If it's a different name, it might be
worthwhile having a definition somewhere that says what is different and why
it is different.

---

From: Mark Baugher <[email-masked]>
Date: Thu, 26 Aug 2010 06:18:17 -0700

We are talking about two different types devices, I think.  One type of gateway is installed and managed by a a provider on the customer's premises.  The second type is a retail product.  We could call both by the same name.  I don't have a problem with this so long as we make a distinction between the two cases, which have different requirements in many ways.

Mark

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 26 Aug 2010 08:30:01 -0700

>We are talking about two different types devices, I think.  One type of gateway is installed and managed by a a provider on the customer's premises.  The second type is a retail product.  We could c…

Fully agree that they should both be included and considered differently where appropriate. However, this probably does not need to be called out in the charter.

--Paul Hoffman, Director
--VPN Consortium

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 26 Aug 2010 11:41:31 -0400

> Fully agree that they should both be included and considered differently where appropriate. However, this probably does not need to be called out in the charter.

well, I disagree with that statement (no need to be called out in the 
charter). The two use-cases described are sufficiently different (and 
well-spread) that they influence many things in how HG are behaving. So 
I support the idea to include the difference in the charter to make 
crystal clear that both use-cases are different and need to be addressed.

I remember many years ago the distinction we use in ngtrans/v6ops for 
managed and unmanaged networks. it shows different protocols and needs. 
Similar to me here.

Marc.

-- 
=========
IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
DTN news service: http://reeves.viagenie.ca
NAT64-DNS64 Opensource: http://ecdysis.viagenie.ca