Subject: [homenet] secret sharing among devices

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Nov 2011 20:45:47 -0500

There have been various discussion in PHL about spreading a secret among
devices so they can authenticate each other.

A super cool idea is a specifically formatted file on a USB drive,
inserted into each system in turn.  While we might be pretty sure
the USB drive (and file system and connector, etc.) is out of scope, the
format for that secret file might be well in scope.

I'd like to suggest that the file format is in scope for the security
work, and would be willing to document such a thing.  (I actually think
the KEYPROV work can be readily adapted)

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 09:53:22 +0800

> the KEYPROV work can be readily adapted)

I definitely support this proposal.   :)

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2011 18:30:52 -0800

On 11/14/2011 5:45 PM, Michael Richardson wrote:
> format for that secret file might be well in scope

Doesn't that assume the device has a USB connector and can mount a stick 
as a drive? While that's common on PCs, it's not on home router boxes 
AFAICT. Many have no USB at all.

Joe

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 10:45:15 +0800

On Nov 15, 2011, at 10:30 AM, Joe Touch <[email-masked]> wrote:
> Doesn't that assume the device has a USB connector and can mount a stick as a drive? While that's common on PCs, it's not on home router boxes AFAICT. Many have no USB at all.

That's why mcr suggested that we not talk about what kind of device is used to share the file.   Actually, though, a lot of routers do have USB ports.   They also have ethernet ports, which is another way to peer hardware together.

---

From: Rene Struik <[email-masked]>
Date: Mon, 14 Nov 2011 21:47:34 -0500

Dear colleagues:

Could you elaborate about the security services and deployment
scenario(s) you wish to facilitate, for the benefit of those not at
IETF-82 who subscribe to the mailing list? In other words, what is the
problem one tries and solve here?

Best regards, Rene

On 14/11/2011 9:45 PM, Ted Lemon wrote:
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

-- 
email: [email-masked]
Skype: rstruik
cell: +1 (647) 867-5658
USA Google voice: +1 (415) 690-7363

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2011 18:53:07 -0800

On 11/14/2011 6:45 PM, Ted Lemon wrote:
> On Nov 15, 2011, at 10:30 AM, Joe Touch<[email-masked]>  wrote:

IMO, then explain the format of the key as an ASCII string. The file can 
then be described as the bare key.

Joe

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 10:55:32 +0800

> problem one tries and solve here?

We do not want, for example, for devices that aren't supposed to be routers to be routers.   By doing a manual key exchange, we can ensure that only devices that are intended to be part of the network topology have the keys that are required to join the routing infrastructure.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 10:56:55 +0800

On Nov 15, 2011, at 10:53 AM, Joe Touch <[email-masked]> wrote:
> IMO, then explain the format of the key as an ASCII string. The file can then be described as the bare key.

It's not just one key.   The point of the file is to allow the various devices to *exchange* keys.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Nov 2011 22:23:25 -0500

>>>>> "Joe" == Joe Touch <[email-masked]> writes:

    Joe> Doesn't that assume the device has a USB connector and can
    Joe> mount a stick as a drive? While that's common on PCs, it's not
    Joe> on home router boxes AFAICT. Many have no USB at all.

1) Joe, "the USB drive is out of scope".
   What matters is that you have some method to get the file into the
   device. How is less important. 

2) a USB port is increasing common on home routers, it's where you plug
   the printer in, or the 16G key or 1TB disk, as the home router
   provides NAS as well.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 14 Nov 2011 22:25:52 -0500

>>>>> "Ted" == Ted Lemon <[email-masked]> writes:
    >> IMO, then explain the format of the key as an ASCII string. The
    >> file can then be described as the bare key. 

    Ted> It's not just one key.   The point of the file is to allow the
    Ted> various devices to *exchange* keys. 

Maybe (it could be supported), but go read RFC6030, from it:

   This document defines a standardized XML-based key container, called
   Portable Symmetric Key Container (PSKC), for transporting symmetric
   keys and key-related metadata.  The document also specifies the
   information elements that are required when the symmetric key is
   utilized for specific purposes, such as the initial counter in the
   HMAC-Based One-Time Password (HOTP) [HOTP] algorithm.  It also
   creates an IANA registry for algorithm profiles where algorithms,
   their metadata and PSKC transmission profile can be recorded for a
   centralized, standardized reference.

so, basically, it's an ASCII file with some <>-based decoration of the
key itself.

---

From: Rene Struik <[email-masked]>
Date: Mon, 14 Nov 2011 22:27:16 -0500

Dear Ted:

Your note below (given by example) suggests a standardized physical
interface to be present on each device, suggests clairvoyance of
configuration decision elements, and procurement of devices from a
single source (or via a potentially expensive "work bench type"
installation/configuration approach).

What about making a list of deployment scenarios, and desired security
and usability behavior, expanding on the below?

Desired properties:
-Evidence regarding the true identity of a device (in casu: router vs.
neighbor's router);
-Evidence about fine-grained device role (in casu: router function,
motion sensor capability, etc.)
-Forward secrecy: compromised device does not compromise its entire past
history
[etc]

Questions:
-Homogeneous vs. heterogeneous trust domain?
-Trust lifecycle - what to do with device replacement, device
repurposing, change of controlling device, etc.?
-Trust initialization - how to provide initial privileged information to
the device?
-Device interface with surroundings: physical communication channel and
properties (e.g., location limited channel)?
[etc]

What would prevent an over-the-air provisioning model (reusing existing
infrastructure, e.g., ZigBee-type radio, powerline, etc.)? I can imagine
(depending on problem description) a 2c per device solution there,
without need for USB plugs, big files, etc.

Hence, my question: what is the problem to be solved here?

Best regards, Rene

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2011 19:44:53 -0800

On 11/14/2011 7:23 PM, Michael Richardson wrote:
>>>>>> "Joe" == Joe Touch<[email-masked]>  writes:

Agreed. That was my primary point.

>     the printer in, or the 16G key or 1TB disk, as the home router

Verizon doesn't include USB ports on their routers. YMMV, but Verizon is 
a fairly large home network provider.

Joe

---

From: "Stephen [kiwin] Palm" <[email-masked]>
Date: Mon, 14 Nov 2011 20:13:02 -0800

My phone cannot mount usb devices. Have nio interest to remove the sdcard
-------
Stephen [kiwin] Palm   Ph.D.                     W: http://www.kiwin.com
Senior Technical Director                             T: +1-949-926-PALM
           Broadcom - Broadband Communications Group 

----- Original Message -----
From: Joe Touch [mailto:[email-masked]]
Sent: Monday, November 14, 2011 07:44 PM
To: Michael Richardson <[email-masked]>
Cc: homenet <[email-masked]>
Subject: Re: [homenet] secret sharing among devices

Joe

---

From: Joel jaeggli <[email-masked]>
Date: Tue, 15 Nov 2011 12:25:25 +0800

plugging things into things seems like a rather short-sightt requirement
for a relationship.

joel

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 12:24:47 +0800

> My phone cannot mount usb devices. Have nio interest to remove the sdcard

Your phone almost certainly has  a USB interface, so actually it's one of the easier devices to configure.  It may be that it will not act as a USB host, but that's an easy problem.

---

From: "Stephen [kiwin] Palm" <[email-masked]>
Date: Mon, 14 Nov 2011 20:46:28 -0800

You miss the point: while phones certainly do have usb device capability - today they are not have host and today they do not accept the A connector - so they cannot accept a standard usb thumb drive - and market forces will keep it that way. 
-------
Stephen [kiwin] Palm   Ph.D.                     W: http://www.kiwin.com
Senior Technical Director                             T: +1-949-926-PALM
           Broadcom - Broadband Communications Group

---

From: "Stephen [kiwin] Palm" <[email-masked]>
Date: Mon, 14 Nov 2011 20:48:42 -0800

Agreed. Could be wireless or nfc. The file format won't help much if there are multiple ways it might (or might not) be transfered 
-------
Stephen [kiwin] Palm   Ph.D.                     W: http://www.kiwin.com
Senior Technical Director                             T: +1-949-926-PALM
           Broadcom - Broadband Communications Group 

----- Original Message -----
From: Joel jaeggli [mailto:[email-masked]]
Sent: Monday, November 14, 2011 08:25 PM
To: Stephen [kiwin] Palm
Cc: [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>
Subject: Re: [homenet] secret sharing among devices

joel

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2011 20:49:03 -0800

On 11/14/2011 8:24 PM, Ted Lemon wrote:
> On Nov 15, 2011, at 12:13 PM, "Stephen [kiwin] Palm"<[email-masked]>  wrote:

Phones are USB clients, not hosts - I don't think a client is required 
to supply power.

Joe

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 13:16:12 +0800

> You miss the point: while phones certainly do have usb device capability - today they are not have host and today they do not accept the A connector - so they cannot accept a standard usb thumb dri…

No I didn't miss the point, please don't assume I am stupid.   Your phone has a USB device.   Therefore there is a physical medium of exchange for the file we are talking about.   True, the medium of exchange is not a thumb drive, but it could be for example that you plug your phone *in* to your router, or something.   We are talking about what the file would look like, not how the devices are connected.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 13:19:56 +0800

> plugging things into things seems like a rather short-sightt requirement

I will resist the obvious rejoinder.  And no, it is not short-sighted.   Assuming that physical user interfaces are likely to become obsolete in favor of something else is simply not consistent with reality.   Physical UIs are easy to understand.   Making someone go to a configuration page on your router is hard to understand.   I think in fact that one of the reasons we fail in security on the Internet is precisely that we fail to understand how people interact with UIs, and design protocols that require UIs with which most people cannot successfully interact.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 13:21:22 +0800

On Nov 15, 2011, at 12:49 PM, Joe Touch <[email-masked]> wrote:
> Phones are USB clients, not hosts - I don't think a client is required to supply power.

Right, which means you have to plug it into a USB host device.   What's your point?

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2011 21:20:09 -0800

On 11/14/2011 9:16 PM, Ted Lemon wrote:
> On Nov 15, 2011, at 12:46 PM, "Stephen [kiwin] Palm"<[email-masked]>  wrote:
> No I didn't miss the point, please don't assume I am stupid. Your
> phone has a USB device. Therefore there is a physical medium of exchange
> for the file we are talking about. True, the medium of exchange is not a
> thumb drive, but it could be for example that you plug your phone *in*
> to your router, or something. We are talking about what the file would
> look like, not how the devices are connected.

I see - you are presuming the phone acts as the thumb drive.

I think we're thinking the phone is the router (ala tethering). In that 
case, there needs to be a way to plug the USB stick into the phone, 
which can't happen (since the phone draws power off the USB, rather than 
delivering it). If the USB were self-powered, it *might* work, but I've 
never seen such a thing.

Joe

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Mon, 14 Nov 2011 21:27:26 -0800

On 11/14/2011 9:16 PM, Ted Lemon wrote:
> No I didn't miss the point, please don't assume I am stupid.

but many users essentially are!

 > We are talking about what the file would look like, not how the devices are connected.

How the devices connect is an essential part of the user interaction.
If we ask users or manufacturers to do something unnatural - they won't

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 13:32:23 +0800

On Nov 15, 2011, at 1:20 PM, Joe Touch <[email-masked]> wrote:
> I think we're thinking the phone is the router (ala tethering). In that case, there needs to be a way to plug the USB stick into the phone, which can't happen (since the phone draws power off the USB, rather than delivering it). If the USB were self-powered, it *might* work, but I've never seen such a thing.

That would be pretty cool, but that's not what I'm talking about.   The reason we are not saying "thumb drive" is because it may not be the right medium of exchange.   It's a good example of a viable medium of exchange, but it's certainly not the only possible one.   I would expect each device to have a copy of the file that's on the thumb drive.   If your device is not a USB host, you would plug it into a device that is a USB host, and the file exchange would proceed.

It's also possible that it might make sense to use some other medium of exchange that's not USB at all.   For example, routers with ethernet ports can simply be connected together, and there you have a physical link.   But for a wireless device with no ethernet ports, that's not an option.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 13:33:25 +0800

> If we ask users or manufacturers to do something unnatural - they won't

Oh yes, we are in violent agreement on this point!

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 15 Nov 2011 00:42:45 -0500

> We do not want, for example, for devices that aren't supposed to be routers to be routers.   By doing a manual key exchange, we can ensure that only devices that are intended to be part of the netw…

How do we explain to "the typical home user" what a router is, how to decide whether a given thing is one, and how to (in all cases) get the Magic Key onto it?  In other words, when you say "are intended," who is doing the intending?

Lee

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Joel jaeggli <[email-masked]>
Date: Tue, 15 Nov 2011 13:43:56 +0800

On 11/15/11 13:19 , Ted Lemon wrote:
>> plugging things into things seems like a rather short-sightt
>> requirement for a relationship.
> 
> I will resist the obvious rejoinder.  And no, it is not
> short-sighted.   Assuming that physical user interfaces are likely to
> become obsolete in favor of something else is simply not consistent
> with reality. 

A decade and a half worth of bluetooth security associations including
really bad ones says otherwise.

Personal devices by in large are shedding data-ports where possible and
especially for low speed interaction.

> Physical UIs are easy to understand.   Making someone
> go to a configuration page on your router is hard to understand. 

And I see that as a usable outcome, as rather unlikely.

>  I
> think in fact that one of the reasons we fail in security on the
> Internet is precisely that we fail to understand how people interact
> with UIs, and design protocols that require UIs with which most
> people cannot successfully interact.

As a consumer I want to bring the thing home, turn it on, and have it work.

> _______________________________________________ homenet mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/homenet
>

---

From: Mark Andrews <[email-masked]>
Date: Tue, 15 Nov 2011 16:44:40 +1100

In message <[email-masked]>, Joe Touch writes:
> >> You miss the point: while phones certainly do have usb device capability - today they are 
> not have host and today they do not accept the A connector - so they cannot accept a standard
>  usb thumb drive - and market forces will keep it that way.
> >

It really doesn't matter what it is.

A MicroSD card would be fine for this.  Lots of cell phones already
have MicroSD slots.  The MicroSD card can be put in a USB card
reader for USB based machines possibly using a SD card adaptor.  A
MicroSD card can be put in a SD card adaptor for SD based devices.

Pop the existing card out of the phone.  Plug it into a card reader
and that into the router.  The router updates the key ring.  You
plug the SD card back into the phone and the phone and router can
now play.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2011 21:57:42 -0800

On 11/14/2011 9:44 PM, Mark Andrews wrote:
...
> have MicroSD slots.

Not iPhones ;-)

I agree with Joel - Bluetooth is fine too. But the broader point is not 
to get hung up on the method of file transfer, but rather the info in 
the file.

Joe

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 14:07:32 +0800

> How do we explain to "the typical home user" what a router is, how to decide whether a given thing is one, and how to (in all cases) get the Magic Key onto it?  In other words, when you say "are in…

Presumably a device that's intended to work in a homenet environment will understand what's on the key, and a device that isn't won't, so it's a non-issue.   Just plug it into every device you want to connect to the network.   Actually, devices that are leaf nodes can benefit from this too.

The point here is that you _won't_ plug it into a device that you _don't_ want connected to your network.

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 15 Nov 2011 01:12:18 -0500

> The point here is that you _won't_ plug it into a device that you _don't_ want connected to your network.

Ah, I thought you were trying to distinguish routers from hosts, where "hosts" don't have the magic in them.

FWIW, the most common boxes I see have two or more Ethernet ports and some Wi-Fi.  I don't want to pay for another interface, especially if it's intended to be one-time use.  So, if in-line is the only method one has for putting the Magic Key on the device, are we talking about (t)FTP?  That doesn't sound easier than a GUI to me.  Or do we need to describe or find another method for Magic Key discovery and retrieval?

Lee

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 14:14:05 +0800

> really bad ones says otherwise.

Yes, and the reason it works is because for most devices, there is no security, and for the remaining devices, there's a screen that can give you instructions.   Have you ever owned a bluetooth headset that didn't have a PIN of 0000?

> especially for low speed interaction.

Maybe so.   Do you expect the iPad three to get rid of its USB port?   What about my next Android phone?   If your point is that networks are increasingly going to be wireless-only, with no means of plugging a physical token into the device, then yes, I agree, we can't solve this problem for those devices.   Either they aggressively autoconfigure, and form networks that shouldn't have been formed, or they are configured manually, by grandma's grandson.

> And I see that as a usable outcome, as rather unlikely.

No offense, but I don't really care what your opinion is.   What I care about is what actually happens.   It may be that you are right, but if so, then I don't really think we can solve this problem.

> As a consumer I want to bring the thing home, turn it on, and have it work.

As a consumer, I want it to strew flowers at my feet as I walk into the house, and clean them up afterwards.   What you want as a consumer is probably more possible than what I want, but what you will get will be a system that has some really bad failure modes.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 14:15:13 +0800

> Not iPhones ;-)

iPhones have USB interfaces.

---

From: Joe Touch <[email-masked]>
Date: Mon, 14 Nov 2011 22:24:53 -0800

On 11/14/2011 10:15 PM, Ted Lemon wrote:
> On Nov 15, 2011, at 1:57 PM, Joe Touch<[email-masked]>  wrote:
>> Not iPhones ;-)
>

iPhones are (or can be) routers.

iPhones have no microSD.

iPhones have a USB port that does not supply power.

Yes, bluetooth might be a way to get data into the phone (not sure if 
IOS supports the full bluetooth spec this way, though). But you can't 
plug a USB stick into it (even with a physical adapter), and you can't 
plug a SD of any sort into it.

Joe

---

From: Mark Andrews <[email-masked]>
Date: Tue, 15 Nov 2011 17:45:17 +1100

> plug a SD of any sort into it.

The iPhone is its own thumb drive.

---

From: Joel jaeggli <[email-masked]>
Date: Tue, 15 Nov 2011 14:46:09 +0800

On 11/15/11 14:14 , Ted Lemon wrote:
>> A decade and a half worth of bluetooth security associations
>> including really bad ones says otherwise.
> 
> Yes, and the reason it works is because for most devices, there is no
> security, 

It's more concise to describe them as offering no MITM protection. The
association is either the product of a predefined shared secret (which
isn't secret) or after bluetooth 2.1 by SSP. the intent to pair in
either case is deliberately initiated.

> and for the remaining devices, there's a screen that can
> give you instructions.   Have you ever owned a bluetooth headset that
> didn't have a PIN of 0000?

yes but that was 1998 and it wasn't the most usable device ever.

>> Personal devices by in large are shedding data-ports where possible
>> and especially for low speed interaction.
> 
> Maybe so.   Do you expect the iPad three to get rid of its USB port?

I expect that devices like the i*/and* as well as other consumer
electronics that are moving onto the network (like televisions speakers
and so forth) will continue to down the road towards shedding their
dependance on tethering to each in a physical fashion. when that happens
precisely is a business decision on the part of their manufacturers and
the suppliers of the application stack and the supporting  accoutrements.

...

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 15:17:35 +0800

> iPhones have a USB port that does not supply power.

Right, we already covered this. You plug them into a USB host device. If you believe this is impractical, okay, but you never expressed that position.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 15:21:25 +0800

> either case is deliberately initiated.

Sure. But because the PIN is fixed, accidental pairing is quite possible.

> the suppliers of the application stack and the supporting  accoutrements.

I think it's pointless to try to predict Apple's product strategy ten years out.  For the moment, their connector seems pretty stable. Of course, iPhones have a UI, so perhaps this point is moot anyway. It's devices that don't have a UI that are the problem.

---

From: Hans Liu <[email-masked]>
Date: Tue, 15 Nov 2011 15:55:00 +0800

I believe less then 50% home routers have a USB port.

Sincerely,
Hans

On Tue, Nov 15, 2011 at 10:30 AM, Joe Touch <[email-masked]> wrote:
> Doesn't that assume the device has a USB connector and can mount a stick as
> a drive? While that's common on PCs, it's not on home router boxes AFAICT.
> Many have no USB at all.
>
> Joe

-- 
Instead of following the fashion, we lead it through.

---

From: Joe Touch <[email-masked]>
Date: Tue, 15 Nov 2011 00:22:37 -0800

On 11/14/2011 11:17 PM, Ted Lemon wrote:
> On Nov 15, 2011, at 2:24 PM, Joe Touch<[email-masked]>  wrote:
> Right, we already covered this. You plug them into a USB host
> device.If you believe this is impractical, okay,
 > but you never expressed that position.

Then let me specify the case:

- verizon home network (no USB on my home router)
- iPhone and iPad (USB clients, but not hosts)
- no PC (use the iCloud service)

Yes, I can exchange files over the iCloud or with bluetooth.

However, the idea of USB as sneakernet is like a stone and chisel already.

Joe

---

From: Robert Cragie <[email-masked]>
Date: Tue, 15 Nov 2011 08:45:26 +0000

Is it really that important to specify USB or even a file format here? The
aim is to get a pre-shared key into devices. The underlying cipher suite
will determine the basic size of the key. There may be additional services
to allow the use of a passphrase in conjunction with a hash to generate the
key. How that key/passphrase gets into the device - is this a concern for
the IETF, considering that there are many different ways to physically do
this (e.g. WPS specifies four mechanisms)?

Robert

On Tue, Nov 15, 2011 at 8:22 AM, Joe Touch <[email-masked]> wrote:

> ______________________________**_________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/homenet<https://www.ietf.org/mailman/listinfo/homenet>
>

-- 

Robert Cragie

Gridmerge Ltd.
89 Greenfield Crescent,
Wakefield, WF4 4WA, UK
+44 1924 910888
+1 415 513 0064
http://www.gridmerge.com

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 16:59:16 +0800

On Nov 15, 2011, at 4:45 PM, Robert Cragie <[email-masked]> wrote:
> Is it really that important to specify USB or even a file format here?

What mcr originally proposed was that we define a file format. USB is an example of how the file old be exchanged.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 17:03:20 +0800

> - no PC (use the iCloud service)
So, one router. 

> However, the idea of USB as sneakernet is like a stone and chisel already.

I agree in principal, but how do you get your Verizon router to join a homenet then?   It has no UI!   If we support this configuration, it means that we have no protection against unintentional router pairing. I don't think that's acceptable.

---

From: Joe Touch <[email-masked]>
Date: Tue, 15 Nov 2011 01:10:39 -0800

On 11/15/2011 1:03 AM, Ted Lemon wrote:
> On Nov 15, 2011, at 4:22 PM, Joe Touch<[email-masked]>  wrote:

Two that could be used independently (separately) or possibly even 
together. E.g., the following seems entirely reasonable:

	iPad connected as a host

	iPhone as the router gatewayed to 3G
	verizon box as the router gatewayed to DSL

> I agree in principal, but how do you get your Verizon router to join
> ahomenet then? It has no UI!

I'll remember that next time I login using the iPad to alter its config ;-)

> If we support this configuration, it means
> that we have no protection against unintentional router pairing. I don't
> think that's acceptable.

I could upload files to the verizon box over WiFi as I do right now for 
other files (including firmware updates).

Joe

---

From: Robert Cragie <[email-masked]>
Date: Tue, 15 Nov 2011 09:35:21 +0000

On Tue, Nov 15, 2011 at 8:59 AM, Ted Lemon <[email-masked]> wrote:

> What mcr originally proposed was that we define a file format. USB is an
> example of how the file old be exchanged.

Exactly, so why all the conversation about USB? This is the domain of
Wi-Fi/ZigBee/HomePlug/UPnP/DLNA, not really the IETF, IMHO.

Robert

---

From: Ray Bellis <[email-masked]>
Date: Tue, 15 Nov 2011 09:42:44 +0000

On 15 Nov 2011, at 17:35, Robert Cragie wrote:

Exactly, so why all the conversation about USB? This is the domain of Wi-Fi/ZigBee/HomePlug/UPnP/DLNA, not really the IETF, IMHO.

<chair hat="on">

Yes, let's please *not* rathole down the actual exchange mechanism.

</chair>

Ray

---

From: Thomas Herbst <[email-masked]>
Date: Tue, 15 Nov 2011 02:40:46 -0800

Ignoring the transfer mechanism for a moment, why would a home networking
vendor put this on their products?

Support costs are huge in this market.
In a previous job, I was told that support calls with the home router
still in the shrink wrap were about 20% of units sold.
The first call kills all margin, on the second call the vendor has lost
money by selling the product.
Implementing "features" that increase support calls is a very fast way to
be fired.

We should try to stay focused on features that have some chance of being
implemented.

tom

On 11/14/11 5:45 PM, "Michael Richardson" <[email-masked]> wrote:

>   Kyoto Plus: watch the video
><http://www.youtube.com/watch?v=kzx1ycLXQSE>
>	               then sign the petition.
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 19:13:23 +0800

> I'll remember that next time I login using the iPad to alter its config ;-)

IETF geeks are not the target end user!   :)

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 19:19:40 +0800

> vendor put this on their products?

The point of it is to prevent problems that would otherwise occur.   For any home router that has hard-wired ethernet ports, we already have a potential solution to this problem that prevents accidental network merges, although I guess we'd have to talk someone in the IEEE into putting forth the actual 802.xxx protocol that would do what we need.

The point is that two devices that haven't physically touched somehow hadn't ought to automatically form a network together.   Believe me, if they do, that'll generate plenty of support calls.

---

From: Randy Turner <[email-masked]>
Date: Tue, 15 Nov 2011 04:10:50 -0800

+(n).  ;)

---

From: Joe Touch <[email-masked]>
Date: Tue, 15 Nov 2011 04:18:28 -0800

On 11/15/2011 3:13 AM, Ted Lemon wrote:
> On Nov 15, 2011, at 5:10 PM, Joe Touch<[email-masked]>  wrote:

IETF geeks aren't the only ones who login to home routers - that's why 
they have web interfaces. Most of the access points in my neighborhood 
all have non-default SSIDs, as a point of reference (and I live in a 
non-tech city).

Joe

---

From: Thomas Herbst <[email-masked]>
Date: Tue, 15 Nov 2011 05:48:19 -0800

Like wifi protected setup? Push button, pass phrase, near field coms and usb stick, recently reduced to push button and pass phrase. 

Not an ietf thing.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 Nov 2011 08:53:47 -0500

>>>>> "Stephen" == Stephen Palm <Stephen> writes:
    Stephen> My phone cannot mount usb devices. Have nio interest to
    Stephen> remove the sdcard 

what's your point?  I wonder if you even read the thread?

Are you saying that your phone is smart (and open) enough to run zOSPF
(mine is), yet can never transfer files at all?   Mine could trivially
scan a QRcode displayed on a laptop screen and do something interesting
with a secret stored in that.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 Nov 2011 09:27:30 -0500

>>>>> "Ted" == Ted Lemon <[email-masked]> writes:
    Ted> It's also possible that it might make sense to use some other
    Ted> medium of exchange that's not USB at all.   For example,
    Ted> routers with ethernet ports can simply be connected together,
    Ted> and there you have a physical link.   But for a wireless device
    Ted> with no ethernet ports, that's not an option. 

Let's talk about the ethernet port exchange here, lest someone get
unduly excited.  Let's understand the benefit / risk / threat.

To make this really secure, you need to do something that can't be bridged,
because if it can be easily bridged, then it can be MITM'ed sent over wifi,
encapsulated into GRE, etc.   

I think really having physical access is important, and it should take
more than a compromised PC with a hardwire to the router to easily do
the transfer, stealing the key remotely for later use.  

I think that this means something like:
  a) using additional symbols at the MII/MLT-3 layer.
  b) playing with PoE drive levels to confirm
  c) near-simultaenous pushing of an out-of-band button.
  d) maybe simultaenous use of wifi (at extremely low power).
  e) using the ethernet cabling in an entirely different fashion
     (e.g. turning it into RS232...)
  f) maybe something LLDP/CDP 
  g) 802.1ag / 802.3ah can do these things...

I do not propose the IETF standardize anything like this, just the
contents which are eventually transfered.

It's clearly the domain of the IEEE, but a single vertically integrated
vendor who has control (or significant influence) right down to the PHY
could easily innovate within their product line, while still
interoperating

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 Nov 2011 09:34:58 -0500

>> but you never expressed that position.

    Joe> Then let me specify the case:

    Joe> - verizon home network (no USB on my home router)
    Joe> - iPhone and iPad (USB clients, but not hosts)
    Joe> - no PC (use the iCloud service)

Tell me again why you need homenet on such a simple network?

---

From: Joe Touch <[email-masked]>
Date: Tue, 15 Nov 2011 13:48:36 -0800

> Tell me again why you need homenet on such a simple network?

So my iPad (and/or anything else in the house) can use either the 
verizon path or the iPhone path to the Internet with automatic routing.

If it's too simple, add other routers that still don't have USBs or cameras.

Joe

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Nov 2011 06:52:31 +0800

> Like wifi protected setup? Push button, pass phrase, near field coms and usb stick, recently reduced to push button and pass phrase.

Into which router do you type he pass phrase?   How?

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 Nov 2011 18:51:15 -0500

>> Tell me again why you need homenet on such a simple network?

    Joe> So my iPad (and/or anything else in the house) can use either
    Joe> the verizon path or the iPhone path to the Internet with
    Joe> automatic routing. 

At this point, it is still a flat LAN with two exit paths.
It's also WIFI. If it was secured WIFI, then you already entered keys
into all devices, so actually, we are probably done.

So, it's not secured WIFI.  The network is open.  Should we have any
security enabled at all then?

    Joe> If it's too simple, add other routers that still don't have
    Joe> USBs or cameras. 

I agree that it's a problem, but it's not clear to me that it's a real
problem.  I think that USB ports are becoming ubiquitous.