Subject: [homenet] another routing option

From: "Howard, Lee" <[email-masked]>
Date: Wed, 2 Nov 2011 10:36:30 -0400

I've said that I don't think we need a full dynamic routing protocol.  There are other options for discovering an available path.  To stimulate creative thinking, I've written a draft proposing one alternative that should be light to implement in home gateways: http://www.asgard.org/images/draft-howard-up-pio-00.txt
If it is interesting, there's more work to be done on it; I could publish it after the pre-meeting publication blackout ends.

Lee

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Ole Troan <[email-masked]>
Date: Wed, 2 Nov 2011 17:46:12 +0100

Howard,

> If it is interesting, there's more work to be done on it; I could publish it after the pre-meeting publication blackout ends.

aren't you in the end just going to reinvent RAs as a distance vector routing protocol...?

cheers,
Ole

---

From: "Howard, Lee" <[email-masked]>
Date: Wed, 2 Nov 2011 17:55:05 -0400

> -----Original Message-----
> From: Ole Troan [mailto:[email-masked]]
> Sent: Wednesday, November 02, 2011 12:46 PM
> To: Howard, Lee
> Cc: [email-masked] Group
> Subject: Re: [homenet] another routing option
>
> Howard,
>
> > I've said that I don't think we need a full dynamic routing protocol.  There are other
> options for discovering an available path.  To stimulate creative thinking, I've written a draft
> proposing one alternative that should be light to implement in home gateways:
> http://www.asgard.org/images/draft-howard-up-pio-00.txt

I wanted to debate the point, but I have to conced it.  Yes, that's pretty much true.

Lee

---

From: Jari Arkko <[email-masked]>
Date: Thu, 03 Nov 2011 00:16:53 +0200

Thanks for writing this up, Howard.

And I think all options should be on the table. That being said, my #1 option for routing was actually RIP, because the code was already on many boxes. I also like OSPF, because it is in theory more robust and works in pretty much under all circumstances.

There has been a series of proposals over the years on using router advertisements for simple default routing. Look for "MANEMO" from the archives, for instance. There are a number of possible designs, from the very simple design that can't even take a look to a full-blown routing protocol carried in RAs. We didn't take that work up for variety of reasons at the time, including some resistance on overloading RAs for other purposes.

Using RAs is certainly a possible approach, though I would probably prefer to just use RIP if "simple" is our guideline, because ultimately that would lead to less new protocols and at least in some cases less new code. Just my opinion, of course.

Jari