Subject: [homenet] pervasive v4

From: Brian E Carpenter <[email-masked]>
Date: Tue, 15 Nov 2011 14:42:30 +1300

If homenet is going to support arbitrary self-configuring topologies,
and pervasive legacy IPv4 is required, we'd surely end up recommending
NAT444-within-the-home as the only remotely practicable approach.
But any such approach would bring in many problems that appear to be
deeply insoluble for IPv4. iirc that was one of the reasons that IPv6
was designed the way it is.

I think we have to recognise that the IPv4 constraint can only apply to
the very simplest homenet topologies.

-- 
Regards
   Brian Carpenter

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 14 Nov 2011 17:50:30 -0800

> was designed the way it is.

Brian,

NAT444 doesn't work in an arbitrary topology since you can end up with 
loops through the NATs, and the WG seems to want to support arbitrary 
topologies.

But using whatever prefix assignment method we come up with for IPv6 to 
also hand out subnets out of 192.168/16 works just fine; do NAT44 in the 
customer edge router and route IPv4 (and IPv6) inside the home (using 
whatever routing protocol we choose to route IPv6.

    Erik

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 15 Nov 2011 15:19:26 +1300

> loops through the NATs, and the WG seems to want to support arbitrary

Right... we could always invent a spanning tree protocol for NAT of course :-).

> whatever routing protocol we choose to route IPv6.

Yes, but then we're extending v4 and expecting homenets to run (presumably) RIP.
That seems kind of out of scope for this WG.

   Bria

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 14 Nov 2011 19:04:41 -0800

> Yes, but then we're extending v4 and expecting homenets to run (presumably) RIP.

Why RIP? Same protocol between the home routers as we will pick for 
routing IPv6 in the home.

> That seems kind of out of scope for this WG.

I think it is an implication of 1) supporting arbitrary topologies and 
2) not breaking IPv4. Thus I don't see a different choice for an 
arbitrary topology routed home network.

    Erik

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 15 Nov 2011 16:27:23 +1300

> routing IPv6 in the home.

Well, my understanding is that RIP is to be found already on
supermarket home routers. I'm assuming that we aren't asking them
to touch their IPv4 code.

There's no reason that I know why a homenet can't run RIP and OSPFv3
simultaneously.

> arbitrary topology routed home network.

I am not convinced that 1) AND 2) is feasible without creating a mountain
that is impossible to climb. Supporting topologies that are *already*
possible with v4, maybe. But why shouldn't the kids' bedroom be IPv6-only
even if Grandma must have IPv4?

    Brian

---

From: Lorenzo Colitti <[email-masked]>
Date: Tue, 15 Nov 2011 13:42:03 +0800

> NAT444-within-the-home as the only remotely practicable approach.

Hans from D-Link suggests that another option is simply to bridge IPv4
packets and route IPv6 packets.

---

From: Lorenzo Colitti <[email-masked]>
Date: Tue, 15 Nov 2011 13:49:07 +0800

> routing IPv6 in the home.

The primitives you have to configure and renumber IPv6 hosts (multiple
addresses, multiple RAs and address deprecation, and so on) are different
from the ones we have in IPv4 (essentially, DHCPv4 and NAT).

So I don't think we will be able to take what we do in IPv6 and apply it
as-is to IPv4. Instead, I think we'll have to either NAT everywhere (like
we do today) or bridge everywhere.

---

From: Joel jaeggli <[email-masked]>
Date: Tue, 15 Nov 2011 13:58:50 +0800

On 11/15/11 13:49 , Lorenzo Colitti wrote:
> On Tue, Nov 15, 2011 at 11:04, Erik Nordmark <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
> addresses, multiple RAs and address deprecation, and so on) are
> different from the ones we have in IPv4 (essentially, DHCPv4 and NAT).
> 
> as-is to IPv4. Instead, I think we'll have to either NAT everywhere
> (like we do today) or bridge everywhere.

the consumer routinely ends up with double nats today, that's hardly
ideal, but it works for the most part. it doesn't seem likely to get
better esp as it involves the support of legacy devices.

> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 15 Nov 2011 19:05:41 +1300

> packets and route IPv6 packets.

Iff the bridges support the spanning tree, yes.

  Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 15 Nov 2011 19:11:26 +1300

And if the user plugs and plays this:

       WAN
        |
     [NAT44]
        |
-------------------
   |           |
[NAT44]     [NAT44]
   |           |
-------------------

what happens? Please script the help desk call.

    Brian

---

From: Joel jaeggli <[email-masked]>
Date: Tue, 15 Nov 2011 14:17:41 +0800

> And if the user plugs and plays this:

Your exit to the upper element is dependent on which dhcp server answers
first...

if you have an address collision well, you're screwed...

        WAN
         |
      [NAT44]
         |
 -------------------
    |     |      |
 [NAT44]  |   [NAT44]
    |     |      |
 -------------------

seen that too...

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 14:20:21 +0800

> better esp as it involves the support of legacy devices.

This is sort of true, although cascaded NATs do cause some problems.   But if we can specify it out of dual-stack devices, I think that would be a win.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 Nov 2011 14:19:10 +0800

On Nov 15, 2011, at 1:42 PM, Lorenzo Colitti <[email-masked]> wrote:
> Hans from D-Link suggests that another option is simply to bridge IPv4 packets and route IPv6 packets.

If this were part of the homenet requirements, I would be pretty happy with that.   We'd need to deal with the case where the CPE device is bridged to the provider network, though, rather than routed.

---

From: Hans Liu <[email-masked]>
Date: Tue, 15 Nov 2011 16:10:04 +0800

On Tue, Nov 15, 2011 at 1:42 PM, Lorenzo Colitti <[email-masked]> wrote:
> On Tue, Nov 15, 2011 at 09:42, Brian E Carpenter
> <[email-masked]> wrote:
>>

To be very honest, if you have two D-Link router at home, you put one
after another, it won't work today. I believe the problem is quite
general a case to many NAT boxes today since they all share
192.168.0.0/24 or 192.168.1.0/24.  So what I told Lorenzo is that, in
that case I would like to disable NAT and route IPv6.

Regards,
Hans

---

From: Jim Gettys <[email-masked]>
Date: Tue, 15 Nov 2011 07:59:10 -0500

> that case I would like to disable NAT and route IPv6.

Some automatically switch addresses in this case.

Jim

---

From: Ray Hunter <[email-masked]>
Date: Tue, 15 Nov 2011 14:30:56 +0100

Exactly the same as today (before Homenet), so presumably they have that 
helpdesk script already.

If you could bridge IPv4 everywhere (as Lorenzo suggested as a 
possibility) one bridge would go into standby mode and it would all just 
work. A tree of NAT44's on all devices will also work just too (as today).

If you start mixing bridging IPv4 with NAT44: that'll be very nasty. 
Ditto mixing autoconfig IPv4 routers and NAT44.

IMHO In the absence of a reliable Homenet topology detection and 
configuration protocol you'd better stick with NAT44 everywhere. This 
has a huge advantage of being backwards compatible with existing devices 
(not unimportant).  Downside is that you have to print a warning on the 
box that arbitrary topologies are not allowed whilst you are still 
running IPv4: just trees.

regards,
RayH

Brian E Carpenter wrote:
>>> On Tue, Nov 15, 2011 at 11:04, Erik Nordmark<[email-masked]

---

From: Acee Lindem <[email-masked]>
Date: Tue, 15 Nov 2011 08:49:47 -0500

+1 

On Nov 15, 2011, at 12:49 AM, Lorenzo Colitti wrote:

> Why RIP? Same protocol between the home routers as we will pick for routing IPv6 in the home.
> 
> The primitives you have to configure and renumber IPv6 hosts (multiple addresses, multiple RAs and address deprecation, and so on) are different from the ones we have in IPv4 (essentially, DHCPv4 and NAT).
> 
> So I don't think we will be able to take what we do in IPv6 and apply it as-is to IPv4. Instead, I think we'll have to either NAT everywhere (like we do today) or bridge everywhere.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Nov 2011 12:52:36 +1300

As Ray said: if it's broken today with v4, it will still be broken
even if the boxes are running IPv6 routing. But afaik this isn't
the 'make IPv4 work better' WG. That means that the requirement
to not break IPv4 actually constrains the possible topologies
for IPv6. I think we have to suck that up.

Regards
   Brian

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Nov 2011 08:09:58 +0800

On Nov 16, 2011, at 7:52 AM, Brian E Carpenter <[email-masked]> wrote:
> But afaik this isn't
> for IPv6.

This was definitely not the sense of the working group in the meeting.   The sense of the working group was "if the IPv6 topology works, but the IPv4 topology doesn't, oh well."   The consensus seemed to be that it was better to make IPv6 work well than to constrain the solution so that topologies in which IPv4 wouldn't work would also break IPv6 (which, let's be clear, is essentially what you are suggesting).

Having said that, if there's a way to make IPv4 topologies that either don't work, or work poorly, with a modern IPv4 NAT router, work well with a homenet router, and it's possible to get that essentially for free, then I think it's worth getting, even though that's certainly not the problem we've set out to solve.   And I think what a couple of people have been saying here (with which I agree) is that it is in fact possible to get this essentially for free.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Nov 2011 13:25:59 +1300

> This was definitely not the sense of the working group in the meeting.   The sense of the working group was "if the IPv6 topology works, but the IPv4 topology doesn't, oh well."   The consensus see…

My statement was intended to be conditional, but doesn't quite read that way.

However, I suspect that the average user won't be happy if IPv6 works in
the bedroom but IPv4 doesn't, so I'm not sure the consensus you mention will
hold in the market.

> Having said that, if there's a way to make IPv4 topologies that either don't work, or work poorly, with a modern IPv4 NAT router, work well with a homenet router, and it's possible to get that esse…

Yes, but I'd like to see it described in terms of real products, not
what is theoretically possible.

   Brian

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Nov 2011 08:55:05 +0800

> the bedroom but IPv4 doesn't, so I'm not sure the consensus you mention will

Why would the average user even notice that IPv4 is broken?   But yes, if they would notice, then it would be good if it weren't broken.

> what is theoretically possible.

If by real products, you mean things you can buy today, I don't agree, but if you mean that homenet gateways ought to not break IPv4, I certainly agree.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Nov 2011 14:00:16 +1300

> If by real products, you mean things you can buy today, I don't agree, but if you mean that homenet gateways ought to not break IPv4, I certainly agree.

What will happen if a user hangs an existing v4-only box bought in the supermarket
off a new homenet-conforming box? I'm not saying we have to guarantee that
it works, but at least we need to understand the possible breakages (IMHO).

   Brian

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Nov 2011 09:07:52 +0800

> it works, but at least we need to understand the possible breakages (IMHO).

Sure.   In point of fact, it will work just as well as if they did the same thing with a non-homenet-conforming box, and possibly better.   In some cases that means it will work; in some cases it means it will not.   IOW, homenet won't make things worse.   So it's hard to accept the notion that, in the event that IPv4 breaks in this case, IPv6 ought to break as well.   Of course, since this is a non-homenet router, possibly it doesn't support IPv6 anyway.

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 15 Nov 2011 21:06:08 -0500

> Sure.   In point of fact, it will work just as well as if they did the same thing with a non-homenet-conforming box, and possibly better.   In some cases that means it will work; in some cases it m…

I agree with this.  Something breaking in IPv4 does not mean it should break in IPv6.
My reading of our charter is that we must not break IPv4 in order to get IPv6 to work, but that doesn't mean  that IPv6 goodness can't be a superset of IPv4 goodness.

Lee

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 15 Nov 2011 21:31:30 -0800

> My reading of our charter is that we must not break IPv4 in order to get IPv6 to work, but that doesn't mean  that IPv6 goodness can't be a superset of IPv4 goodness.

If we want to address the consumer expectations about ease of use yet 
deliver more capable home networks, then I think we need to be aware of 
the total complexity of the home network.

A network where both IPv4 and IPv6 are used, yet the topology for the 
inside the home is different, significantly increases the complexity.

The service call will be something like "the internet is working fine, 
but the printer is broken" when the laptop uses dual-stack but the 
printer is IPv4 only.

I uniformity (within the home) is better if we care about complexity.

Regards,
    Erik

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Nov 2011 14:29:16 +0800

On Nov 16, 2011, at 1:31 PM, Erik Nordmark <[email-masked]> wrote:
> The service call will be something like "the internet is working fine, but the printer is broken" when the laptop uses dual-stack but the printer is IPv4 only.
> 

This is certainly a valid point, but you've got it backwards, since we're talking about bridging IPv4.  The real risk is that a bonjour printer will work only if you are plugged into the same router it is.

---

From: Randy Turner <[email-masked]>
Date: Tue, 15 Nov 2011 22:35:44 -0800

Good points...Speaking of Bonjour, I haven't seen many references to support for multicast (yet)...I'm assuming this is on the plate.

Randy

---

From: Ray Bellis <[email-masked]>
Date: Wed, 16 Nov 2011 06:39:38 +0000

> Good points...Speaking of Bonjour, I haven't seen many references to support for multicast (yet)...I'm assuming this is on the plate.

Yes, it was one of the topics of discussion at the interim, mostly in the context of naming and service discovery.  There hasn't really been any discussion on the use of multicast as a high bandwidth streaming system.

Ray

---

From: Fred Baker <[email-masked]>
Date: Wed, 16 Nov 2011 17:20:04 +0800

On Nov 15, 2011, at 1:42 PM, Lorenzo Colitti wrote:

> On Tue, Nov 15, 2011 at 09:42, Brian E Carpenter <[email-masked]> wrote:

That's what some routers do to provide IPv6 and IPv4 in parallel from an ISP. If you start from the assumption, very clearly stated in the architecture draft, that one might want to route within the home (for example to pull A/V on one path and data, smart grid, or other services on another), that's side-stepping the discussion.

We could, for example, simply bridge throughout a data center. It would get packets there. Put all the tenants on the same LAN. Oh, there are problems? Hmmm, hadn't thought of that.