Subject: [homenet] For information: Announced new draft on MIF WG: draft-kaiser-if-sel-00

From: Arnaud Kaiser <[email-masked]>
Date: Tue, 18 Jun 2013 15:25:59 +0200

Dear participants to homenet group,

We submitted "Interface Selection Mechanism for Multiple Interfaces IPv6 
Hosts" draft-kaiser-if-sel-00 available at:
http://tools.ietf.org/html/draft-kaiser-if-sel-00

This document describes an interface selection mechanism that enables
multiple interfaces (multihomed) IPv6 hosts to select their most
appropriate egress interface to send data over the network. The
mechanism extends the Neighbor Discovery (ND) protocol [RFC4861] with
two new Router Advertisement options.

The proposed mechanism has been developed in the context of home network 
and may be relevant to HOMENET WG.

Your comments are very welcome.

Thanks in advance,

Arnaud & Alex

---

From: Ole Troan <[email-masked]>
Date: Tue, 18 Jun 2013 15:59:46 +0200

> We submitted "Interface Selection Mechanism for Multiple Interfaces IPv6 Hosts" draft-kaiser-if-sel-00 available at:
> The proposed mechanism has been developed in the context of home network and may be relevant to HOMENET WG.

there was something similar discussed at the last IETF, about adding meta information to prefixes:
http://tools.ietf.org/html/draft-korhonen-dmm-prefix-properties-03
http://tools.ietf.org/html/draft-bhandari-dhc-class-based-prefix-04

could you do what you want with that?

taking the link cost and path cost to its logical end, wouldn't you just have the host participate in the routing protocols?

cheers,
Ole