Subject: Re: [homenet] Stub-only implementation of Babel

From: Markus Stenberg <[email-masked]>
Date: Fri, 5 Dec 2014 15:29:51 +0200

On 23.11.2014, at 23.53, Juliusz Chroboczek <[email-masked]> wrote:
>> sbabeld doesn't speak to the kernel itself, it execs the "ip" utility
>> instead.  That makes error handling somewhat random,
> Steven has fixed that -- sbabeld's error handling should be reasonably
> reliable now.  (And it’s also slightly smaller.)

Speaking of sizes.. Steven made following comparison of existing routing (or ‘routing’ in case of hnetd) protocol implementation candidates:

http://employees.org/~mstenber/201412-igp-implementations.pdf

I hope the cabal (aka ‘design team’ or whatever it is called today) writing the routing comparison document includes aspects like that, or even just spec size, as metrics for evaluation. 

Cheers,

-Markus

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 5 Dec 2014 13:41:31 +0000

Who contributed the ISIS implementation in Erlang? I must admit I haven¹t
followed it closely but I thought all the quagga work was C or C++?

On 12/5/14, 8:29 AM, "Markus Stenberg" <[email-masked]> wrote:

>> reliable now.  (And it¹s also slightly smaller.)
>
>Speaking of sizes.. Steven made following comparison of existing routing
>(or Œrouting¹ in case of hnetd) protocol implementation candidates:
>
>I hope the cabal (aka Œdesign team¹ or whatever it is called today)
>writing the routing comparison document includes aspects like that, or
>even just spec size, as metrics for evaluation.
>
>Cheers,
>
>-Markus
>_______________________________________________
>homenet mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/homenet

---

From: Markus Stenberg <[email-masked]>
Date: Fri, 5 Dec 2014 15:48:07 +0200

> followed it closely but I thought all the quagga work was C or C++?

It is the most recent IS-IS for Quagga, not part of the mainline (not sure if there are plans for it either).

The built-in IS-IS in Quagga is not zeroconf, nor does it do source specific routing, so it is not an option. I am aware of two additional source-specific things on top of Quagga, one of them being that AutoISIS. (The other one was some prototype using Klick IIRC).

Of course, to be fair, we could probably include the built-in Quagga IS-IS footprint metric at some point too, but I think ‘order of magnitude’ more’ is still the result.

(That said, link-state protocol implementation _does not_ have to be big, c.f. Bird’s OSPF/OSPFv3 which is just ~thrice size of Babel.)

Cheers,

-Markus