Subject: [homenet] Reminder - WG Actions

From: Ray Bellis <[email-masked]>
Date: Wed, 11 Mar 2015 10:19:51 +0000

Please note that there’s only just under a week left on the WGLC for draft-ietf-homenet-prefix-assignment-03.

Reviews of that, and also for draft-ietf-homenet-dncp-01 and draft-ietf-homenet-hncp-04 would be much appreciated.

Mark and I are running slightly behind on producing the agenda for the WG session in Dallas.  I hope to get it out later today.

Ray

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 13 Mar 2015 16:24:37 +1300

> Please note that there’s only just under a week left on the WGLC for draft-ietf-homenet-prefix-assignment-03.

I find myself wondering how this algorithm will work during a make-before-break
renumbering procedure. Maybe it's obvious (but not to me ;-).

Break-before-make doesn't confuse me, because it amounts to destroying
all prefixes and starting again. But we don't want to encourage that
approach.

   Brian

---

From: Pierre Pfister <[email-masked]>
Date: Fri, 13 Mar 2015 08:33:09 +0100

Hello Brian,

> renumbering procedure. Maybe it's obvious (but not to me ;-).

In that case you would receive a new prefix not colliding with the previous one.
In the prefix assignment perspective, this new prefix is just a new delegated prefix
you should use for numbering you links. So the algorithm would use both and you’d get one prefix
per link for each of them. When the previous prefix gets removed, old assigned prefixes 
are removed too.

PA is just a general purpose distributed numbering algorithm. The way you handle lifetimes is out
of the scope of PA. But it surely is in the scope of HNCP (ietf-homenet-hncp).

HNCP attaches the preferred and valid lifetimes to each delegated prefix, which are in turn provided to the hosts by the
mean of RAs.
In the make-before-break case, PA numbers the links with the new prefix before removing the prefixes associated with the old one.
It let hosts renumber gracefully based on preferred lifetime values.

Cheers,

- Pierre

---

From: Pierre Pfister <[email-masked]>
Date: Fri, 13 Mar 2015 08:30:45 +0100

Hello Brian,

Cheers,

- Pierre

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 14 Mar 2015 13:16:04 +1300

Pierre,

> per link for each of them. When the previous prefix gets removed, old assigned prefixes 

OK. It just wasn't obvious to me that PA could be used in that way.

> It let hosts renumber gracefully based on preferred lifetime values.

Right. So the next question is: what will trigger HNCP to start this
process? RFC 4192 seems to assume a guiding intelligence performing a
careful sequence of actions.

Thanks
    Brian

---

From: Steven Barth <[email-masked]>
Date: Sat, 14 Mar 2015 08:18:16 +0100

> careful sequence of actions.
A variety of events are possible, in general HNCP references RFC 7084 
here, i.e. homenet routers support DHCPv6-PD, the DHCPv6 dynamic 
reconfigure mechanism and in addition possibly 6rd as sources of IPv6 
prefixes. So either of those usually or other events such as a link-down 
on an uplink interface etc.

Cheers,

Steven