Subject: [homenet] NTP in Homenet?

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 18 Aug 2015 14:34:51 +0200

How do Homenet routers configure NTP?  Just use the pool?

---

From: Henning Rogge <[email-masked]>
Date: Tue, 18 Aug 2015 14:40:23 +0200

Hi,

would be nice to have a NTP daemon on every Homenet router... gateways pull
their time from the uplink, every other router pulls time from the gateway
routers.

Henning Rogge

On Tue, Aug 18, 2015 at 2:34 PM, Juliusz Chroboczek <
[email-masked]> wrote:

> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet
>

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 18 Aug 2015 14:54:06 +0200

> would be nice to have a NTP daemon on every Homenet router... gateways
> pull their time from the uplink, every other router pulls time from the
> gateway routers.

NTP supports peering, which is more efficient than client/server -- if
every Homenet router peers with its neighbours, then NTP will compute
a shortest-dispersion tree.  (Of course, a Homenet node might not
implement full NTP, just SNTP, so being a client of the gateway might be
unavoidable.)

The alternative would be to store a list NTP servers in EXTERNAL-CONNECTION,
but that seems less elegant.

Suggested plan:

  - no signalling over HNCP;
  - we're client of each gateway;
  - we peer with all neighbours;
  - we let NTP do its magic.

Agreed?

-- Juliusz

---

From: Ca By <[email-masked]>
Date: Tue, 18 Aug 2015 05:58:05 -0700

On Tuesday, August 18, 2015, Henning Rogge <[email-masked]> wrote:

> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
I'd rather not have yet another service to exploit running on the gateway.

Gateways have historically horrible security records and ntp exploits have
nearly crushed the internet in the last few years.

CB

---

From: Steven Barth <[email-masked]>
Date: Tue, 18 Aug 2015 15:01:20 +0200

> How do Homenet routers configure NTP?  Just use the pool?

Either use the pool or use one from an SNTP DHCP option an edge router
received from an ISP and published in HNCP.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 18 Aug 2015 13:10:23 +0000

> received from an ISP and published in HNCP.

+1
Default (e.g., in open source implementations) should be to use the pool, in the absence of DHCP option info. Router manufacturers / ISPs may choose to default their routers to other NTP servers.

RFC 7084  recommends support for NTP option. If NTP is supported, the router is required to request the DHCPv6 option and use that, if it gets a response.
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 18 Aug 2015 15:21:24 +0200

> > received from an ISP and published in HNCP.

Ah, silly me.  Yes, of course, we're already publishing DHCP(v6) options.

> RFC 7084 recommends support for NTP option. If NTP is supported, the
> router is required to request the DHCPv6 option and use that, if it gets
> a response.

Ok.  That means that we don't want any NTP peering within the Homenet, right?

-- Juliusz

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 18 Aug 2015 13:45:26 +0000

> > > Either use the pool or use one from an SNTP DHCP option an edge
> > > router received from an ISP and published in HNCP.
> 
> > router is required to request the DHCPv6 option and use that, if it
> > gets a response.
> 

I don't know of anything in the homenet routers that require a peering level of synchronization. And I think it would be dangerous to suggest it's achievable. I can easily envision a multihomed network, where each CE router gets time from its ISP, and doesn't care what other devices in the home network do (or optionally both try to propagate their time). And then there are all the hosts doing their own thing. 

The most common use for NTP time that I know of is in logs. To get a reasonable sense of when something happened. So I'd suggest to keep it simple and not try for or expect synchronization.
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 18 Aug 2015 16:11:59 +0200

> I don't know of anything in the homenet routers that require a peering
> level of synchronization. And I think it would be dangerous to suggest
> it's achievable.

Well, if configured with both client-server and peer relationships, NTP
will converge to a set of disjoint lowest-dispersion trees, so I guess
there's no harm in automatically configuring some peer relationships.  But
I agree with you that it doesn't need to be mentioned in the spec.

It's clear to me now, thanks to both of you, I'll try to hack something up.

(The reason I'm asking is that once shncpd has learned to do local
configuration of DNS and NTP, it can be used instead of a DHCP/RA
client -- with fast roaming as an added benefit.  Does my enthusiasm show,
or do I need to spam even more?)

-- Juliusz

---

From: Dave Taht <[email-masked]>
Date: Tue, 18 Aug 2015 16:13:44 +0200

> Ok.  That means that we don't want any NTP peering within the Homenet, right?

There has been some good work starting up around ntp of late. I personally would
rather like it if accurate time could be provided if an accurate
device (gps) was
found, and ntp was secured, and sane, and local when possible.

there are two good mailing lists for getting opinions about where ntp
should go and/or is going
are - time-nuts and gpsd-devel

and this was very good news on this front:

http://www.informationweek.com/cloud/infrastructure-as-a-service/linux-foundation-funds-ntps-father-time/d/d-id/1321775

-- 
Dave Täht
worldwide bufferbloat report:
http://www.dslreports.com/speedtest/results/bufferbloat
And:
What will it take to vastly improve wifi for everyone?
https://plus.google.com/u/0/explore/makewififast