Subject: [homenet] HNCP in tcpdump and wireshark?

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 09 Jun 2016 17:38:08 +0200

Dear Markus, dear all,

Do you know if anyone is working on HNCP support for tcpdump and
wireshark?  I'm considering giving it out as a student project this
summer, but of course it doesn't make a lot of sense if somebody beats us
to it.

(I already know about the lua script for Wireshark.)

-- Juliusz

---

From: Markus Stenberg <[email-masked]>
Date: Thu, 9 Jun 2016 19:30:41 +0300

> On 9.6.2016, at 18.38, Juliusz Chroboczek <[email-masked]> wrote:
> 
> Dear Markus, dear all,
> 

Plenty of Wireshark built-in decoders are in lua also, so I guess you can if you must, but probably just upstreaming the Lua version would be the thing to do..?

Cheers,

-Markus

---

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 09 Jun 2016 18:38:59 +0200

> Plenty of Wireshark built-in decoders are in lua also, so I guess you
> can if you must, but probably just upstreaming the Lua version would be
> the thing to do..?

Do we have your blessing for completing and upstreaming your lua code?

-- Juliusz

---

From: Markus Stenberg <[email-masked]>
Date: Thu, 9 Jun 2016 20:25:57 +0300

> Do we have your blessing for completing and upstreaming your lua code?

Certainly. Currently hnetd (where it resides) is Apache licensed, and AFAIK that is fine, and if not, earlier version (with very minor changes) was GPL just like the Wireshark. Only change from GPL->Apache version was the update to match RFC7788 #s.

Cheers,

-Markus