Subject: [homenet] Benoit Claise's No Objection on draft-ietf-homenet-dot-13: (with COMMENT)

From: Benoit Claise <[email-masked]>
Date: Thu, 31 Aug 2017 06:52:36 -0700

Benoit Claise has entered the following ballot position for
draft-ietf-homenet-dot-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-homenet-dot/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

"As a result, the use of '.home' is deprecated."
I had to double-checked that .home was NOT in
https://www.iana.org/assignments/special-use-domain-names/special-use-domain-names.xhtml
.home was specified/requested in RFC7788 but never requested to IANA according
to RFC6761. If mentioned in the draft, this info might help others...

---

From: Ted Lemon <[email-masked]>
Date: Thu, 31 Aug 2017 10:11:46 -0400

I can update the text as follows:

        As a result,
	the use of '.home.', both as specified in RFC7788, and for other uses is deprecated.
	This should not be taken to mean that an explicit allocation by ICANN is superseded;
	this deprecation refers to uses of '.home.' as practiced at the time of publication
	of this document.

As you can see, though, this is somewhat problematic, which is why we took out similar text previously.   I think this new text is less problematic than the old text, but personally I still prefer to just let people wonder what "deprecated" means.   I would actually rather leave it ambiguous, in the sense that this would also discourage ICANN allocating '.home.' as a GTLD.   However, I suspect that there are people on the IESG who understand this issue better than I do, and so I would appreciate it if you would discuss this during the telechat, if you read this in time, and see if you can get a consensus from the IESG on what to write here.   I am happy to make this change or not make it, as you all decide.

> On Aug 31, 2017, at 9:52 AM, Benoit Claise <[email-masked]> wrote:
> 
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Benoit Claise <[email-masked]>
Date: Thu, 31 Aug 2017 17:39:38 +0200

Hi Ted,
> 	this deprecation refers to uses of '.home.' as practiced at the time of publication
I'm surprised by "for the other uses".
I was thinking something such as:

         As a result, the use of '.home.', as specified in RFC7788, is deprecated.
	Since '.home.' was not requested to IANA according to RFC6761, no IANA action
         is required.

I'm probably over simplifying this, which probably makes it more complex.
A little bit too late for this quick telechat today, so let me discuss 
with Terry and come back to you.

Regards, Benoit

> .

---

From: Ted Lemon <[email-masked]>
Date: Thu, 31 Aug 2017 11:42:13 -0400

On Aug 31, 2017, at 11:39 AM, Benoit Claise <[email-masked]> wrote:
> A little bit too late for this quick telechat today, so let me discuss with Terry and come back to you.

OK.   Other uses are ad-hoc uses of the name: e.g., Sky TV in the UK, IIRC, just used this domain in all their routers without ever getting permission or trying to claim it officially.   I believe that other such uses exist.   This is discussed in https://datatracker.ietf.org/doc/draft-ietf-dnsop-sutld-ps/ <https://datatracker.ietf.org/doc/draft-ietf-dnsop-sutld-ps/>, which is in the RFC editor queue.