Subject: Re: [homenet] Ted's security talk at IETF99: DNCP Security

From: Michael Richardson <[email-masked]>
Date: Tue, 01 Aug 2017 11:38:22 -0400

Ted Lemon <[email-masked]> wrote:
    mcr> Christian's comments in DNSSD (which I also watched today) is right though:
    mcr> for many applications in *discovery* is important you probably don't want
    mcr> certs, because they reveal too much, and the relationship is too
    mcr> ephermeral.
    mcr> The link between Dave's Laptop and Dave's Cool Printer is probably
    mcr> longer.

    > Indeed, but we don't want Dave's Laptop going around asking for Dave's Cool
    > Printer when Dave's Laptop is not on the home network where Dave's Cool
    > Printer lives.

You agree that it's a different problem right?

The common part is that one might have a similar set of external (physical) signals.

Should Dave bring his printer to the IETF network, and they happen to
discovery each other via privacy-enhanced dnssd magic (cf: Arthur Clark's
definition of magic), then it would be good that they can prove that it's really them.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Ted Lemon <[email-masked]>
Date: Tue, 1 Aug 2017 11:56:33 -0400

> definition of magic), then it would be good that they can prove that it's really them.

To be honest, I probably missed the point you were making—I just went back and reviewed this exchange, and I don't actually understand what the distinction is that you are making between ephemeral and long-lived relationships.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 01 Aug 2017 16:48:22 -0400

> You agree that it's a different problem right?

    mcr> The common part is that one might have a similar set of external
    mcr> (physical) signals.

    mcr> Should Dave bring his printer to the IETF network, and they happen to
    mcr> discovery each other via privacy-enhanced dnssd magic (cf: Arthur Clark's
    mcr> definition of magic), then it would be good that they can prove that it's
    mcr> really them.

    > To be honest, I probably missed the point you were making—I just went back
    > and reviewed this exchange, and I don't actually understand what the
    > distinction is that you are making between ephemeral and long-lived
    > relationships.

This thread started by being about the problem of getting devices in the home
to securely join the homenet.  One sees a list of possible routers in the
home, and identifies one that should belong, and tells your homenet that it
should be allowed to join.  (And the router also is told to join your
network).

The short-term exchange is where you discover the new router and do the
out-of-band secured exchange to establish initial trust.  Within that initial
trust, longer-term credentials (asymmetric keys) are exchanged.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 1 Aug 2017 16:53:03 -0400

So what you're saying is ephemeral is the keying used for the initial
exchange?

---

From: Michael Richardson <[email-masked]>
Date: Tue, 01 Aug 2017 20:42:13 -0400

> So what you're saying is ephemeral is the keying used for the initial

yes, it's probably more about authenticating the initial (DH/TLS/etc.) exchange.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 1 Aug 2017 20:55:37 -0400

OK.   So I think the comparison with me and my printer is probably a red
herring. :)

What I was getting at when talking about Christian's work is that the
process of validating the initial leap of faith for homenet could be
similar to the process that Christian is using for validating the pairing
process in private service discovery.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 02 Aug 2017 03:05:20 -0400

> OK. So I think the comparison with me and my printer is probably a red

A bit, yes.
The part where it's not, is that having established this out of band
process (when the discovery was authorized),  a secured channel remains, in
which one can exchange credentials for next time.  It's not TOFU.
It's more like, "Trust After First Discovery" or something like that.

    > What I was getting at when talking about Christian's work is that the process
    > of validating the initial leap of faith for homenet could be similar to the
    > process that Christian is using for validating the pairing process in private
    > service discovery.

I agree, exactly.  That's the laudry list of processes.