Subject: [hops] Questions to ask

From: Mirja Kühlewind <[email-masked]>
Date: Fri, 4 Sep 2015 15:38:57 +0200

Hi again,

at the last meeting, the main interest of the group (for now as a starting 
point) was to collect and see measurement data. However, collecting random 
measurement data might not be the most useful thing to do and makes it also 
often difficult to get access to existing data sets. While the focus of the 
proposed hops group is clearly on measurement of middlebox impairments, we 
believe we could even be more specific than that and try to tackle certain 
questions that you like an answer for or that have been raised lately in some 
context e.g. other working group.

One example is on UDP impairments because there are a bunch of new protocols 
that have chosen to encapsulate over UDP to enable Internet path traversal (or 
at least make it more likely to be able to connect). The questions here are:

- How likely is it that your traffic will be fully blocked if you use (a new 
unknown protocol over) UDP?

- How likely is it that your UDP traffic is throttled to a certain rate while 
TCP traffic on the same path is not?

There might be even more questions in this context (but these are the ones we 
are actually currently working on).

So now, the purpose of this email is, to collect more of these questions such 
that we can use this working group as a forum to find a match between people 
that have a question and people that have the data to (at least partially) 
answer that question.

Therefore please send questions to the list! Or start a discussion on what areas 
we might want to focus on so that we as a group can try to find the right 
questions! Or if you have data, tell us which questions you can already answer 
or at least (at high level) which kind of data you have!

Thanks,
Brian and Mirja

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 4 Sep 2015 14:33:59 +0000

I think TCPM would also be interested quite a bit in real-world measurement data on impairments resulting from the endsystem network stack itself, e.g., "broken" TCP HW offloading on NICs.

Any data on that would really be welcome in TCPM (in particular in the context of EDO).

Michael

> -----Original Message-----
> From: hops [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
> Sent: Friday, September 04, 2015 3:39 PM
> To: [email-masked]
> Cc: Brian Trammell
> Subject: [hops] Questions to ask
> 
> Hi again,
> 
> _______________________________________________
> hops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hops

---

From: Christian Kuhtz <[email-masked]>
Date: Fri, 4 Sep 2015 16:29:06 +0000

Michael,

> I think TCPM would also be interested quite a bit in real-world measurement data on impairments resulting from the endsystem network stack itself, e.g., "broken" TCP HW offloading on NICs.

Can you please elaborate what you're referring to?  Are you talking about historic behavior or current state of the art behaviors?

If current state of the art, can you be specific on context please?  

Thanks in advance.

Best regards,
Christian

-----Original Message-----
From: hops [mailto:[email-masked]] On Behalf Of Scharf, Michael (Michael)
Sent: Friday, September 4, 2015 7:34 AM
To: Mirja Kühlewind <[email-masked]>; [email-masked]
Cc: Brian Trammell <[email-masked]>
Subject: Re: [hops] Questions to ask

Michael

> point) was to collect and see measurement data. However, collecting 
> random measurement data might not be the most useful thing to do and 
> makes it also often difficult to get access to existing data sets. 
> While the focus of the proposed hops group is clearly on measurement 
> of middlebox impairments, we believe we could even be more specific 
> than that and try to tackle certain questions that you like an answer 
> for or that have been raised lately in some context e.g. other working 
> group.
> 
> One example is on UDP impairments because there are a bunch of new 
> protocols that have chosen to encapsulate over UDP to enable Internet 
> path traversal (or at least make it more likely to be able to 
> connect). The questions here
> are:
> 
> - How likely is it that your traffic will be fully blocked if you use 
> (a new unknown protocol over) UDP?
> 
> - How likely is it that your UDP traffic is throttled to a certain 
> rate while TCP traffic on the same path is not?
> 
> There might be even more questions in this context (but these are the 
> ones we are actually currently working on).
> 
> So now, the purpose of this email is, to collect more of these 
> questions such that we can use this working group as a forum to find a 
> match between people that have a question and people that have the 
> data to (at least
> partially)
> answer that question.
> 
> Therefore please send questions to the list! Or start a discussion on 
> what areas we might want to focus on so that we as a group can try to 
> find the right questions! Or if you have data, tell us which questions 
> you can already answer or at least (at high level) which kind of data 
> you have!
> 
> Thanks,
> Brian and Mirja
> 
> https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.i
> etf.org%2fmailman%2flistinfo%2fhops&data=01%7c01%7cchkuhtz%40microsoft
> .com%7c3e26e4bef2a84b2b8f1c08d2b535e560%7c72f988bf86f141af91ab2d7cd011
> db47%7c1&sdata=jrCFwXC5VUY0RMmxX7CyuB%2f1upswnsZvt%2bm11A1ktvQ%3d

_______________________________________________
hops mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fhops&data=01%7c01%7cchkuhtz%40microsoft.com%7c3e26e4bef2a84b2b8f1c08d2b535e560%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=jrCFwXC5VUY0RMmxX7CyuB%2f1upswnsZvt%2bm11A1ktvQ%3d

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 4 Sep 2015 17:03:04 +0000

Hi Christian,

I was referring to the problems TCPM currently faces with extending the option space. One specific example found so far in prototypes is explained in:

https://www.ietf.org/proceedings/93/slides/slides-93-tcpm-1.pdf Slide 4

This is related to the segmentation/reassembly engines. And in TCPM there is currently a lot of uncertainty how TCP offload engines would deal with unknown TCP options, long options, etc. Measurements could perhaps help to reduce that uncertainty.

I am not sure why historic behavior should matter. In TCPM we wonder whether something like EDO could get widely deployed in the *current* Internet, and we lack data for answering that question.

Michael

> From: Christian Kuhtz [mailto:[email-masked]]
> Sent: Friday, September 04, 2015 6:29 PM
> To: Scharf, Michael (Michael); Mirja Kühlewind; [email-masked]
> Cc: Brian Trammell
> Subject: RE: [hops] Questions to ask
> 
> Michael,
> 
> > I think TCPM would also be interested quite a bit in real-world
> measurement data on impairments resulting from the endsystem network
> stack itself, e.g., "broken" TCP HW offloading on NICs.
> 
> Can you please elaborate what you're referring to?  Are you talking
> about historic behavior or current state of the art behaviors?
> 
> I think TCPM would also be interested quite a bit in real-world
> measurement data on impairments resulting from the endsystem network
> stack itself, e.g., "broken" TCP HW offloading on NICs.
> 
> https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ie
> tf.org%2fmailman%2flistinfo%2fhops&data=01%7c01%7cchkuhtz%40microsoft.c
> om%7c3e26e4bef2a84b2b8f1c08d2b535e560%7c72f988bf86f141af91ab2d7cd011db4
> 7%7c1&sdata=jrCFwXC5VUY0RMmxX7CyuB%2f1upswnsZvt%2bm11A1ktvQ%3d