Subject: Re: [new issue] Re: Proxying OPTIONS *

From: Mark Nottingham <[email-masked]>
Date: Thu, 13 Nov 2008 17:38:22 -0800

Does anyone object to reinstating this text into 2616bis?

On 11/10/2007, at 11:43 PM, Mark Nottingham wrote:

>
> Now i83.
>
> <http://www.w3.org/Protocols/HTTP/1.1/rfc2616bis/issues/#i83>
>
>
> On 04/10/2007, at 9:10 AM, Henrik Nordstrom wrote:
>
>> On ons, 2007-10-03 at 23:49 +0200, Julian Reschke wrote:
>>
>>> " If a proxy receives a request without any path in the Request- 
>>> URI and
>>>    the method specified is capable of supporting the asterisk form  
>>> of
>>>    request, then the last proxy on the request chain MUST forward  
>>> the
>>>    request with "*" as the final Request-URI. For example, the  
>>> request
>>>
>>>           OPTIONS http://www.ics.uci.edu:8001 HTTP/1.1
>>>
>>>    would be forwarded by the proxy as
>>>
>>>           OPTIONS * HTTP/1.1
>>>           Host: www.ics.uci.edu:8001
>>>
>>>    after connecting to port 8001 of host "www.ics.uci.edu"." --
>>> <http://tools.ietf.org/html/rfc2068#section-5.1.2>
>>>
>>> Best regards, Julian
>>
>> There is one slight problem with the above and it's " and the method
>> specified is capable of supporting the asterisk form of request".  
>> This
>> requires the proxy to know about each such method, and with HTTP  
>> being
>> extensible it's not fully possible. In RFC2616 only OPTIONS meets  
>> this
>> criteria.
>>
>> Is there a possibility for other methods than OPTIONS which may make
>> sense on a global resource-less context? I think not. If this is
>> complemented with a restriction that the special request-URI "*" may
>> only be used in OPTIONS requests then it's fine. Interoperability of
>> extension methods using "*" will be tricky at best..
>>
>> Please put this into the issues list, starting with julians response.
>> http://www.w3.org/mid/[email-masked]
>>
>>
>> Regards
>> Henrik
>
>
> --
> Mark Nottingham     http://www.mnot.net/
>
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Jamie Lokier <[email-masked]>
Date: Fri, 14 Nov 2008 01:51:23 +0000

> >>>          Host: www.ics.uci.edu:8001

Isn't http://www.ics.uci.edu:8001 commonly normalised to
http://www.ics.uci.edu:8001/ ?

-- Jamie

---

From: David Morris <[email-masked]>
Date: Thu, 13 Nov 2008 17:57:11 -0800 (PST)

Sort of seems to me that unless * is known to work for a method, the
correct last proxy to origin server request would be:
   SOMETHING / HTTP/1.1
rather than
   SOMETHING * HTTP/1.1

Dave Morris

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 13 Nov 2008 17:57:15 -0800

Maybe in browsers (e.g., through the navigation bar), but not as a  
matter of specification.

---

From: Henrik Nordstrom <[email-masked]>
Date: Fri, 14 Nov 2008 22:57:11 +0100

> correct last proxy to origin server request would be:

Yes. Is there a conflict?

The reinstated text is conditioned on * to be specified as allowed for
the method in question. In HTTP/1.1 only OPTIONS allow * URIs..

Regards
Henrik