Subject: RFC2616 vs draft-ietf-httpbis-p7-auth

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 3 Dec 2009 20:12:51 -0700

The OAuth working group is working to define a new HTTP authentication scheme. This requires referencing either RFC 2617 or draft-ietf-httpbis-p7-auth. The goal is to move the spec into last call in 3-6 months.

Which ABNF and reference should the new work use?

EHL

---

From: "Paul C. Bryan" <[email-masked]>
Date: Fri, 04 Dec 2009 07:07:05 +0000

On Thu, 2009-12-03 at 20:12 -0700, Eran Hammer-Lahav wrote:

> The OAuth working group is working to define a new HTTP authentication
> scheme. This requires referencing either RFC 2617 or
> draft-ietf-httpbis-p7-auth. The goal is to move the spec into last
> call in 3-6 months.
> 

I lean toward draft-ietf-httpbis-p7-auth, for AFAIK, OAuth will only use
the response status codes and headers, and nothing related to basic or
digest authentication in particular.

Paul

> 
> EHL
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Julian Reschke <[email-masked]>
Date: Fri, 04 Dec 2009 17:21:35 +0100

> Which ABNF and reference should the new work use?

It's very hard to predict how long we'll need to go to LC. So a good 
strategy might be to leave things the way they are now, and to get back 
to this question once you're preparing WGLC.

Best regards, Julian