Subject: [410 Gone] HTTP/1.1, part 2: Message Semantics

From: Karl Dubost <[email-masked]>
Date: Wed, 24 Feb 2010 22:35:25 -0500

Hi, 

I was reading again the draft and I had a few questions about 

    410 Gone

The draft specification says:

    In HTTP/1.1, part 2: Message Semantics
    At http://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis/latest/p2-semantics.html#status.410

    8.4.11 410 Gone

    The requested resource is no longer available at 
    the server and no forwarding address is known. 
    This condition is expected to be considered 
    permanent. Clients with link editing capabilities 
    SHOULD delete references to the request-target 
    after user approval. If the server does not know, 
    or has no facility to determine, whether or not 
    the condition is permanent, the status code 404 
    (Not Found) SHOULD be used instead. This response 
    is cacheable unless indicated otherwise.

    The 410 response is primarily intended to assist 
    the task of web maintenance by notifying the 
    recipient that the resource is intentionally 
    unavailable and that the server owners desire that 
    remote links to that resource be removed. Such an 
    event is common for limited-time, promotional 
    services and for resources belonging to 
    individuals no longer working at the server's 
    site. It is not necessary to mark all permanently 
    unavailable resources as "gone" or to keep the 
    mark for any length of time -- that is left to the 
    discretion of the server owner. 

This seems to be undefined: "Clients with link editing capabilities"
but used in two places "8.3.2 301 Moved Permanently" and "8.4.11 410 Gone".

> Clients with link editing capabilities 
> SHOULD delete references to the request-target 
> after user approval.

What is the scenario for this feature?

The "410 Gone" response is cacheable. 
Does that mean the server can send a body? Such as

        HTTP/1.1 410 Gone
        Date: Thu, 25 Feb 2010 03:28:01 GMT
        Server: Apache/2.2.0
        Content-Length: 204
        Content-Type: text/plain; charset=utf-8

        410 Gone
        There used to be something here
        about poneys and rainbows but a cloud 
        has stolen it

It says also that links could be removed from the original source. Do we have an example of such a working system without human help? 

There is something which in some cases might seems contradictory:
cacheable AND links removed. It is subtle, but an example might help understand.

-- 
Karl Dubost
Montréal, QC, Canada
http://www.la-grange.net/karl/

---

From: Mark Baker <[email-masked]>
Date: Thu, 25 Feb 2010 01:22:42 -0500

Hi Karl,

> What is the scenario for this feature?

As an example (301, not 410);

https://bugzilla.mozilla.org/show_bug.cgi?id=213467

I'm sure you could imagine how a 410 would be handled in that context.

> Does that mean the server can send a body? Such as

Sure.  All responses can have a body, except HEAD responses.

> It says also that links could be removed from the original source. Do we have an example of such a working system without human help?

Not AFAIK.

> cacheable AND links removed. It is subtle, but an example might help understand.

Can you explain why you believe it contradictory?

Mark.