Subject: Re: short-time client side caching and clock skew

From: Mark Nottingham <[email-masked]>
Date: Tue, 1 Jun 2010 21:57:10 +1000

See also:
  http://www.w3.org/mid/[email-masked]

If you're going to suggest replacement text, please incorporate the changes in -latest (if you haven't already); see 
  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/29

Cheers,

On 31/05/2010, at 11:04 PM, Jorrit Jongma wrote:

> Henrik,
> 
> Thank you for your insights and corrections.
> 
> If I understand you correctly, the following pseudo-code would cover all the cases, taking -09 as base, and completely bypassing date_value if possible:
> 
> if (response_version_1_1 && !response_via_1_0) {
> 	corrected_initial_age = age_value + (response_time - request_time);
> } else {
> 	apparent_age = max(0, response_time - date_value);
> 	corrected_received_age = max(apparent_age, age_value);
> 	response_delay = response_time - request_time;
> 	corrected_initial_age = corrected_received_age + response_delay;
> }
> resident_time = now - response_time;
> current_age = correct_initial_age + resident_time;
> 
> I have tested current operation in a few browsers, and the results are not encouraging; if the above is judged correct it is my intent to submit bug tickets to some of these browser manufacturers and see if they will update.
> 
> Regards,
> Jorrit
> 
> 
> 

--
Mark Nottingham     http://www.mnot.net/

---

From: "Jorrit Jongma" <[email-masked]>
Date: Tue, 1 Jun 2010 14:50:19 +0200

I thought #29 was already in -09, due to the comments of the report. It
appears that isn't so, so re-done, incorporating #29 / -latest would be:

response_delay = response_time - request_time;
corrected_age_value = age_value + response_delay;
if (reponse_version_1_1 && !response_via_1_0) {
	corrected_initial_age = corrected_age_value;
} else {
	apparent_age = max(0, response_time - date_value);
	corrected_initial_age = max(apparent_age, corrected_age_value);
}	
resident_time = now - response_time;
current_age = corrected_initial_age + resident_time;

Interesting to see that this issue was raised before. Hopefully it will
finally be resolved.

Thanks,
Jorrit

-----Original Message-----
From: Mark Nottingham [mailto:[email-masked]] 
Sent: dinsdag 1 juni 2010 13:57
To: Jorrit Jongma
Cc: 'Henrik Nordström'; [email-masked]
Subject: Re: short-time client side caching and clock skew

See also:

If you're going to suggest replacement text, please incorporate the changes
in -latest (if you haven't already); see 
  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/29

Cheers,

On 31/05/2010, at 11:04 PM, Jorrit Jongma wrote:

> If I understand you correctly, the following pseudo-code would cover all
the cases, taking -09 as base, and completely bypassing date_value if
possible:
> I have tested current operation in a few browsers, and the results are not
encouraging; if the above is judged correct it is my intent to submit bug
tickets to some of these browser manufacturers and see if they will update.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 2 Jun 2010 16:56:08 +1000

Tracking this as
  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/212