Subject: FW: I-D Submission: draft-lee-httpext-metadata-00.txt

From: 이문상 <[email-masked]>
Date: Sat, 26 Jun 2010 11:48:01 +0900

FYI.

---
Moon-Sang Lee, Senior Engineer, Ph.D.
Convergence Software Lab., Digital Media & Communication R&D Center,
Samsung Electronics Co., Ltd.,
TEL: +82-31-279-8082
Email: [email-masked]
Wisdom begins in wonder. *Socrates*

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Friday, June 25, 2010 4:34 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: 

Message-Id: <[email-masked]>
Date: Fri, 25 Jun 2010 00:33:55 -0700 (PDT)

,[email-masked]
Subject: Manual Post Requested for draft-lee-httpext-metadata
Content-Type: text/plain; charset="utf-8"
Mime-Version: 1.0

Manual Posting Requested for following Internet-Draft:

I-D Submission Tool URL:
https://datatracker.ietf.org/idst/status.cgi?submission_id=24392

Filename:	   draft-lee-httpext-metadata
Version:	   00
Staging URL:	   http://www.ietf.org/staging/draft-lee-httpext-metadata-
00.txt
Title:		   A New Header For Metadata Exchange
Creation_date:	   2010-06-25
WG ID:		   Individual Submission
Number_of_pages: 11
Abstract:
This document provides a mechanism by which web servers can provide
metadata of a web resource which is indicated by a URL.  The web client
like web browser can use this metadata to filter out unwanted web resource
or link to itself.  In addition, the web client can take advantage of such
metadata to provide high-level services like displaying additional
information about the web resource without downloading it.  We expect this
mechanism to enable quick access to metadata of any web resource from any
web client reduces overall web traffic remarkably.

Submitter: Moon-Sang Lee ([email-masked])

Author(s):
Moon-Sang Lee, [email-masked]

Jung-Lok Yu, [email-masked]

Comment:
Thank you!

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Sat, 26 Jun 2010 00:53:55 -0700

Hi,

You are entering an area with a lot of prior experience.

There is little reason to extend HTTP with additional headers given the recent work on the HTTP Link header [1] (and the 'describedby' relation type), as well as the POWDER [2] and XRD [3] descriptor formats, and the host-meta proposal [4] which is currently in last call. In addition, you might want to take a look at analysis included in an early draft of LRDD [5] which covers existing methods for obtaining resource metadata.

Between using the HTTP Link header and host-meta, you should have full coverage of what you are trying to do, without having to create any new mechanism.

EHL

[1] http://tools.ietf.org/html/draft-nottingham-http-link-header
[2] http://www.w3.org/TR/powder-dr/
[3] http://www.oasis-open.org/apps/org/workgroup/xri/download.php/38236/xrd-1.0-wd17.html
[4] http://tools.ietf.org/html/draft-hammer-hostmeta
[5] http://tools.ietf.org/html/draft-hammer-discovery-03#appendix-B

> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of ???
> Sent: Friday, June 25, 2010 7:48 PM
> To: [email-masked]
> Subject: FW: I-D Submission: draft-lee-httpext-metadata-00.txt
> 
> 
> FYI.
> 
> ---
> metadata of a web resource which is indicated by a URL.  The web client like
> web browser can use this metadata to filter out unwanted web resource or
> link to itself.  In addition, the web client can take advantage of such metadata
> to provide high-level services like displaying additional information about the
> web resource without downloading it.  We expect this mechanism to enable
> quick access to metadata of any web resource from any web client reduces
> overall web traffic remarkably.
>

---

From: "Hausenblas, Michael" <[email-masked]>
Date: Sat, 26 Jun 2010 10:11:44 +0100

+1 to what Eran said, I couldn't have phrased it better.

Nevertheless, your use case sounds interesting, Moon-Sang, and I'd be  
more than happy to follow-up off-list to investigate how it can be  
realised with existing methods, such as Link: header.

Cheers,
             Michael
-- 
http://sw-app.org/mic.xhtml#i
Sent from my iPhone

On 26 Jun 2010, at 08:57, "Eran Hammer-Lahav" <[email-masked]>  
wrote:

> There is little reason to extend HTTP with additional headers given  
> the recent work on the HTTP Link header [1] (and the 'describedby'  
> relation type), as well as the POWDER [2] and XRD [3] descriptor  
> formats, and the host-meta proposal [4] which is currently in last  
> call. In addition, you might want to take a look at analysis  
> included in an early draft of LRDD [5] which covers existing methods  
> for obtaining resource metadata.
>
> Between using the HTTP Link header and host-meta, you should have  
> full coverage of what you are trying to do, without having to create  
> any new mechanism.
>
> EHL
>