Subject: [#193] Trailers and intermediaries

From: Mark Nottingham <[email-masked]>
Date: Wed, 14 Jul 2010 15:14:49 +1000

Henrik,

I think a bit more of a change is necessary to get this right;

> b) the trailer fields consist entirely of optional metadata, and the recipient could use the message (in a manner acceptable to the server where the field originated) without receiving it. In other words, the server that generated the header (often but not always the origin server) is willing to accept the possibility that the trailer fields might be silently discarded along the path to the client.

Thoughts?

On 14/08/2007, at 1:37 AM, Henrik Nordstrom wrote:

> On mån, 2007-08-13 at 20:00 +1000, Mark Nottingham wrote:
> 
>>> b) the server is the origin server for the response, the trailer  
>>> fields consist entirely of optional metadata, and the recipient  
>>> could use the message (in a manner acceptable to the origin server)  
>>> without receiving this metadata. In other words, the origin server  
>>> is willing to accept the possibility that the trailer fields might  
>>> be silently discarded along the path to the client.
>>> 
>> Read strictly, this doesn't seem to give an intermediary along the  
>> path to the client the wiggle room necessary to preserve those  
>> trailers if the request doesn't have a TE: trailers. Something like  
>> this might help;
>> 
>> c) the server is an intermediary, the forwarded request did not  
>> include a TE header field that indicated "trailers", and the trailers  
>> are being forwarded.
> 
> Personally I don't get why there need to be a distinction between origin
> and intermediary here. Informational headers may be added at any step in
> the forwarding chain, not just the origin server.
> 
> So I propose instead removing the first part of b "the server is the
> origin server for the response, ". and also remove "origin " where it
> occurs in 'b'.
> 
> b) the trailer fields consist entirely of optional metadata, and the
> recipient could use the message (in a manner acceptable to the server)
> without receiving this metadata. In other words, the server is willing
> to accept the possibility that the trailer fields might be silently
> discarded along the path to the client.
> 
> And for clarity add the obvious restriction that
> 
> A proxy server MUST NOT move any existing entity headers to the trailer
> unless 'a' is fulfilled.
> 
> Regards
> Henrik

--
Mark Nottingham     http://www.mnot.net/

---

From: Henrik Nordström <[email-masked]>
Date: Wed, 14 Jul 2010 09:29:00 +0200

> > b) the trailer fields consist entirely of optional metadata, and the recipient could use the message (in a manner acceptable to the server where the field originated) without receiving it. In oth…

+1. 

Regards
Henrik

---

From: Julian Reschke <[email-masked]>
Date: Wed, 14 Jul 2010 13:41:49 +0200

>> b) the trailer fields consist entirely of optional metadata, and the recipient could use the message (in a manner acceptable to the server where the field originated) without receiving it. In othe…

Sounds good. Proposed patch: 
<http://trac.tools.ietf.org/wg/httpbis/trac/attachment/ticket/193/193.diff>.

Best regards, Julian