Subject: NEW: #233 - Is * usable as a request-uri for new methods?

From: Mark Nottingham <[email-masked]>
Date: Sat, 24 Jul 2010 15:10:55 +0200

<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/233>

--->8---

Can methods other than OPTIONS (e.g., new extension methods) specify that * is an acceptable request-URI?

Allowing it may cause interop issues with intermediaries, servers, etc.

---8<---

Anyone think we should allow methods other than OPTIONS to use *?

--
Mark Nottingham     http://www.mnot.net/

---

From: Willy Tarreau <[email-masked]>
Date: Sat, 24 Jul 2010 16:06:35 +0200

> Anyone think we should allow methods other than OPTIONS to use *?

"*" refers to the server itself regardless of any of its resources. I'm
not sure we'd need other method targetting the server and not a specific
resource. Maybe it could have made sense if a method such as CONNECT was
supported on servers, for instance to establish a tunnel between a client
and a server, but it does not and anyway for this we could use the Upgrade
mechanism which already supports GET on a specific resource or OPTIONS *.

Regards,
Willy

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 25 Jul 2010 03:10:24 +0800

> Anyone think we should allow methods other than OPTIONS to use *?

It's probably jet lag speaking, but was it considered in place of /.well-known/ ?

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 25 Jul 2010 09:40:22 +0200

OPTIONS * or [other method] * ?

OPTIONS * was definitely considered, but it's got implementation problems (while technically possible, it's difficult for average folks to affect the response) and OPTIONS isn't cacheable. 

Cheers,

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 25 Jul 2010 16:25:02 +0800

> OPTIONS * or [other method] * ?

GET * was what I was thinking.   The point of well known being to retrieve a representation of a resource describing the host.

It's probably moot anyhow.  The first advantage over /.well-known/ - no potential for namespace clash - has been dealt with anyway.  The second advantage - not taking control of URI space away from site owners - is a minor thing only.

--Martin