Subject: Re: issue 79: must understand content-* header fields or fail

From: Mark Nottingham <[email-masked]>
Date: Wed, 14 Jul 2010 15:45:05 +1000

I've seen one message agreeing with Roy's proposal to remove the Content-* language as per below.

Note that doing this would close both #79 and #102 <http://trac.tools.ietf.org/wg/httpbis/trac/ticket/102>.

In the discussion of #102, Roy said

> At most, this should only warn implementations that all of the metadata needs to be understood or discarded whenever changes are made to the corresponding data.

I think it's worth adding a bit of (non-requirement) guidance to the definition of PUT along these lines if we remove this requirement.

Any objections to closing these issues by doing so?

On 30/07/2009, at 8:24 PM, Roy T. Fielding wrote:

> The editors spent some time discussing
> 
>  http://trac.tools.ietf.org/wg/httpbis/trac/ticket/79
> 
> with regard to the requirement in RFC 2616, section.9.6,
> the description of PUT:
> 
> "The recipient of the entity MUST NOT ignore any Content-*
> (e.g. Content-Range) headers that it does not understand or
> implement and MUST return a 501 (Not Implemented) response
> in such cases."
> 
> The purpose of this requirement was to enable some future
> use of Content-Range for the purpose of partial updates.
> 
> No server that I am aware of supports that requirement.
> Partial updates should be accomplished using a new method
> (PATCH) rather than a retroactive requirement on deployed
> services that nobody implemented.
> 
> My proposal is to remove that sentence from the spec and
> note in the changes section that the requirement was removed
> in favor of deploying PATCH.
> 
> ....Roy
> 

--
Mark Nottingham     http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 29 Jul 2010 14:18:50 +0200

Haven't heard any objection, so we'll try that.

This resolution will also close #102.