Subject: Re: New issue: p5-range 5.4.2, proxy recommendations regarding 200 responses to Range

From: Mark Nottingham <[email-masked]>
Date: Thu, 2 Sep 2010 11:14:17 +1000

(just me) +1

On 30/08/2010, at 8:24 AM, Henrik Nordström wrote:

> fre 2010-07-23 klockan 08:58 -0400 skrev Yves Lafon:
> 
>> I don't see why it would be a MAY for a proxy and a SHOULD for a server, 
>> it seems better to keep them both as SHOULDs.
> 
> Because a SHOULD means it's the recommended method, and as shown in this
> case it's not a good general purpose recommendation.
> 
> The optimization to have proxies reduce the traffic sent to the
> requestor by eating the unwanted parts of the response when the server
> responds with more data than requested should imho be a MAY, not a
> SHOULD.
> 
> For a server the situation is different as it has control over the
> requested resource.
> 
> Regards
> Henrik
> 
> 

--
Mark Nottingham     http://www.mnot.net/

---

From: Yves Lafon <[email-masked]>
Date: Mon, 20 Sep 2010 05:46:57 -0400 (EDT)

> For a server the situation is different as it has control over the

Ok, I was looking at this from the UA point of view where the fact that 
you are talking to a server or a proxy shouldn't matter much, but I see 
your point on requirements on proxies and control over the resource.
So +1 on the proposed change.

-- 
Baroula que barouleras, au tiéu toujou t'entourneras.

         ~~Yves