Subject: use of Warning in request messages

From: "Roy T. Fielding" <[email-masked]>
Date: Fri, 13 Sep 2013 14:30:51 -0700

When editing the definition of Warning last night, I noticed
that it claims to be applicable to both request and response
messages.  That is surprising (and not in a good way).

I don't see how sending Warning in a request would ever be useful.
At best, it might mistakenly be stored in a PUT.

Does anyone know?  Can I make Warning specific to responses?

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 17 Sep 2013 10:59:53 +1000

2616 said:

> Warning headers can in general be applied to any message, however some specific warn-codes are specific to caches and can only be applied to response messages.

The case that I can think of is a non-transparent intermediary changing a request payload. 

*shrug*

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Amos Jeffries <[email-masked]>
Date: Sun, 15 Sep 2013 23:07:56 +1200

> Does anyone know?  Can I make Warning specific to responses?

Consider an ICAP content filter being applied to PUT and POST. In such 
situation it is useful to append  Warning about transformation, etc.

I don't see how there is any more (or less) difference to Warning on 
requests as for responses. There are extension warnings possible that 
could apply to requests.

Amos

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 23 Sep 2013 18:20:13 -0700

On Sep 15, 2013, at 4:07 AM, Amos Jeffries wrote:

> Consider an ICAP content filter being applied to PUT and POST. In such situation it is useful to append  Warning about transformation, etc.
> 
> I don't see how there is any more (or less) difference to Warning on requests as for responses. There are extension warnings possible that could apply to requests.
> 
> Amos

Okay, I have left it as is.

....Roy