Subject: Agenda for Seattle Interim

From: Mark Nottingham <[email-masked]>
Date: Tue, 17 Sep 2013 13:27:54 +1000

As mentioned before, the rough thinking for our agenda in Seattle is:

--->8---

# Wednesday

Interop / testing day

# Thursday

Issue discussion (including those raised in the interop) and related presentations

# Friday

Continued issue discussion, wrap-up and planning

---8<---

Suggestions are (as always) welcome. 

While a good part of the interop / testing day is likely to be unstructured, it would be helpful if we have a discussion about what we'd like to test, who will be participating, etc., and -- ideally -- if someone is willing to do work on test frameworks, etc. Feel free to start that here, or on the devops list.

Also, if you have a particular issue you'd like to make a brief presentation about, please give me a heads-up.

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 24 Sep 2013 15:36:39 +1000

A bit more formal, still looking for input:
  https://github.com/http2/wg_materials/blob/master/interim-13-10/agenda.md

Cheers,

---

From: "Brian Raymor (MS OPEN TECH)" <[email-masked]>
Date: Wed, 25 Sep 2013 01:18:43 +0000

> -----Original Message-----
> From: Mark Nottingham [mailto:[email-masked]]
> Sent: Monday, September 23, 2013 10:37 PM
> To: [email-masked] WG

<snip>

> > While a good part of the interop / testing day is likely to be unstructured, it
> would be helpful if we have a discussion about what we'd like to test, who
> will be participating, etc., and -- ideally -- if someone is willing to do work on
> test frameworks, etc. Feel free to start that here, or on the devops list.
> >

Michelle Lai shared a protocol test draft on http-devops - http://www.ietf.org/mail-archive/web/http-devops/current/msg00004.html:

   This document suggests guidance and principles for testing
   HTTP/2.0 implementations. Goals are to improve the HTTP/2.0
   specification by mitigating the potential ambiguity of the
   protocol specification and improving interoperability of its
   implementations.

I propose an agenda item for the someone(s) "willing to do work on test frameworks" and principles. (Perhaps this could be done "task force style" similar to the SF interim) If a brief presentation would be helpful, please let us know.

Thanks,
...Brian

Brian Raymor
Senior Program Manager
Microsoft Open Technologies, Inc. 
A subsidiary of Microsoft Corporation

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 30 Sep 2013 16:33:58 +1000

Hi Brian,

> I propose an agenda item for the someone(s) "willing to do work on test frameworks" and principles. (Perhaps this could be done "task force style" similar to the SF interim) If a brief presentation…

That sounds great. How about we start things off on Wednesday with this discussion? A presentation would be very helpful.

Regards,