Subject: Updating Digest header RFC3230 using "selected representation"

From: Roberto Polli <[email-masked]>
Date: Tue, 16 Apr 2019 11:25:57 +0200

Hi @all,

as the Digest header is still used, I'm willing to refresh the old spec

- https://tools.ietf.org/html/rfc3230

using the new definitions of RFC723x (eg. selected representation)
and untagling it from delta-encoding.

Is there somebody interested in supporting that effort?

Thanks and have a nice day,
R.

-- 
Roberto Polli
Full Stack Developer
M. +39 3406522736
·D
TEAM PER LA
TRASFORMAZIONE
DIGITALE
Presidenza del Consiglio dei Ministri
teamdigitale.governo.it

Il Team per la Trasformazione Digitale, salvo eccezioni, comunica con
le altre Amministrazioni via posta elettronica ordinaria e non posta
elettronica certificata, in conformità a quanto previsto dall’art.47
del Codice dell’Amministrazione Digitale.

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 16 Apr 2019 10:33:18 +0100

Hi Roberto,

Yes I would like to see an update. This spec is no longer consistent with
other HTTP docs, and leads to some circular arguments. Despite that I think
it still has a valid use.

I'd like to see the document updated to align with the current HTTP core
work, I'm happy to help if I can.

Lucas

---

From: Roberto Polli <[email-masked]>
Date: Tue, 16 Apr 2019 11:44:33 +0200

Hi Lucas,

Il giorno mar 16 apr 2019 alle ore 11:33 Lucas Pardue
<[email-masked]> ha scritto:
> On Tue, 16 Apr 2019, 10:29 Roberto Polli, <[email-masked]> wrote:

> Yes I would like to see an update.
> This spec is no longer consistent with other HTTP docs, and leads to some circular arguments.
> Despite that I think it still has a valid use.
Great! Here's an editable google docs:

  - https://docs.google.com/document/d/1p8KBR_dQKfh7PgLTOYXg_htMAME8nnEblKRC0DSH5_o/edit

> I'd like to see the document updated to align with the current HTTP core work, I'm happy to help if I can.
I need some guidance on the ietf workflow (Eg. proposing the draft,
..) as it's the first time
I'm doing that :D

I hope that the technical side can converge quic-ly :D

Have a nice day,

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 16 Apr 2019 10:54:07 +0100

I think you're on the right track.

Present a salient problem statement, seek others also interested, prepare
some text that address the problem (Google doc is ok to start with,
focusing on content not formatting). At some point we can get an individual
Internet Draft prepared (markdown GitHub workflow is relatively
straightforward) and see if a working group like HTTPbis has interest in
adopting it for further work / publication.

Lucas

On Tue, 16 Apr 2019, 10:44 Roberto Polli, <[email-masked]>
wrote:

>   -
> https://docs.google.com/document/d/1p8KBR_dQKfh7PgLTOYXg_htMAME8nnEblKRC0DSH5_o/edit
>