Subject: Call For Adoption: HTTP/2 and TLS 1.3 post-handshake authentication

From: Patrick McManus <[email-masked]>
Date: Mon, 15 Apr 2019 15:02:00 -0400

Friendly Folk of HTTPbis,

A fortnight ago David Benjamin published
https://tools.ietf.org/html/draft-davidben-http2-tls13 as an individual
draft. It 'clarifies the use of TLS 1.3 post-handshake authentication and
key update with HTTP/2'.

Feedback both on the list and informally has been along the lines of
"that's what we all mean - it should be written down just like that".

To take advantage of David's kindness in writing it down, we're going to
issue a call for adoption for using this individual draft as the starting
point for a working group document with David as the author.

This email starts a call for adoption. Please reply to this email with your
thoughts, and state whether or not you believe the group should adopt this
document. Feedback is requested by *Monday**, April 29*.

Thanks!

-Patrick

---

From: "Christopher Wood" <[email-masked]>
Date: Mon, 15 Apr 2019 15:43:26 -0400

Adopt it. And thanks to David to writing it down!

On Mon, Apr 15, 2019, at 12:06 PM, Patrick McManus wrote:
> draft. It 'clarifies the use of TLS 1.3 post-handshake authentication 
> and key update with HTTP/2'.
> 
> To take advantage of David's kindness in writing it down, we're going 
> to issue a call for adoption for using this individual draft as the 
> starting point for a working group document with David as the author.
> 
> This email starts a call for adoption. Please reply to this email with 
> your thoughts, and state whether or not you believe the group should 
> adopt this document. Feedback is requested by *Monday**, April 29*.
> 
> Thanks!
> 
> -Patrick
>

---

From: David Schinazi <[email-masked]>
Date: Wed, 17 Apr 2019 12:07:33 -0700

I support adoption. Thanks David!

David

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 23 Apr 2019 06:27:03 -0400

This is the only sensible conclusion; and we should thank David for writing it down for us.

On Thu, Apr 18, 2019, at 05:11, David Schinazi wrote:
> On Mon, Apr 15, 2019 at 11:43 PM Christopher Wood <[email-masked]> wrote:

---

From: Mike Bishop <[email-masked]>
Date: Tue, 30 Apr 2019 20:06:03 +0000

Late to the party, but yes.

David wrote this draft because I didn’t think it was appropriate for Secondary Certs (as an extension) to mandate HTTP/2 behavior outside of implementors of Secondary Certs and wouldn’t take his PR in that document.  I fully support the text itself.  Here it is, and we should adopt and publish it.

From: Patrick McManus <[email-masked]>
Sent: Monday, April 15, 2019 12:02 PM
To: HTTP Working Group <[email-masked]>
Subject: Call For Adoption: HTTP/2 and TLS 1.3 post-handshake authentication

A fortnight ago David Benjamin published https://tools.ietf.org/html/draft-davidben-http2-tls13 as an individual draft. It 'clarifies the use of TLS 1.3 post-handshake authentication and key update with HTTP/2'.

Feedback both on the list and informally has been along the lines of "that's what we all mean - it should be written down just like that".

To take advantage of David's kindness in writing it down, we're going to issue a call for adoption for using this individual draft as the starting point for a working group document with David as the author.

This email starts a call for adoption. Please reply to this email with your thoughts, and state whether or not you believe the group should adopt this document. Feedback is requested by Monday, April 29.

Thanks!

-Patrick