Subject: Status code 422 in http-core uses the term `entity`. Should we use `representation` ?

From: Roberto Polli <[email-masked]>
Date: Tue, 14 May 2019 17:38:52 +0200

Hi @all,

while reading httpbis-semantics I noted that:

- Status code 422 uses the term `entity`

I filed an issue:

- https://github.com/httpwg/http-core/issues/224

My proposals:

- it should use the term `representation`
- the definition should expand the original statements which are tied to webdav
  so that it could be more generic
- we could add one or two examples with the correct 422 usage

How would you manage it?

Regards,
R.
-- 
Roberto Polli
Full Stack Developer
M. +39 3406522736
·D
TEAM PER LA
TRASFORMAZIONE
DIGITALE
Presidenza del Consiglio dei Ministri
teamdigitale.governo.it

Il Team per la Trasformazione Digitale, salvo eccezioni, comunica con
le altre Amministrazioni via posta elettronica ordinaria e non posta
elettronica certificata, in conformità a quanto previsto dall’art.47
del Codice dell’Amministrazione Digitale.

---

From: Julian Reschke <[email-masked]>
Date: Wed, 15 May 2019 08:41:47 +0200

> - it should use the term `representation`

"enclosed representation"

>    so that it could be more generic

Please be more specific.

> - we could add one or two examples with the correct 422 usage

I'm not against examples, but we currently have none in this section.
Adding just a few for 422 would be weird.

> How would you manage it?

I'll take care of it.

Best regards, Julian

---

From: Roberto Polli <[email-masked]>
Date: Wed, 15 May 2019 10:33:07 +0200

Hi J,

> "enclosed representation"
Ok, I'm following the thread on gh.

> >    so that it could be more generic

Your PR https://github.com/httpwg/http-core/pull/226
clarifies, so it's ok

> Adding just a few for 422 would be weird.
Ok!

Thanks++,
R.