Subject: Communicating Warning Information in HTTP APIs

From: André Cedik <[email-masked]>
Date: Tue, 5 Nov 2019 19:58:36 +0100

Hey everyone,

Erik Wilde submitted an I-D on Monday - using the subject of this mail as
the title (see https://datatracker.ietf.org/doc/draft-cedik-http-warning/)
- that he and I wrote. It is our goal "to allow HTTP providers to have a
standardized way of communicating to their consumers that while the
response can be considered to be a non-failure, there is some warning
information available that they might want to take into account".

Shortly after we submitted the draft Julian Reschke notified us (see
https://github.com/dret/I-D/issues/125) that the Warning header is bound to
be removed with the next spec (draft-ietf-httpbis-cache). Which is very
unfortunate for the I-D since we wanted to use it for indicating that the
client would find additional information within the response body.

Since there is currently no other way of conveying this to an http client
(that we know of), we'd really like to get feedback if this is a use case
for which you would be willing to keep the Warning header or if there is
another way to make something like this possible.

Best
André Cedik

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 6 Nov 2019 16:50:54 +1100

Hi André,

My .02 is that Warning's semantics are not consistently used or implemented by intermediaries, which makes it less than useful. Its syntax is also... not great.

If you have use cases, I'd recommend minting a new header field and starting fresh, rather than trying to reuse it.

Cheers,

> On 6 Nov 2019, at 5:58 am, André Cedik <[email-masked]> wrote:
> 
> Hey everyone,
> 
> Erik Wilde submitted an I-D on Monday - using the subject of this mail as the title (see https://datatracker.ietf.org/doc/draft-cedik-http-warning/) - that he and I wrote. It is our goal "to allow HTTP providers to have a standardized way of communicating to their consumers that while the response can be considered to be a non-failure, there is some warning information available that they might want to take into account".
> 
> Shortly after we submitted the draft Julian Reschke notified us (see https://github.com/dret/I-D/issues/125) that the Warning header is bound to be removed with the next spec (draft-ietf-httpbis-cache). Which is very unfortunate for the I-D since we wanted to use it for indicating that the client would find additional information within the response body. 
> 
> Since there is currently no other way of conveying this to an http client (that we know of), we'd really like to get feedback if this is a use case for which you would be willing to keep the Warning header or if there is another way to make something like this possible.
> 
> Best
> André Cedik 

--
Mark Nottingham   https://www.mnot.net/

---

From: Roberto Polli <[email-masked]>
Date: Wed, 6 Nov 2019 17:45:45 +0100

Hi André,

Il giorno mer 6 nov 2019 alle ore 04:21 André Cedik
<[email-masked]> ha scritto:
> Julian Reschke notified us (see https://github.com/dret/I-D/issues/125) that the Warning header is bound to be removed with the next spec (draft-ietf-httpbis-cache

I'm very interested in that subject. Please keep me in the loop!

Pax,
R.