Subject: Call for Adoption: Extensible Prioritization Scheme for HTTP

From: Tommy Pauly <[email-masked]>
Date: Thu, 21 Nov 2019 15:28:18 +0800

Hello HTTPbis,

During our IETF 106 meetings, we received updates from the design team for updating HTTP's priority hinting mechanism, with the goals of defining priorities for HTTP/3 and allowing this scheme to be backported to HTTP/2.

The output of the design team is documented in this draft: https://tools.ietf.org/html/draft-kazuho-httpbis-priority-04

This draft defines:
- A SETTINGS parameter to disable the HTTP/2 priority mechanism
- Two priority values, urgency (0-7), and incremental (boolean)
- Mechanisms to communicate these priority values using headers and frames

This email begins a call for Working Group adoption of this draft. Note that adoption indicates that we, as a working group, want to use draft-kazuho-httpbis-priority as a basis for the definition of priorities for HTTP/3. There is still ongoing discussion that will continue, specifically around the mechanism for end-to-end and hop-by-hop signaling.

This call will end on Friday, December 6. Please reply to this email and indicate whether or not you believe we should adopt this document!

Best,
Tommy & Mark

---

From: Patrick McManus <[email-masked]>
Date: Thu, 21 Nov 2019 17:23:25 +0800

I strongly support adoption. We don't want to end up with a gap in client
priority due to the h3 transition so timeliness matters. The broad input it
has already received makes it the right candidate for the WG to begin work
on - the core tension around e2e vs hop-2-hop is one we have in a number of
places and is something we might just have to focus on how we can put as
much of it into upgradable pieces that we can replace later. In any event,
that's something for the WG to deal with after adoption.

-Patrick

On Thu, Nov 21, 2019 at 3:31 PM Tommy Pauly <[email-masked]> wrote:

> Hello HTTPbis,
>
> During our IETF 106 meetings, we received updates from the design team for
> updating HTTP's priority hinting mechanism, with the goals of defining
> priorities for HTTP/3 and allowing this scheme to be backported to HTTP/2.
>
> The output of the design team is documented in this draft:
> https://tools.ietf.org/html/draft-kazuho-httpbis-priority-04
>
> This draft defines:
> This email begins a call for Working Group adoption of this draft. Note
> that adoption indicates that we, as a working group, want to
> use draft-kazuho-httpbis-priority as a basis for the definition of
> priorities for HTTP/3. There is still ongoing discussion that will
> continue, specifically around the mechanism for end-to-end and hop-by-hop
> signaling.
>
> This call will end on *Friday, December 6*. Please reply to this email
> and indicate whether or not you believe we should adopt this document!
>
> Best,
> Tommy & Mark
>

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 21 Nov 2019 11:21:34 -0500

I vote to adopt.

  - Dmitri.

---

From: Brad Lassey <[email-masked]>
Date: Thu, 21 Nov 2019 11:41:26 -0500

I support adoption

On Thu, Nov 21, 2019 at 11:21 AM Dmitri Tikhonov <
[email-masked]> wrote:

> > During our IETF 106 meetings, we received updates from the design team
> for updating HTTP's priority hinting mechanism, with the goals of defining
> that adoption indicates that we, as a working group, want to use
> draft-kazuho-httpbis-priority as a basis for the definition of priorities
> for HTTP/3. There is still ongoing discussion that will continue,
> specifically around the mechanism for end-to-end and hop-by-hop signaling.
> >
> > This call will end on Friday, December 6. Please reply to this email and
> indicate whether or not you believe we should adopt this document!
> >
> > Best,
> > Tommy & Mark
>
>

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 21 Nov 2019 09:42:50 -0800

I strongly support the adoption of this work. (I'm skeptical of the
header-based mechanism for conveying this information, but as you said,
this discussion can continue in the WG).

---

From: Tom Bergan <[email-masked]>
Date: Thu, 21 Nov 2019 10:43:42 -0800

I echo Ryan's concerns but also strongly support adoption.

---

From: Daniel Stenberg <[email-masked]>
Date: Thu, 21 Nov 2019 22:31:38 +0100 (CET)

> https://tools.ietf.org/html/draft-kazuho-httpbis-priority-04

...

> indicate whether or not you believe we should adopt this document!

Another vote for adoption!

-- 

  / daniel.haxx.se

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 22 Nov 2019 17:12:26 +0800

> this discussion can continue in the WG).

This should be interesting.  I also think that we should adopt this, but I have reservations about the frame-based signaling.

---

From: Ryan Hamilton <[email-masked]>
Date: Fri, 22 Nov 2019 06:54:08 -0800

On Fri, Nov 22, 2019 at 1:15 AM Martin Thomson <[email-masked]> wrote:

> This should be interesting.  I also think that we should adopt this, but I
> have reservations about the frame-based signaling.
>

Hah! Well then....

---

From: Amos Jeffries <[email-masked]>
Date: Sat, 23 Nov 2019 18:33:15 +1300

Another vote for adoption.

IMO we had too many compromises aggregated in the h2 scheme that
complicated it in the end. It may be nice to try a selection of use-case
targeted prioritization schemes.

AYJ

On 21/11/19 8:28 pm, Tommy Pauly wrote:
> for updating HTTP's priority hinting mechanism, with the goals of
> defining priorities for HTTP/3 and allowing this scheme to be backported
> to HTTP/2.
> 
> continue, specifically around the mechanism for end-to-end and
> hop-by-hop signaling.
>