Subject: Working Group Last Call: HTTP Core Documents

From: Tommy Pauly <[email-masked]>
Date: Thu, 14 Jan 2021 09:49:22 -0800

Hello HTTP WG,

The time has come to start our Working Group Last Call for our current “core” documents! The issues list for these documents has been whittled down and we’re ready to have the working group review them in depth in preparation to progress them towards publication.

These are substantial drafts, so your time in reviewing is very much appreciated. We'll plan to have a three-and-a-half-week last call, so that we will get feedback prior to our planned interim dates. The last call will end on Monday, February 8, 2021.

The three drafts to review are:

HTTP Semantics, draft-ietf-httpbis-semantics
https://www.ietf.org/archive/id/draft-ietf-httpbis-semantics-14.html <https://www.ietf.org/archive/id/draft-ietf-httpbis-semantics-14.html>

HTTP/1.1, draft-ietf-httpbis-messaging
https://www.ietf.org/archive/id/draft-ietf-httpbis-messaging-14.html <https://www.ietf.org/archive/id/draft-ietf-httpbis-messaging-14.html>

HTTP Caching, draft-ietf-httpbis-cache
https://www.ietf.org/archive/id/draft-ietf-httpbis-cache-14.html <https://www.ietf.org/archive/id/draft-ietf-httpbis-cache-14.html>

Please send email to the working group list with comments and feedback, and state if you think these documents are ready to progress. You can also file issues here: https://github.com/httpwg/http-core/issues <https://github.com/httpwg/http-core/issues>.

Many thanks to Julian, Mark, and Roy for their hard work on editing these documents!

Best,
Tommy

---

From: "Roy T. Fielding" <[email-masked]>
Date: Fri, 15 Jan 2021 20:58:27 -0800

> On Jan 14, 2021, at 9:49 AM, Tommy Pauly <[email-masked]> wrote:
> 
> Hello HTTP WG,
> 
> https://www.ietf.org/archive/id/draft-ietf-httpbis-semantics-14.html
> 
> https://www.ietf.org/archive/id/draft-ietf-httpbis-messaging-14.html
> 
> https://www.ietf.org/archive/id/draft-ietf-httpbis-cache-14.html
> 
> Please send email to the working group list with comments and feedback, and state if you think these documents are ready to progress. You can also file issues here: https://github.com/httpwg/http-core/issues.
> 

If you are interested in seeing what words changed since RFC723x,
I have updated my Frankenstein diffs at

   https://httpwg.org/http-core/diffs/diff_semantics_frfc_to_14.html
   https://httpwg.org/http-core/diffs/diff_messaging_frfc_to_14.html
   https://httpwg.org/http-core/diffs/diff_cache_frfc_to_14.html

Note that these use manually rearranged original text, but not the
original section headings, to minimize the diffs and highlight changes,
deletions, and new text.

Cheers,

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 16 Jan 2021 16:58:05 +1100

One other thing -- the best starting point is probably the 'Changes from previous RFCs' section near the bottom of each one; that should list all of the normative changes in each. The subsequent Change Log is more detailed.

Note that even if you followed the issues when they were originally discussed, it's worthwhile re-checking the outcomes; because of the length of the effort, we've had to revisit issues sometimes (this comes to mind for two issues in Caching - updating stored headers and must-understand).

Cheers,

> On 16 Jan 2021, at 3:58 pm, Roy T. Fielding <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/