Subject: Re: Call for Adoption: draft-bdc-something-something-certificate-05

From: Justin Richer <[email-masked]>
Date: Wed, 7 Apr 2021 09:07:47 -0400

I support adoption of this document. It’s straightforward work, and it's my hope that the existence of an RFC will help nudge existing practices to be similar with each other.

 — Justin

> On Mar 31, 2021, at 7:26 PM, Mark Nottingham <[email-masked]> wrote:
> 
> Hello everyone,
> 
> This is a Call for Adoption for 'Client-Cert HTTP Header: Conveying Client Certificate Information from TLS Terminating Reverse Proxies to Origin Server Applications', found at:
>  https://www.ietf.org/archive/id/draft-bdc-something-something-certificate-05.html
> 
> The intended status of the document would be Informational. Please comment on whether you support adoption of this document. As always, adoption of a document is treated as a starting point, and its contents may change as part of the process.
> 
> The Call for Adoption will run until 14 April.
> 
> - Mark and Tommy

---

From: Brian Campbell <[email-masked]>
Date: Mon, 26 Apr 2021 09:02:02 -0600

The response to the Call for Adoption is pretty consistent with how the
draft has typically been received. The reception has been positive but
quite underwhelming. It seems pretty clear from this that the HTTP WG isn't
the right venue to progress this work (if that even happens at all).

On Wed, Mar 31, 2021 at 5:30 PM Mark Nottingham <[email-masked]> wrote:

> Hello everyone,
>
> This is a Call for Adoption for 'Client-Cert HTTP Header: Conveying Client
> Certificate Information from TLS Terminating Reverse Proxies to Origin
> Server Applications', found at:
>
> The intended status of the document would be Informational. Please comment
> on whether you support adoption of this document. As always, adoption of a
> document is treated as a starting point, and its contents may change as
> part of the process.
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 27 Apr 2021 01:10:03 +1000

Hi Brian,

Apologies for letting this slip off our radar; the Chairs should have communicated about this after the CfA ended. In other words, we had a calendar fail; please forgive us.

Regarding adoption - we take not only the responses to the CfA, but also previous discussion into account when considering the issue. Tommy and I will confer about this and get back to the group shortly.

Cheers,

> On 27 Apr 2021, at 1:02 am, Brian Campbell <[email-masked]> wrote:
> 
> The response to the Call for Adoption is pretty consistent with how the draft has typically been received. The reception has been positive but quite underwhelming. It seems pretty clear from this that the HTTP WG isn't the right venue to progress this work (if that even happens at all). 
> 
> CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited.  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

--
Mark Nottingham   https://www.mnot.net/

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Apr 2021 20:37:22 +0000

For what it's worth, I said (in the before-times) that I support this document, and that hasn't changed.  There is still a significant ecosystem using client certificates on the web, and while there are good reasons to encourage them to find other options, there's also value in being able to support them in a less-scattered way than the ecosystem currently does.

-----Original Message-----
From: Mark Nottingham <[email-masked]> 
Sent: Wednesday, March 31, 2021 7:27 PM
To: [email-masked] Group <[email-masked]>
Subject: Call for Adoption: draft-bdc-something-something-certificate-05

Hello everyone,

- Mark and Tommy

---

From: Roberto Polli <[email-masked]>
Date: Fri, 30 Apr 2021 19:07:24 +0200

FWIW I support this document.

Kind regards,
R: