Subject: Minor fix to ellipses in binary-messages

From: "Martin Thomson" <[email-masked]>
Date: Thu, 26 May 2022 10:00:48 +1000

https://github.com/httpwg/http-extensions/pull/2128 makes a very small change to the indetermine-length encoding diagram to remove an ellipsis as follows:

 Indeterminate-Length Response  {
   Framing Indicator (i) = 3,
   Indeterminate-Length Informational Response (..) ...,
   Final Response Control Data (..),
   Indeterminate-Length Field Section (..),
-  Indeterminate-Length Content (..) ...,
+  Indeterminate-Length Content (..),
   Indeterminate-Length Field Section (..),
   Padding (..),
 }

The same change is made for the request.  For context, this is how content is defined:

 Indeterminate-Length Content {
   Indeterminate-Length Content Chunk (..) ...,
   Content Terminator (i) = 0,
 }

Note that the removed ellipsis would mean that the Content could be repeated or omitted entirely, which would make it impossible to find the trailers if there are any.  The ellipsis on the Indeterminate-Length Content Chunk line is the intended and correct place; that doesn't change.

This aligns the picture with the prose, so this is *technically* not a design change, but I wanted to ensure that it was raised here given the state of the draft.  The known-length encoding doesn't have this problem.

Cheers,
Martin

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 25 May 2022 19:58:23 -0700

Hi Martin,

Thanks for fixing this. I did check over my code to make sure I had followed the prose and not the diagram, and everything looked good! I can’t imagine this will cause problems for anyone, since the intent of the text is pretty clear that the content section already handles its own repeated chunks and terminator.

Best,
Tommy

> On May 25, 2022, at 5:00 PM, Martin Thomson <[email-masked]> wrote:
>