Subject: [Hubmib] RE: Dot3OamEntry in EFM-COMMON-MIB

From: "Matt Squire" <[email-masked]>
Date: Thu, 19 Feb 2004 01:48:38 -0500

Hi Jayaprakash - 

Some responses in-line

> (1) Its a good idea that dot3Oam events need to be sent as SNMP traps.
> A SNMP trap can send all the attributes specified in the standard
> 
> But, I feel, running total fields would still need to be defined 
> in some table. What do you say?

Let me make sure I understand.  The defined error events provide thresholds for 
a) frame errors
b) symbol errors
c) errored seconds
We already have C30 counters and MIB variables for frame errors, so we do have a "running total" for frame errors.  But you're right in that I don't think we have symbol errors or errored seconds reflected in C30 or a MIB.  

My guess is that it may be possible to get a counter for errored seconds in the MIB.  A symbol error has been discussed in the past, and my recollection is that the majority of people were very against it as it has such a high update rate that it would be hard to maintain accurately across the management interfaces provided.  So I don't know that getting a symbol error counter into C30 would float, and if its not there, we're not going to get a counter in the MIB.  

> (2) A seperate issue regarding dot3OamEventConfigTable:
> 
> How do we set the peer values for entities defined in this table,
>  as I understand peer entities are not a part of the ifTable, will 
> there be a dot3OamPeerEventConfigTable? In that case SNMP traps 
> for dot3OamPeer events also needs to be defined.
>
> your thoughts?
>

Dot3 OAM had the self-imposed mandate for no "set" capability.  If you want to "set" parameters on a remote device, it could be done either locally at that device (e.g. CLI), or via telnet/SNMP/whatever.  But .3ah OAM can't help configure a peer entity.  

We've tried to pick defaults so that configuration, in most cases, isn't required.  

- Matt

> regards
> Jayaprakash

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "Matt Squire" <[email-masked]>
Date: Thu, 19 Feb 2004 01:48:38 -0500

Hi Jayaprakash - 

Some responses in-line

- Matt

---

From: Rajagopalan Subramanian <[email-masked]>
Date: Thu, 19 Feb 2004 21:58:25 -0800

Hi Matt,
Its good to have Traps to report whenever there is an OAM event. 
 
But according to the 802.3ah Standard, in the section 30A.19,
aOAMLocalErrSymPeriodEvent and aOAMRemoteErrSymPeriodEvent are listed as
'GET' attributes of am OAM object class.
The definition for these in the sections 30.11.1.1.30 and 30.11.1.1.37 also
implies that they should be updated as and when we receive or send an Event
Notification.
This made me believe that these events should also be maintained as SNMP
(statistics) table attributes.
 
Your thoughts please.
 
Thanks
Raj Subramanian

-----Original Message-----
From: Matt Squire [mailto:[email-masked]] 
Sent: Friday, February 06, 2004 9:14 AM

Thats a good question.  I'm still a little unsure of how to best map the
event tables into MIB stuff.  But we will almost definitly include the
running totals into the event information, along with all of the other
fields in the event TLVs.  
 
One possibility is to simply map each OAM event to a notification (SNMP
trap), where we take all fields (including the running totals) into the
trap.  Thats the way I'm leaning presently, where we don't maintain any SNMP
tables for the events, and instead just map them to SNMP traps.  If you
think thats good/bad, let me know.  
 
- Matt
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 20, 2004 6:24 AM
To: Matt Squire
Subject: Dot3OamEntry in EFM-COMMON-MIB
Hi Matt
 
Got one more doubt while going through the
draft-squire-hubmib-efm-mib-00.txt
 
Are you planning to provide the following running-total counters in the
Dot3OamEntry along with the dot3OamThreshold and Config objects?
 
dot3OamErrSymRunningTotal
dot3OamErrFrameSecsSummaryRunningTotal
dot3OamErrFrameRunningTotal
dot3OamErrFramePeriodRunningTotal
 
regards
Jayaprakash

Confidentiality Notice

The information contained in this electronic message and any attachments to
this message are intended
for the exclusive use of the addressee(s) and may contain confidential or
privileged information. If
you are not the intended recipient, please notify the sender at Wipro or
[email-masked] immediately
and destroy all copies of this message and any attachments.

Confidentiality Notice

The information contained in this electronic message and any attachments to
this message are intended

for the exclusive use of the addressee(s) and may contain confidential or
privileged information. If

you are not the intended recipient, please notify the sender at Wipro or
[email-masked] immediately

and destroy all copies of this message and any attachments.

---

From: Rajagopalan Subramanian <[email-masked]>
Date: Thu, 19 Feb 2004 21:58:25 -0800

Hi Matt,

Your thoughts please.
 
Thanks
Raj Subramanian

-----Original Message-----
From: Matt Squire [mailto:[email-masked]] 
Sent: Friday, February 06, 2004 9:14 AM

 
 
- Matt
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 20, 2004 6:24 AM
To: Matt Squire
Subject: Dot3OamEntry in EFM-COMMON-MIB
Hi Matt

 
 
regards
Jayaprakash

Confidentiality Notice

Confidentiality Notice

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 20 Feb 2004 18:56:42 +0200

Raj,
 
There is no need to keep a strict relationship between the Clause 30 definitions and the SNMP MIB. From a Hubmib Charter point of view, we are looking at the IEEE 802.3 standard as a source and reference for the IETF MIBs, but we are allowed to take different approaches when needed. From a technical point of view Clause 30 describes the MAC level management model, while the SNMP MIB, may take a different approach, dictated by the operational requirements of management in an Internet environment. 
 
On a different note, I would recommend to use the correct SNMP terminology - i.e. Notifications, rather than Traps (which are a sub-set of SNMPv3 Notifications).
 
Regards,
Dan
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Rajagopalan Subramanian
Sent: 20 February, 2004 7:58 AM
To: [email-masked]'
Cc: [email-masked]'
Subject: [Hubmib] RE: Dot3OamEntry in EFM-COMMON-MIB

Hi Matt,
 
But according to the 802.3ah Standard, in the section 30A.19, aOAMLocalErrSymPeriodEvent and aOAMRemoteErrSymPeriodEvent are listed as 'GET' attributes of am OAM object class.
The definition for these in the sections 30.11.1.1.30 and 30.11.1.1.37 also implies that they should be updated as and when we receive or send an Event Notification.
This made me believe that these events should also be maintained as SNMP (statistics) table attributes.
 
Your thoughts please.
 
Thanks
Raj Subramanian

-----Original Message-----
From: Matt Squire [mailto:[email-masked]] 
Sent: Friday, February 06, 2004 9:14 AM

Thats a good question.  I'm still a little unsure of how to best map the event tables into MIB stuff.  But we will almost definitly include the running totals into the event information, along with all of the other fields in the event TLVs.  
 
One possibility is to simply map each OAM event to a notification (SNMP trap), where we take all fields (including the running totals) into the trap.  Thats the way I'm leaning presently, where we don't maintain any SNMP tables for the events, and instead just map them to SNMP traps.  If you think thats good/bad, let me know.  
 
- Matt
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 20, 2004 6:24 AM
To: Matt Squire
Subject: Dot3OamEntry in EFM-COMMON-MIB
Hi Matt
 
Got one more doubt while going through the draft-squire-hubmib-efm-mib-00.txt
 
Are you planning to provide the following running-total counters in the Dot3OamEntry along with the dot3OamThreshold and Config objects?

regards
Jayaprakash

Confidentiality Notice

The information contained in this electronic message and any attachments to this message are intended
for the exclusive use of the addressee(s) and may contain confidential or privileged information. If
you are not the intended recipient, please notify the sender at Wipro or [email-masked] immediately
and destroy all copies of this message and any attachments.

Confidentiality Notice

The information contained in this electronic message and any attachments to this message are intended

for the exclusive use of the addressee(s) and may contain confidential or privileged information. If

you are not the intended recipient, please notify the sender at Wipro or [email-masked] immediately

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 20 Feb 2004 18:56:42 +0200

Raj,

 
Regards,
Dan
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Rajagopalan Subramanian
Sent: 20 February, 2004 7:58 AM
To: [email-masked]'
Cc: [email-masked]'
Subject: [Hubmib] RE: Dot3OamEntry in EFM-COMMON-MIB

Hi Matt,

Your thoughts please.
 
Thanks
Raj Subramanian

-----Original Message-----
From: Matt Squire [mailto:[email-masked]] 
Sent: Friday, February 06, 2004 9:14 AM

 
 
- Matt
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 20, 2004 6:24 AM
To: Matt Squire
Subject: Dot3OamEntry in EFM-COMMON-MIB
Hi Matt

 
 
regards
Jayaprakash

Confidentiality Notice

Confidentiality Notice

---

From: "Matt Squire" <[email-masked]>
Date: Thu, 26 Feb 2004 12:13:15 -0500

Thats a good point.  The difficulty is that the actual "statistic" is not available, but the "event" is available.  The difference being that if the event never happens, there is nothing in the event table, and therefore the info isn't there.  If the event does happen, the info is there in the event.  
 
Quite the predicament.
 
My thought would be that we make all of the event information available in the MIB, so that the running total is available when the event occurs, but to not try to introduce the actual statistics that do not currenly exist in the Ethernet MIB (for example, symbol errors).  
 
Does that work?
-----Original Message-----
From: Rajagopalan Subramanian [mailto:[email-masked]]
Sent: Friday, February 20, 2004 12:58 AM
To: Matt Squire
Cc: [email-masked]'
Subject: RE: Dot3OamEntry in EFM-COMMON-MIB

Hi Matt,

Your thoughts please.
 
Thanks
Raj Subramanian

-----Original Message-----
From: Matt Squire [mailto:[email-masked]] 
Sent: Friday, February 06, 2004 9:14 AM

 
 
- Matt
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 20, 2004 6:24 AM
To: Matt Squire
Subject: Dot3OamEntry in EFM-COMMON-MIB
Hi Matt

 
 
regards
Jayaprakash

Confidentiality Notice

Confidentiality Notice

---

From: "Matt Squire" <[email-masked]>
Date: Thu, 26 Feb 2004 12:13:15 -0500

Quite the predicament.

Does that work?
-----Original Message-----
From: Rajagopalan Subramanian [mailto:[email-masked]]
Sent: Friday, February 20, 2004 12:58 AM
To: Matt Squire
Cc: [email-masked]'
Subject: RE: Dot3OamEntry in EFM-COMMON-MIB

Hi Matt,

Your thoughts please.
 
Thanks
Raj Subramanian

-----Original Message-----
From: Matt Squire [mailto:[email-masked]] 
Sent: Friday, February 06, 2004 9:14 AM

 
 
- Matt
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 20, 2004 6:24 AM
To: Matt Squire
Subject: Dot3OamEntry in EFM-COMMON-MIB
Hi Matt

 
 
regards
Jayaprakash

Confidentiality Notice

Confidentiality Notice