Subject: [Hubmib] EPON MIB document - alignment in the enumerations of the dot3Epon FecAbility object to the equivalent IEEE802.3 attribute

From: Lior Khermosh <[email-masked]>
Date: Tue, 3 Apr 2007 00:31:02 -0700

Hi all,
In the EPON MIB document (draft-ietf-hubmib-efm-epon-mib-06.txt) there is a mismatch in the dot3EponFecAbility enumerations to the equivalent IEEE802.3 attribute.

dot3EponFecAbility OBJECT-TYPE
    SYNTAX  INTEGER {
             unknown(1),
             unsupported(2),
             supported(3)

In the IEEE spec the equivalent attribute has a different order:
 
30.5.1.1.13 aFECAbility
ATTRIBUTE
APPROPRIATE SYNTAX:
A ENUMERATION that meets the requirement of the description below
unknown           initializing, true state not yet known
supported          FEC supported
not supported    FEC not supported

The document is in the AUTH48 stage in the RFC editing queue.
Although the document is in it's very final stages I think it be better fixed. It was brought into my attention by some of the implementers of the MIB asking for the change and it has a lot of sense in keeping the same enumerations to avoid possible confusion in different implementations.
The proposed change in the EPON MIB is:

  dot3EponFecAbility OBJECT-TYPE
     SYNTAX  INTEGER {
              unknown(1),
              unsupported(2),
              supported(3)

to be changed to:

  dot3EponFecAbility OBJECT-TYPE
     SYNTAX  INTEGER {
              unknown(1),
              supported(2),
              unsupported(3)

If there is any objection to this action please respond to this mail.
So unless there is any objection to this change by let's say the 10th of April, I will proceed with the action.

Sorry for the late change,

Best regards,
Lior

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Tue, 3 Apr 2007 09:56:56 +0200

Thanks Lior, for bringing this to the attention of the WG and the IESG.

I think this change (even at this late point in the process) makes
sense.
It is a somewhat technical change, so we need to make sure the WG 
(and IESG) are OK with it.

Thanks for also copy-ing the IEEE 802.3 chair and vice-chair. I would
appreciate if they can also let us know if this change indeed makes
sense as we (Lior and I) think.

Therefor, (speaking as WG chair), I ask that HUBMIB WG members do indeed

speak up BEFORE April 10th if they see any issue with this proposal.

If nobody speaks up, then we will ask our AD to approve the change.

Bert Wijnen
HUBMIB WG chair.

> -----Original Message-----
> From: Lior Khermosh [mailto:[email-masked]] 
> Sent: dinsdag 3 april 2007 9:31
> To: [email-masked]'
> Cc: [email-masked]'; 
> [email-masked]'; [email-masked]'; 
> [email-masked]'; Wijnen, Bert (Bert); 
> [email-masked]'; [email-masked]'
> Subject: EPON MIB document - alignment in the enumerations of 
> the dot3EponFecAbility object to the equivalent IEEE802.3 attribute
> 
> Hi all,
> In the EPON MIB document 
> (draft-ietf-hubmib-efm-epon-mib-06.txt) there is a mismatch 
> in the dot3EponFecAbility enumerations to the equivalent 
> IEEE802.3 attribute.
> 
> Although the document is in it's very final stages I think it 
> be better fixed. It was brought into my attention by some of 
> the implementers of the MIB asking for the change and it has 
> a lot of sense in keeping the same enumerations to avoid 
> possible confusion in different implementations.
> So unless there is any objection to this change by let's say 
> the 10th of April, I will proceed with the action.
>