Subject: Re: IETF solution for pairing cellular hosts

From: "Virendra Gandhi" <[email-masked]>
Date: Wed, 26 Sep 2007 20:23:47 +0530

Hi Pars,
This is the classic John Smith problem, what you mention comes after
the target is identified, but first comes the John Smith problem,
there could be multiple John Smiths so it is necessary which John
Smith the querier  wants further as is also mentioned by others in
these discussions the location has to also come into play.

An interesting quote "Names are an important key to what a society
values. Anthropologists recognize naming as 'one of the chief methods
for imposing an order on perception'. David Slawson.

So first Naming has to be set right mentioned here an example of the
magnitude of this problem, Recently there was an article that mentions
quote " Shanghainese frustrated over name game" in which it states
that there are over 3937 people named Chen Jie and 3751 people named
Zhang Min and purely in terms of Surnames (last name) Zhang comes out
first with almost 90000 occurrences Unquote. Similarly practically
every third person in Korea is a Kim and if I talk about Indians I bet
you must have heard of at least one Patel not to mention John Smith in
any English speaking country. It is necessary not only to know which
Zhang or Patel or John Smith one is talking about but also to trace
/locate/ search the right one universally from Domain or related way.

I am working on Naming and it could not only solve the problem
mentioned by you but also others like say one of the ideas prevailing
during the dot com boom was that if one is driving around and passes
by a restaurant and wants to talk to people for reservation it would
be possible and other problems of Convergence for example titled 'The
beast of complexity' Apr 12th 2001 From The Economist print edition
Stuart Feldman the director of IBM's Institute for Advanced Commerce
states, Quote "Imagine, says the man from IBM, that you are running on
empty and want to know the cheapest open petrol station within a mile.
You speak into your cellphone, and seconds later you get the answer on
the display. This sounds simple, but it requires a combination of a
multitude of electronic services, including a voice-recognition and
natural-language service to figure out what you want, a location
service to find the open petrol stations near you and a
comparison-shopping service to pick the cheapest one. Unquote. Now
such services would require a platform where 'all users and service
providers' are registered, this (Won) would then be the platform for
all such net services and also help enabling compatibility and
convergence. Yet again this would only be possible if the Namespace
problem is solved.

 The cell phone will definitely enable wonders but first Naming has to
be in place

World On Net.
Virendra Gandhi

On 9/26/07, Pars Mutaf <[email-masked]> wrote:
>
> On 9/26/07, [email-masked] <[email-masked]> wrote:
> > >Please refer to my first mail. There are three basic problems that I
> > see.
> >
> > >1. You don't want to publish your private information
> > >2. Manual exchange is difficult
> >
> > Ridiculous! I give my phone to the other person and ask
> > them to dial my number and call me. Now we both have a
> > record of each others' phone numbers.
>
> SIP URIs and home addresses are too long (an IPv6 address
> is 16 bytes long and random looking, a SIP URI can be very
> long e.g. up to 30 characters and even more with a random
> part for privacy).
>
> I would appreciate comments on this. Maybe we should move
> to the mailing list if you are interested?
>
> https://www1.ietf.org/mailman/listinfo/humanresolvers
>
>
> > >3. Face-to-face contact is not always available
> >
> > I can't believe that I'm reading this in an email message.
> > Some people put their phone number in the signature block.
> > Others type it in when requested. Most mobile devices have
> > a way to sync a phonebook with a PC. Job done.
>
> I don't understand.
>
> > >The proposed solution is the only one that addresses these three
> > problems.
> >
> > Seems to me that you have only one real problem and we
> > can adress that (number 1 above) by simply doing nothing.
>
> I really don't understand.
>
>
> > --Michael Dillon
> >
> > P.S. I did design a method vaguely similar to this for exchanging
> > contact information between mobile phone users that required the
> > support of the mobile network operator.
>
>
> I would be interested. Is there an I-D or something?
>
>
> pars
>
>
>
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> >
>
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
>
>

_______________________________________________
humanresolvers mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/humanresolvers

---

From: "Virendra Gandhi" <[email-masked]>
Date: Thu, 27 Sep 2007 10:55:47 +0530

True but thank god this is not the case here, cause if it was then
imagine the problems for pairing cellular hosts, but that's neither
here nor there. The point is Naming has to be in place (to my mind
above all else) to enable a lot of things.

Virendra Gandhi

On 9/26/07, IETF member Dave Aronson <[email-masked]> wrote:
> Virendra Gandhi [mailto:[email-masked]] writes:
>
>  > This is the classic John Smith problem,
>
> As an interesting (at least to me) side note:  The most common *given* name in the world is Mohammed.  The most common *family* name in the world is Chang.  This does *not* mean that Mohammed Chang is a common name....
>
> :-)
>
> --
> Dave Aronson
> "Specialization is for insects."  -Heinlein
> Work: http://www.davearonson.com/
> Play: http://www.davearonson.net/
>
>
>