Subject: [hybi] RFC 6455 on The WebSocket Protocol

From: [email-masked]
Date: Sun, 11 Dec 2011 14:18:10 -0800 (PST)

A new Request for Comments is now available in online RFC libraries.

        RFC 6455

        Title:      The WebSocket Protocol 
        Author:     I. Fette, A. Melnikov
        Status:     Standards Track
        Stream:     IETF
        Date:       December 2011
        Mailbox:    [email-masked], 
                    [email-masked]
        Pages:      71
        Characters: 162067
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-hybi-thewebsocketprotocol-17.txt

        URL:        http://www.rfc-editor.org/rfc/rfc6455.txt

The WebSocket Protocol enables two-way communication between a client
running untrusted code in a controlled environment to a remote host
that has opted-in to communications from that code.  The security
model used for this is the origin-based security model commonly used
by web browsers.  The protocol consists of an opening handshake
followed by basic message framing, layered over TCP.  The goal of
this technology is to provide a mechanism for browser-based
applications that need two-way communication with servers that does
not rely on opening multiple HTTP connections (e.g., using
XMLHttpRequest or <iframe>s and long polling).  [STANDARDS-TRACK]

This document is a product of the BiDirectional or Server-Initiated HTTP Working Group of the IETF.

This is now a Proposed Standard Protocol.

STANDARDS TRACK: This document specifies an Internet standards track
protocol for the Internet community,and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Internet
Official Protocol Standards (STD 1) for the standardization state and
status of this protocol.  Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  http://www.ietf.org/mailman/listinfo/ietf-announce
  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see http://www.rfc-editor.org/rfcsearch.html.
For downloading RFCs, see http://www.rfc-editor.org/rfc.html.

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 11 Dec 2011 15:59:07 -0700

Congratulations to the working group, with special thanks to Ian and
Alexey for all their work on the document!

On 12/11/11 3:18 PM, [email-masked] wrote:
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi

---

From: Gabriel Montenegro <[email-masked]>
Date: Mon, 12 Dec 2011 01:57:38 +0000

In addition to Ian and Alexey, a very special thanks to our AD, Peter, for a very active and helpful involvement to help the document towards RFChood.

chairs

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Peter Saint-Andre
> Sent: 11 December, 2011 14:59
> To: [email-masked]
> Subject: Re: [hybi] RFC 6455 on The WebSocket Protocol
> 
> Congratulations to the working group, with special thanks to Ian and Alexey for
> all their work on the document!
> 
> > followed by basic message framing, layered over TCP.  The goal of this
> > technology is to provide a mechanism for browser-based applications
> > that need two-way communication with servers that does not rely on
> > opening multiple HTTP connections (e.g., using XMLHttpRequest or
> > <iframe>s and long polling).  [STANDARDS-TRACK]
> >
> > protocol for the Internet community,and requests discussion and
> > suggestions for improvements.  Please refer to the current edition of
> > the Internet Official Protocol Standards (STD 1) for the
> > standardization state and status of this protocol.  Distribution of this memo is
> unlimited.
> >
> > author of the RFC in question, or to [email-masked].
> > Unless specifically noted otherwise on the RFC itself, all RFCs are
> > for unlimited distribution.
> >
> >
> > The RFC Editor Team

---

From: Tim Bray <[email-masked]>
Date: Sun, 11 Dec 2011 18:33:38 -0800

Since I didn't do any of the it, I can safely say: Great Work!  -T

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Mon, 12 Dec 2011 04:35:39 +0100

>Alexey for all their work on the document!

(I assume by "Ian" Peter means Ian Fette and Ian Hickson.)
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Salvatore Loreto <[email-masked]>
Date: Mon, 12 Dec 2011 09:59:26 +0200

let me also thank
all the wg participants for their contributions to the technical 
discussions,
the people that have served as authors (Ian, Ian and Alexey) for their 
work on the document and
the ADs (Lisa, Alexey and Peter) for all the wise suggestions and 
guidance through the all journey

cheers
Sal

-- 
Salvatore Loreto
www.sloreto.com