Subject: [hybi] New WebSocket testsuite release

From: Tobias Oberstein <[email-masked]>
Date: Fri, 14 Mar 2014 13:14:20 -0700

Hello,

we've just released a new version 0.6.1 of Autobahn|Testsuite which now includes >500 test cases in total.

https://pypi.python.org/pypi/autobahntestsuite

The new test cases are all for "permessage-deflate" (test sections 12 and 13) and now cover

- various different parameter negotiations
- message fragmentation with permessage-deflate

everything of course both for testee clients and testee servers.

Here are Chrome and Autobahn (client) .. scroll down to sections 12/13 for the new tests:

http://autobahn.ws/testsuite/reports_20140314/clients/index.html

Roadmap:
If time permits, we'll be working on adding "permessage-priority" to both Autobahn|Python and Autobahn|Testsuite
https://github.com/oberstet/permessage-priority/blob/master/draft-oberstein-hybi-permessage-priority.txt

Cheers,
/Tobias

---

From: Joakim Erdfelt <[email-masked]>
Date: Fri, 14 Mar 2014 13:23:28 -0700

Any new negotiation checks yet?

Such as the more strict Sec-WebSocket-Protocol rules from Chrome 33
(courtesy of the Javascript WebSocket API)?

--
Joakim Erdfelt <[email-masked]>
webtide.com <http://www.webtide.com/> - intalio.com/jetty
Expert advice, services and support from from the Jetty & CometD experts
eclipse.org/jetty - cometd.org

On Fri, Mar 14, 2014 at 1:14 PM, Tobias Oberstein <
[email-masked]> wrote:

> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi
>

---

From: Tobias Oberstein <[email-masked]>
Date: Fri, 14 Mar 2014 13:26:31 -0700

no, sorry, lack of time (this whole testsuite baby already ate much much more time I ever planned for)

"opening handshake" testing is still missing ..

the fuzzing kicks in after handshake .. also rgd permessage-deflate .. but it will catch if the implementation is wrong wrt to the negotiated parameters.

Von: Joakim Erdfelt [mailto:[email-masked]]
Gesendet: Freitag, 14. März 2014 21:23
An: Tobias Oberstein
Cc: [email-masked]
Betreff: Re: [hybi] New WebSocket testsuite release

Such as the more strict Sec-WebSocket-Protocol rules from Chrome 33 (courtesy of the Javascript WebSocket API)?

--
Joakim Erdfelt <[email-masked]<mailto:[email-masked]>>
webtide.com<http://www.webtide.com/> - intalio.com/jetty<http://intalio.com/jetty>
Expert advice, services and support from from the Jetty & CometD experts
eclipse.org/jetty<http://eclipse.org/jetty/> - cometd.org<http://cometd.org/>

On Fri, Mar 14, 2014 at 1:14 PM, Tobias Oberstein <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Roadmap:

Cheers,
/Tobias

_______________________________________________
hybi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hybi