Subject: [hybi] Generic WebSocket Subprotocol Close Code

From: Patrick Gansterer <[email-masked]>
Date: Thu, 16 Oct 2014 21:16:29 +0200

Hi,

I'd like to register the value 3000 as "generic subprotocol error" in the WebSocket Close Code Number Registry. Every subprotocol can use it then when it encounters problems with the received messages defined in the subprotocol, when there is no better matching error code defined.
I mailed with Alexey already, who suggested to ask on this mailing list for other opinions.

--
Patrick

---

From: Peter Thorson <[email-masked]>
Date: Mon, 20 Oct 2014 09:11:35 -0400

Is the idea that this would be similar in meaning to the 1002/protocol error except for errors in the subprotocol?

> On Oct 16, 2014, at 15:16 , Patrick Gansterer <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> hybi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hybi

---

From: Patrick Gansterer <[email-masked]>
Date: Mon, 20 Oct 2014 16:46:22 +0200

Yes.

We also might want to define an error similar to 1003/1007: If the subprotocol defines that all messages are encoded as JSON objects, then an invalid JSON object could lead to e.g. 3001 "subprotocol encoding error".

--
Patrick

---

From: Takeshi Yoshino <[email-masked]>
Date: Mon, 27 Oct 2014 22:33:14 +0900

So, two errors like this?

3000 Generic subprotocol error
3001 Invalid subprotocol data

BTW, what's the motivation? Providing default for convenience?

Takeshi

On Mon, Oct 20, 2014 at 11:46 PM, Patrick Gansterer <[email-masked]>
wrote:

> Yes.
>
> We also might want to define an error similar to 1003/1007: If the
> subprotocol defines that all messages are encoded as JSON objects, then an
> invalid JSON object could lead to e.g. 3001 "subprotocol encoding error".
>
> --
> Patrick
>
> > Is the idea that this would be similar in meaning to the 1002/protocol
> error except for errors in the subprotocol?
> >
> >> I'd like to register the value 3000 as "generic subprotocol error" in
> the WebSocket Close Code Number Registry. Every subprotocol can use it then
> when it encounters problems with the received messages defined in the
> subprotocol, when there is no better matching error code defined.