Subject: [I2nsf] FW: New Version Notification for draft-xia-i2nsf-capability-interface-im-00.txt

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 29 Jan 2015 00:45:54 +0000

Hi all,
We have written a draft to propose the information model for the I2NSF capability interface (between network controller with NSFs).
Please review it and warmly welcome your comments, suggestions.

Thanks!

B.R.
Frank

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, January 29, 2015 8:42 AM
> To: Dacheng Zhang; Xialiang (Frank); DaCheng Zhang; Xialiang (Frank)
> Subject: New Version Notification for
> draft-xia-i2nsf-capability-interface-im-00.txt
> 
> 
> A new version of I-D, draft-xia-i2nsf-capability-interface-im-00.txt
> has been successfully submitted by Liang Xia and posted to the IETF
> repository.
> 
> Name:		draft-xia-i2nsf-capability-interface-im
> Revision:	00
> Title:		Information Model of Interface to Network Security Functions
> Capability Interface
> Document date:	2015-01-29
> Group:		Individual Submission
> Pages:		12
> URL:
> http://www.ietf.org/internet-drafts/draft-xia-i2nsf-capability-interface-im-00.
> txt
> Status:
> https://datatracker.ietf.org/doc/draft-xia-i2nsf-capability-interface-im/
> Htmlized:
> http://tools.ietf.org/html/draft-xia-i2nsf-capability-interface-im-00
> 
> 
> Abstract:
>    This draft is focused on the NBI of NSFs and proposes an information
>    model for configuring various kinds NSF security functions. The Yang
>    structure and use examples are also presented to clarify how to use
>    the information model.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 29 Jan 2015 09:15:54 +0000

Hi Xiaojun,
Also thanks for your quick comments. My responses are as follows:
1. Do the rules have a priority?
[Frank]: Sure. We are considering to add this attribute to the rule in the next version.

2. How to know whether certain profiles are referenced in the rule? How to know which profile is performed?
[Frank]: Currently, the association between a rule and the its referenced profiles is through configuration. Also, the system has the log and report mechanisms which support the policy matching log and report.

3. Who or how to decides the logic relation among all the conditions?
[Frank]: I think it should be the network administrator.

4. Do you mean that traffic which not within the schedule can’t be filtered?
[Frank]: Yes. But here, maybe "matched" is more suitable than "filtered"~~

5. I suggest that the security profile definition can be removed to section 2.
[Frank]: Ok, I will consider it.

Thanks again!

B.R.
Frank

> From: xiaojun [mailto:[email-masked]]
> Sent: Thursday, January 29, 2015 4:54 PM
> To: Xialiang (Frank); [email-masked]
> Cc: 'Romascanu, Dan (Dan)'; 'Joseph Salowey'
> Subject: 答复: [I2nsf] FW: New Version Notification for
> Frank,
> Thanks for your greet job!
> I have some comments. Please see the attached document.
> 
> Best regards！
> 
> Xiaojun
> 
> -----邮件原件-----
> 发件人: I2nsf [mailto:[email-masked]] 代表 Xialiang (Frank)
> 发送时间: 2015年1月29日 8:46
> 收件人: [email-masked]
> 抄送: Romascanu, Dan (Dan); Joseph Salowey
> 主题: [I2nsf] FW: New Version Notification for
> We have written a draft to propose the information model for the I2NSF
> capability interface (between network controller with NSFs).
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Fri, 30 Jan 2015 04:52:56 +0000

Generally speaking, the answer is YES~~
But we do not exclude other options. For example, the NSF can be intelligent enough to support service interface directly.

B.R.
Frank

> Sent: Friday, January 30, 2015 11:50 AM
> I have a confusion: Both of your drafts include policy, rule, action. Do the
> security policy (draft-xia-i2nsf-security-policy-im-00.txt) map to policy in the
> information Model for I2NSF Capability Interface? Does network controller
> do this mapping?
> 
> 
> Best regards!
> 
> Xiaojun
> 
> -----邮件原件-----
> 发送时间: 2015年1月29日 17:16
> 收件人: xiaojun; [email-masked]
> 抄送: 'Romascanu, Dan (Dan)'; 'Joseph Salowey'
> 主题: Re: [I2nsf] FW: New Version Notification for
> [Frank]: Currently, the association between a rule and the its referenced
> profiles is through configuration. Also, the system has the log and report
> mechanisms which support the policy matching log and report.
> 
> > > https://datatracker.ietf.org/doc/draft-xia-i2nsf-capability-interfac
> > > e-
> > > im/
> > > Htmlized: