Subject: [I2nsf] Intent As The Common Interface to Network Resources (Dave Lenrow)

From: "Natale, Bob" <[email-masked]>
Date: Fri, 30 Jan 2015 15:29:20 +0000

Hi folks,

Apologies if you have already seen the attached, but Linda’s reference to “the HP hosted ‘Intent driven summit’” in an earlier message caused me to search it and that led me to contact Dave Lenrow of HP, who hosted it. The event happened earlier this month and they do intend to post content on the web, but that has not happened yet. Dave promised to send me the URL when it’s available and I will forward it then (unless not needed by the group). In the meantime, he did send the attached slides, which he used for the introductory session.

Avanti,
BobN

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 30 Jan 2015 16:20:35 +0000

Bob,

Thank you very much for sharing the Intent Networking Summit  slides. The Intent for Network Resources has also been discussed at the  ONF NBI group.

As said in the slide, the “intent is completely abstract”. I2NSF is intended to specify a concrete Security Policy Language both at the Service Layer and Functional Layer, hopefully be a branch to this whole industry “Intent Driven” initiative.

Linda
From: Natale, Bob [mailto:[email-masked]]
Sent: Friday, January 30, 2015 9:29 AM
To: Linda Dunbar; John Strassner; Xialiang (Frank); Romascanu, Dan (Dan); Joseph Salowey
Cc: [email-masked]
Subject: Intent As The Common Interface to Network Resources (Dave Lenrow)

Hi folks,

Avanti,
BobN

---

From: John Strassner <[email-masked]>
Date: Sat, 31 Jan 2015 22:03:56 +0000

Just to clarify what Linda said:

·         For me, replace “A concrete security policy language” with “A formal security policy language” (reason: I don’t know what “concrete” means, and “formal” implies specifying the language formally using either EBNF or ABNF)

·         IFF we assume that intent-based programming is similar to declarative programming (re: my earlier post), then our scope should be to build our formal language to support this style of programming (as opposed to, for example, an imperative style of programming)

·         I don’t agree with “being a branch to this whole industry ‘Intent Driven’ initiative”. One thing that was apparent at the Intent-based Networking Summit is that there are already multiple projects with multiple different interpretations of “intent”. This is, imho, a non-starter.

regards,
John

Dr. John Strassner, Ph.D.
CTO, Software Laboratory, CRD

Futurewei Technologies
US R&D Center
2330 Central Expressway
Building A, office A2-2143
Santa Clara, California   95050

  Office:  +1.408.330.4923
  Email:   [email-masked]

From: Linda Dunbar
Sent: Friday, January 30, 2015 8:21 AM
To: Natale, Bob; John Strassner; Xialiang (Frank); Romascanu, Dan (Dan); Joseph Salowey
Cc: [email-masked]
Subject: RE: Intent As The Common Interface to Network Resources (Dave Lenrow)

Bob,

Linda

Hi folks,

Avanti,
BobN