Subject: [I2nsf] Stability call for draft-ietf-i2nsf-terminology-03

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 18 May 2017 18:33:03 +0100

Hi WG,

The framework document got updated to match the terminology document which was a
good first test.

Now we would like to make sure that the terminology as currently documented is
something we can all work with. Hence this call for review and opinion.

Please respond to the question "Is the terminology draft stable?"

1. No. Major changes are needed.
If you do this you are duty bound to point out the problems, and you are
expected to help solve them.

2. Yes, but I haven't really read it.
If you do this we will chuckle and probably make you stand up at the next WG
meeting.

3. Yes, but I have some minor concerns.
You'll need to point them out and help fix them, but we will still be able to
consider the document as a good basis for future work.

4. Yes, I think this is something we can use as our foundation.

Note that Linda and I don't intend last-calling this document for a bit as we
suspect new terms will show up as other work progresses.

Cheers,
Adrian

---

From: John Strassner <[email-masked]>
Date: Thu, 25 May 2017 13:20:14 -0700

Hi Adrian,

I vote #4 (Yes, I think this is something we can use as our foundation).
Please note that we have (at least) some additional terminology to sort out
concerning attestation. Prior to that, I plan on doing a thorough review.
Any comments that you have are of course more than welcome!

best,
John

On Thu, May 18, 2017 at 10:33 AM, Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>

-- 
regards,
John

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 27 May 2017 11:59:25 -0400

Adrian: 

It appears due to my error, I did not respond to this quickly.   Answers
are: 

1) yes - no major changes needed
2) I've read it and edited the terminology document. 
3) It is good for a foundation. 

Sue 

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, May 18, 2017 1:33 PM
To: [email-masked]
Subject: [I2nsf] Stability call for draft-ietf-i2nsf-terminology-03

Hi WG,

The framework document got updated to match the terminology document which
was a good first test.

Now we would like to make sure that the terminology as currently documented
is something we can all work with. Hence this call for review and opinion.

3. Yes, but I have some minor concerns.
You'll need to point them out and help fix them, but we will still be able
to consider the document as a good basis for future work.

Note that Linda and I don't intend last-calling this document for a bit as
we suspect new terms will show up as other work progresses.

Cheers,
Adrian

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 27 May 2017 16:14:52 +0000

Hi,

Agree with John. It is mature and stable enough to be used as a foundation, though there are some additional terminology we’ll have to deal with.

Be goode,

On 25 May 2017, at 22:20 , John Strassner <[email-masked]<mailto:[email-masked]>> wrote:

Hi Adrian,

I vote #4 (Yes, I think this is something we can use as our foundation). Please note that we have (at least) some additional terminology to sort out concerning attestation. Prior to that, I plan on doing a thorough review. Any comments that you have are of course more than welcome!

best,
John

On Thu, May 18, 2017 at 10:33 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
Hi WG,

Cheers,
Adrian

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
regards,
John
_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: <[email-masked]>
Date: Mon, 29 May 2017 14:45:50 +0000

Hi Adrian, all,

Yes, but I have some minor concerns. Please find below some comments about this draft: 

* Please consider removing the use of the normative language in this text:

   Assertion:  Defined by the ITU in [X.1252] as "a statement made by
      an entity without accompanying evidence of its validity". In the
      context of I2NSF, an assertion MAY include metadata about all or
                                     ^^^^ 
      part of the assertion (e.g., context of the assertion, or about
      timestamp indicating the point in time the assertion was
      created). The validity of an assertion cannot be verified.
      (from [I-D.ietf-sacm-terminology]).

* Make the following change

OLD:

   Capability:  A set of features that are available from an I2NSF
      Component. These functions may, but do not have to, be used. All

NEW:

   Capability:  A set of features that are available from an I2NSF
      Component. These features may, but do not have to, be used. All

* I don't understand this text:

      "Examples are Capabilities that are available from an
      NSF Server."

Especially, what is an NSF Server?

* Consider removing these entries

Client:  See I2NSF Consumer.
Client-Facing Interface:  See I2NSF Consumer-Facing Interface.

I would avoid defining redundant entries. 

* I don't understand this one: 

   Component:  An encapsulation of software that communicates using
      Interfaces. A Component may be implemented by hardware and/or
      software, and be represented using a set of classes. In general,
      a Component encapsulates a set of data structures and a set of
      algorithms that implement the function(s) that it provides.

* What is an "Entity"? This term is called out in many entries. It would be OK if "entity" was used, but I guess the use of "Entity" is on purpose.  

* Not sure to understand why 'building block' is mentioned here. Saying that it is about how data is structured/organized would be simple, IMO.

   Data Structure:  A low-level building block that is used in
      programming to implement an algorithm. A data model typically
      contains multiple types of data structures; however, a data
      structure does not contain a data model. Note the difference
      between a data **model** and a data **structure**.

* Please double check the wording of this sentence: 

I2NSF Components are managed and communicate with other
      I2NSF Components using I2NSF Interfaces.

Cheers,
Med

> -----Message d'origine-----
> De : I2nsf [mailto:[email-masked]] De la part de Adrian Farrel
> Envoyé : jeudi 18 mai 2017 19:33
> À : [email-masked]
> Objet : [I2nsf] Stability call for draft-ietf-i2nsf-terminology-03
> 
> Hi WG,
> 
> was a
> to
> we