Subject: [I2nsf] Progress with draft-ietf-i2nsf-framework-05

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 18 May 2017 18:49:22 +0100

Hi WG,

I am about to do a document shepherd review prior to starting a WG last call. In
conversation with Linda just now I think I spotted a few areas where I am going
to make chunky suggestions for additional text, but overall the document looks
sound.

If you care deeply about this work and haven't looked at the framework for a
while, now would be a good time. Don't wait for WG last call.

Thanks,
Adrian

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Mon, 22 May 2017 03:32:20 +0000

Hi Adrian, I2NSFers,
I reviewed the latest draft again and thinks it's in a very good shape now. So, it can be a foundation for all the other drafts.

Of course, I also have some comments about it as below:
1. nits: P18 " Table 1: Subject Capability Index " should change to " Table 1: Packet Content Matching Capability Index ",  P19, " Table 2: Object Capability Index " should change to " Table 2: context matching Capability Index ";
2. Section 11 of Security Considerations: this section is a little bit simple without considering the possible threats like: unauthenticated connections between users and controller, and between controller and NSFs, DoS attacks from malicious users or NSFs, etc;
3. question: should section 7.3 move to the I2NSF gap analysis draft?
4. I think remote attestation function should be described as a part into the whole I2NSF framework;
5. Section 3.2, by my understanding, notification is just part of the monitor functions, such as: syslog, netconf. Is it necessary to divide them into two interfaces?

B.R.
Frank

-----邮件原件-----
发件人: I2nsf [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2017年5月19日 1:49
收件人: [email-masked]
主题: [I2nsf] Progress with draft-ietf-i2nsf-framework-05

Hi WG,

I am about to do a document shepherd review prior to starting a WG last call. In conversation with Linda just now I think I spotted a few areas where I am going to make chunky suggestions for additional text, but overall the document looks sound.

If you care deeply about this work and haven't looked at the framework for a while, now would be a good time. Don't wait for WG last call.

Thanks,
Adrian

_______________________________________________
I2nsf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2nsf

---

From: Rakesh Kumar <[email-masked]>
Date: Thu, 25 May 2017 19:41:35 +0000

Hi WG chairs,

I support going to WGLC for this draft.

Thanks
Rakesh
-----邮件原件-----
发件人: I2nsf [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2017年5月19日 1:49
收件人: [email-masked]
主题: [I2nsf] Progress with draft-ietf-i2nsf-framework-05

Hi WG,

Thanks,
Adrian

---

From: Rakesh Kumar <[email-masked]>
Date: Thu, 25 May 2017 20:15:00 +0000

Hi Frank,

Thanks for your review and support. We will make changes to the draft based on your comments and any other comments we receive in next few days.
Please see my take on your comments below.

Thanks
Rakesh

On 5/21/17, 8:32 PM, "I2nsf on behalf of Xialiang (Frank)" <[email-masked] on behalf of [email-masked]> wrote:

Hi Adrian, I2NSFers,

Of course, I also have some comments about it as below:
1. nits: P18 " Table 1: Subject Capability Index " should change to " Table 1: Packet Content Matching Capability Index ",  P19, " Table 2: Object Capability Index " should change to " Table 2: context matching Capability Index ";
[Rakesh]  Makes sense to me. We should take this.

2. Section 11 of Security Considerations: this section is a little bit simple without considering the possible threats like: unauthenticated connections between users and controller, and between controller and NSFs, DoS attacks from malicious users or NSFs, etc;
[Rakesh] In my opinion, this is just a framework document. Any specific of security considerations (such as you pointed out) should go into each individual drafts covering client, regigttration and NSF interfaces.  If you think it would help, we could add something like this to the section 11.

3. question: should section 7.3 move to the I2NSF gap analysis draft?
[Rakesh] I don’t have very strong opinion one way or other but it gives some context to other sections. It is good to have.

4. I think remote attestation function should be described as a part into the whole I2NSF framework;
[Rakesh] I agree with you.

5. Section 3.2, by my understanding, notification is just part of the monitor functions, such as: syslog, netconf. Is it necessary to divide them into two interfaces?
[Rakesh] In larger scheme of things, everything can be combined into one but it is good to show differentiation since each set serve different purpose and may require different operational characterstics.

B.R.
Frank

-----邮件原件-----
发件人: I2nsf [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2017年5月19日 1:49
收件人: [email-masked]
主题: [I2nsf] Progress with draft-ietf-i2nsf-framework-05

Hi WG,

Thanks,
Adrian

---

From: John Strassner <[email-masked]>
Date: Thu, 25 May 2017 13:16:52 -0700

Hi Adrian,

I have a few pending edits to the framework draft, but will not get to it
for about a week at least. Your comments will be more than welcome!

best,
John

On Thu, May 25, 2017 at 12:41 PM, Rakesh Kumar <[email-masked]> wrote:

> I am about to do a document shepherd review prior to starting a WG last
> call. In conversation with Linda just now I think I spotted a few areas
> where I am going to make chunky suggestions for additional text, but
> overall the document looks sound.
>
> If you care deeply about this work and haven't looked at the framework for
> a while, now would be a good time. Don't wait for WG last call.
>
> Thanks,
> Adrian
>
>
>

-- 
regards,
John

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 30 May 2017 13:24:26 -0500

I should complete my review mid next week.  But I suspect it will be 
nits.  I was quite comfortable with it earlier.

Frank is ahead of me...

Bob