Subject: [I2nsf] Warren Kumari's No Objection on draft-ietf-i2nsf-problem-and-use-cases-15: (with COMMENT)

From: Warren Kumari <[email-masked]>
Date: Tue, 09 May 2017 07:56:35 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-i2nsf-problem-and-use-cases-15: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-i2nsf-problem-and-use-cases/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I found the document to provide a useful overview and introduction - I
think that documents which provide an introduction to a technology are
useful, as they set the stage for users and implementers to understand
how everything ties together.

I thank the authors for writing it.

I also note that this is part of the I2NSF charter, and was written to
satisfy this.

---

From: Benoit Claise <[email-masked]>
Date: Tue, 9 May 2017 17:09:43 +0200

> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-problem-and-use-cases/
Indeed.
We clarified the situation of "support documents" with this IESG 
statement: 
https://www.ietf.org/iesg/statement/support-documents-in-ietf-wgs.html, 
dated Nov 2016.
The statement contains this key sentence IMO:

    As regards to timing, it would be worthwhile to discuss the need to
    publish support documents early during the charter development
    process in order to set the right expectations and minimize
    surprises at a late stage.

The authors produced the charter deliverables. Thanks for that.
Once a deliverable is in an existing charter, I don't really understand 
the meaning of abstaining.
The IESG statement should take effect for future charter discussions, 
not past charters.

Regards, Benoit
>
>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
> .
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 9 May 2017 11:27:44 -0400

On Tue, May 9, 2017 at 11:09 AM, Benoit Claise <[email-masked]> wrote:
> We clarified the situation of "support documents" with this IESG statement:
> As regards to timing, it would be worthwhile to discuss the need to publish
> support documents early during the charter development process in order to
> set the right expectations and minimize surprises at a late stage.
>
> Once a deliverable is in an existing charter, I don't really understand the
> meaning of abstaining.
> The IESG statement should take effect for future charter discussions, not
> past charters.

Agreed.  I also find support documents helpful and think that
following the statement is best as that's the guidance we have
provided to the community.  In the case of this document, the editors
did spend time resolving comments and changed it to an informational
draft, so that will hopefully help a few people who abstained
previously.

With that said, we'll talk about this at the retreat more as people
were very supportive of a recent overview document, but are not
supportive of use case documents.  If this is a distinction we expect
to continue, we should provide this guidance to working groups before
they charter.

Best regards,
Kathleen

-- 

Best regards,
Kathleen

---

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 9 May 2017 20:42:17 +0200

The i2nsf charter says

"A single document covering use cases, problem statement, and gap analysis 
document. This document will initially be produced for reference as a living 
list to track and record discussions: the working group may decide to not 
publish this document as an RFC."

It's okay for me that the wg decided that they want to publish this document 
(for whatever reason). I've read it and did not find it very useful for 
people outside the wg. However, that's why I abstain and not blocking it.

Mirja

On 09.05.2017 17:09, Benoit Claise wrote:
> https://www.ietf.org/iesg/statement/support-documents-in-ietf-wgs.html, dated
> Nov 2016.
>     publish support documents early during the charter development process in
>     order to set the right expectations and minimize surprises at a late stage.
>

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 9 May 2017 11:59:53 -0700

> On May 9, 2017, at 11:42 AM, Mirja Kühlewind <[email-masked]> wrote:
> 
> The i2nsf charter says
> 
> "A single document covering use cases, problem statement, and gap analysis document. This document will initially be produced for reference as a living list to track and record discussions: the working group may decide to not publish this document as an RFC."
> 
> It's okay for me that the wg decided that they want to publish this document (for whatever reason). I've read it and did not find it very useful for people outside the wg. However, that's why I abstain and not blocking it.

+1
Alissa

---

From: Benoit Claise <[email-masked]>
Date: Thu, 11 May 2017 14:35:30 +0200

Let's remind ourselves what the ABSTAIN is for.
 From https://www.ietf.org/iesg/voting-procedures.html :

  * *"Abstain"* means "I cannot support sending this document forward."
    There are two obvious reasons an AD might post this ballot position:

      o I am so strongly opposed to the document that I am unwilling to
        "discuss". (Note that this should be very unusual.)
      o I oppose this document but understand that others differ and am
        not going to stand in the way of the others.

    It is normal good practice for an AD to enter a Comment that
    explains the reason for their Abstain position.

"Not very useful" might fit in the HBU category (*), but that's a 
different situation IMO.

(*) HBU: "Harmless But Useless". Ron Bonica's copyright.

Regards, Benoit

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 11 May 2017 08:43:03 -0400

> On May 11, 2017, at 8:35 AM, Benoit Claise <[email-masked]> wrote:
> 
> From https://www.ietf.org/iesg/voting-procedures.html <https://www.ietf.org/iesg/voting-procedures.html> : 
> "Abstain" means "I cannot support sending this document forward." There are two obvious reasons an AD might post this ballot position: 
> 
> I am so strongly opposed to the document that I am unwilling to "discuss". (Note that this should be very unusual.)
> I oppose this document but understand that others differ and am not going to stand in the way of the others.
> It is normal good practice for an AD to enter a Comment that explains the reason for their Abstain position.
> 
> "Not very useful" might fit in the HBU category (*), but that's a different situation IMO.

Different from what? It’s each AD’s prerogative to decide why he or she may "oppose this document but understand that others differ.” It would not be wise to try to impose some standard on what others can find objectionable in an ABSTAIN ballot, IMO. 

Alissa

>>> On May 9, 2017, at 11:42 AM, Mirja Kühlewind <[email-masked]> <mailto:[email-masked]> wrote:
>>> 
>>> The i2nsf charter says
>>> 
>>>>> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html <https://www.ietf.org/iesg/statement/discuss-criteria.html>
>>>>> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-problem-and-use-cases/ <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-problem-and-use-cases/>
>>>>> 
>>>>> 
>>>>> 
>>>> https://www.ietf.org/iesg/statement/support-documents-in-ietf-wgs.html <https://www.ietf.org/iesg/statement/support-documents-in-ietf-wgs.html>, dated
>>>> Nov 2016.
>>>>> [email-masked] <mailto:[email-masked]>
>>>>> https://www.ietf.org/mailman/listinfo/i2nsf <https://www.ietf.org/mailman/listinfo/i2nsf>
>>>>> .
>>>>> 
>> .
>> 
>