Subject: Re: [I2nsf] Request for WG Adoption Call for I2NSF Data Model Drafts

From: John Strassner <[email-masked]>
Date: Thu, 2 Nov 2017 05:08:19 +0000

Hi Paul,

First, I attended that same call.

Second, my worry is that draft-kumar is not ready. It is not an information model; rather, it is (at best) requirements that could be turned into an information model. In addition, it needs to be integrated with the existing capability draft. Note that it is absolutely essential that we only have a single information model. Having multiple information models is akin to having multiple dictionaries; what inevitably happens is that the same concept is defined in multiple conflicting ways. I suggest that this document be examined in more detail to determine how best to proceed. I have already talked to Frank about that.

Third, we need to think about how we want to author data models. You have adopted a perfectly reasonable style, which is similar to how many YANG models are built. This is not object-oriented. However, the info model is in fact object-oriented, and so the question arises: do we follow existing style, or do we try and build YANG modules that are more object-oriented. I personally vote for the latter (see the SUPA data models for an example), but this should be decided by the WG. Until that is decided, I suggest that any data model is not ready for adoption.

Regards,
John

From: I2nsf [mailto:[email-masked]] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Tuesday, October 31, 2017 6:14 PM
To: John Strassner <[email-masked]>
Cc: [email-masked]; SecCurator_Team <[email-masked]>; Yoav Nir <[email-masked]>; Linda Dunbar <[email-masked]>
Subject: Re: [I2nsf] Request for WG Adoption Call for I2NSF Data Model Drafts

Hi John,
You are right. :-)

Actually, the authors of IM and DM documents for the client-facing interface
had a teleconference with Linda last September (9/27/2017).
We discussed how to correct the IM and how to synchronize these two IM and DM documents.

I joined the IM document as a co-author to synchronize them.

The current DM has the ECA policy model, but I need to modify something to synchronize them completely.
I think this synchronization is not a big deal because our IM is not so complicated and our DM is structured to
accommodate the IM.
During the WG adoption call, I will make these two IM and DM documents completely synchronized.

Thanks for your good suggestion.

Best Regards,
Paul

On Wed, Nov 1, 2017 at 2:26 AM, John Strassner <[email-masked]<mailto:[email-masked]>> wrote:
Wouldn't it be ore prudent to first have the design team meet to discuss alignment issues, and then proceed from the results of that?

regards,
John

On Tue, Oct 31, 2017 at 9:22 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Paul,

Got your request.

For I2NSF Consumer-Facing Interface YANG Data Model, I think it is better to be called together with
draft-kumar-i2nsf-client-facing-interface-im-04. Do you think draft-kumar-i2nsf-client-facing-interface-im-04 is ready?

Linda

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, October 30, 2017 8:24 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Yoav Nir <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; SecCurator_Team <[email-masked]<mailto:[email-masked]>>; Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>>
Subject: Request for WG Adoption Call for I2NSF Data Model Drafts

Dear Linda and Yoav,
Could you start the WG adoption call for the following three data model drafts?

1. I2NSF Capability YANG Data Model
(draft-hares-i2nsf-capability-data-model-05 )
https://tools.ietf.org/html/draft-hares-i2nsf-capability-data-model-05

2. I2NSF Network Security Functions-Facing Interface YANG Data Model
(draft-kim-i2nsf-nsf-facing-interface-data-model-04)
https://tools.ietf.org/html/draft-kim-i2nsf-nsf-facing-interface-data-model-04

3. I2NSF Consumer-Facing Interface YANG Data Model
(draft-jeong-i2nsf-consumer-facing-interface-dm-04)
https://tools.ietf.org/html/draft-jeong-i2nsf-consumer-facing-interface-dm-04

We address all the discussions last meetings for the synchronization between
the information models and data models.

Thanks for your coordination.

Best Regards,
Paul
--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957<tel:+82%2031-299-4957>
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
regards,
John

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Yoav Nir <[email-masked]>
Date: Thu, 2 Nov 2017 20:39:19 +0200

Hi, John

> On 2 Nov 2017, at 7:08, John Strassner <[email-masked]> wrote:

<snip/>

> Second, my worry is that draft-kumar is not ready. It is not an information model; rather, it is (at best) requirements that could be turned into an information model. In addition, it needs to be i…

I’d like to point out that a draft that gets adopted does not need to be ready for publication. It only needs to be good enough to be a starting point for work by the working group.

At present, draft-kumar is the product of its seven authors. They can put whatever they want in this document and they don’t need anyone to agree to any changes.

What adoption changes is that the group gets change control, so if the group decides that the IM should be added in this draft, that is what happens; and if the group decides that it should be merged with the capabilities draft, that is fine as well.  It is not the usual way to have a working group work on an individual draft. If we want to work on this, we adopt it and make it ready. We don’t wait for individual authors to make their draft ready for publications and then adopt it followed immediately by working group last call.

I agree that we may want to spend some time on the list of documents before adopting them, but getting to start work on the content of these documents is what this group is chartered to do.

Yoav

---

From: John Strassner <[email-masked]>
Date: Thu, 2 Nov 2017 13:08:38 -0700

Hi Yoav,

I understand the adoption practice :-)

What I don't understand is why draft-kumar is titled "Information Model for
Consumer-Facing Interface", as it is not an information model.

In addition, this draft conflicts with the capability I-D, which has
already been adopted. For example, the very first object that is described
is a Policy object, which "represents a mechanism to express a Security
Policy by Security Admin (i.e., I2NSF User) using Consumer-Facing interface
toward Security Controller; the policy would be enforced on an NSF." This
object conflicts with the SecurityECAPolicyRule object defined in the
capability draft.

Especially because there is a normative requirement in the next line of the
kumar draft ("The Policy object SHALL have following information").

Now, if I look at this object, I can make the following comments:
  - The information specified is a mixture of attributes and relationships
to other objects, but the actual format and syntax is not specified
  - Name and descriptions SHOULD NOT be defined in this spec: they are
inherited from external specs as defined in the Capability draft
  - Multi-tenancy SHOULD NOT be defined as an attribute! This appears to be
a set of relationships to other objects
  - End-Group SHOULD NOT be defined as an attribute, appears to be
relationships to other objects, and has problems in its definition
  - Threat-Feed SHOULD NOT be defined as an attribute, appears to be
relationships to other objects, and has problems in its definition
  - Telemetry Data SHOULD NOT be a "field"
  - Rules (see below)
  - Owner (see below)

What really bothers me is the "Rules" field. This is completely
contradictory to the capability draft. Please re-examine it.

So, if you are asking if I support WG adoption, then the answer is NO.
However, my point was that this draft, besides not being organized as an
information model, is in too incomplete a state to start working on - all I
have is questions.

regards,
john

On Thu, Nov 2, 2017 at 11:39 AM, Yoav Nir <[email-masked]> wrote:

> Second, my worry is that draft-kumar is not ready. It is not an
> information model; rather, it is (at best) requirements that could be
> turned into an information model. In addition, it needs to be integrated
> with the existing capability draft. Note that it is absolutely essential
> that we only have a single information model. Having multiple information
> models is akin to having multiple dictionaries; what inevitably happens is
> that the same concept is defined in multiple conflicting ways. I suggest
> that this document be examined in more detail to determine how best to
> proceed. I have already talked to Frank about that.
>
>
> I’d like to point out that a draft that gets adopted does not need to be
> ready for publication. It only needs to be good enough to be a starting
> point for work by the working group.
>
> At present, draft-kumar is the product of its seven authors. They can put
> whatever they want in this document and they don’t need anyone to agree to
> any changes.
>
> What adoption changes is that the group gets change control, so if the
> group decides that the IM should be added in this draft, that is what
> happens; and if the group decides that it should be merged with the
> capabilities draft, that is fine as well.  It is not the usual way to have
> a working group work on an individual draft. If we want to work on this, we
> adopt it and make it ready. We don’t wait for individual authors to make
> their draft ready for publications and then adopt it followed immediately
> by working group last call.
>
> I agree that we may want to spend some time on the list of documents
> before adopting them, but getting to start work on the content of these
> documents is what this group is chartered to do.
>
> Yoav
>
>

-- 
regards,
John

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 2 Nov 2017 21:17:41 +0000

John,

Thank you very much for identifying some of the issues of the IM draft. Agree with you that we need to resolve the conflicts with the “capability I-D”. I hope we can make some progress in IETF100.

Per RFC 3444, the information model can be loosely defined, as long as it lays out the needed information elements. I understand not everyone agree with RFC3444. But before changes to RFC3444 is made, we should allow people to name their draft based on RFC3444.

Once become WG draft, the WG can contribute and make it correct.

Linda

From: John Strassner [mailto:[email-masked]]
Sent: Thursday, November 02, 2017 3:09 PM
To: Yoav Nir <[email-masked]>; John Strassner <[email-masked]>
Cc: John Strassner <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>; [email-masked]; Linda Dunbar <[email-masked]>
Subject: Re: [I2nsf] Request for WG Adoption Call for I2NSF Data Model Drafts

Hi Yoav,

What I don't understand is why draft-kumar is titled "Information Model for Consumer-Facing Interface", as it is not an information model.

In addition, this draft conflicts with the capability I-D, which has already been adopted. For example, the very first object that is described is a Policy object, which "represents a mechanism to express a Security Policy by Security Admin (i.e., I2NSF User) using Consumer-Facing interface toward Security Controller; the policy would be enforced on an NSF." This object conflicts with the SecurityECAPolicyRule object defined in the capability draft.

Especially because there is a normative requirement in the next line of the kumar draft ("The Policy object SHALL have following information").

Now, if I look at this object, I can make the following comments:
  - The information specified is a mixture of attributes and relationships to other objects, but the actual format and syntax is not specified
  - Name and descriptions SHOULD NOT be defined in this spec: they are inherited from external specs as defined in the Capability draft
  - Multi-tenancy SHOULD NOT be defined as an attribute! This appears to be a set of relationships to other objects
  - End-Group SHOULD NOT be defined as an attribute, appears to be relationships to other objects, and has problems in its definition
  - Threat-Feed SHOULD NOT be defined as an attribute, appears to be relationships to other objects, and has problems in its definition
  - Telemetry Data SHOULD NOT be a "field"
  - Rules (see below)
  - Owner (see below)

What really bothers me is the "Rules" field. This is completely contradictory to the capability draft. Please re-examine it.

So, if you are asking if I support WG adoption, then the answer is NO. However, my point was that this draft, besides not being organized as an information model, is in too incomplete a state to start working on - all I have is questions.

regards,
john

On Thu, Nov 2, 2017 at 11:39 AM, Yoav Nir <[email-masked]<mailto:[email-masked]>> wrote:
Hi, John

On 2 Nov 2017, at 7:08, John Strassner <[email-masked]<mailto:[email-masked]>> wrote:

<snip/>

Yoav

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Thu, 2 Nov 2017 14:23:17 -0700

Thanks Linda. I do not agree with 3444, as it is informational, and relies
on 3198 for a real definition. I don't really see the point of 3444.

My point was that if you are going to call something an info model, then it
should describe objects, hopefully in an object-oriented way. What I see is
a confusion between what is an object, what is an attribute, and what is a
relationship. That confusion must be cleared up before we can consider WG
adoption.

best regards,
John

On Thu, Nov 2, 2017 at 2:17 PM, Linda Dunbar <[email-masked]>
wrote:

> John,
>
>
>
> Thank you very much for identifying some of the issues of the IM draft.
> Agree with you that we need to resolve the conflicts with the “capability
> I-D”. I hope we can make some progress in IETF100.
>
>
>
> Per RFC 3444, the information model can be loosely defined, as long as it
> lays out the needed information elements. I understand not everyone agree
> with RFC3444. But before changes to RFC3444 is made, we should allow people
> to name their draft based on RFC3444.
>
>
>
> *From:* John Strassner [mailto:[email-masked]]
> *Sent:* Thursday, November 02, 2017 3:09 PM
> *To:* Yoav Nir <[email-masked]>; John Strassner <[email-masked]>
> *Cc:* John Strassner <[email-masked]>; Mr. Jaehoon Paul
> Jeong <[email-masked]>; [email-masked]; Linda Dunbar <
> [email-masked]>
> *Subject:* Re: [I2nsf] Request for WG Adoption Call for I2NSF Data Model
> Drafts
>
>
>
> Hi Yoav,
>
>
>
> What I don't understand is why draft-kumar is titled "Information Model
> for Consumer-Facing Interface", as it is not an information model.
>
>
>
> Especially because there is a normative requirement in the next line of
> the kumar draft ("The Policy object SHALL have following information").
>
>
>
>   - Multi-tenancy SHOULD NOT be defined as an attribute! This appears to
> be a set of relationships to other objects
>

-- 
regards,
John

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Sat, 4 Nov 2017 13:26:50 +0900

John,

For draft-kumar for consumer-facing interface information model, you can
give the authors
further constructive suggestions because you did good job in I2NSF
capability information model.
IMHO, the current draft-kumar is good for at least firewall and web-filter
through the implementation experiences of my SKKU team at the last three
IETF hackathons.
So I believe that draft-kumar can be a good starting point for
consumer-facing interface.

For the data models, as you mentioned, we authors followed the legacy YANG
models.
The object-oriented data model such as SUPA will be a good candidate.
As the WG becomes to have a consensus to use which YANG model between
the legacy YANG model and the object-oriented YANG model,
we authors of the data models will be able to work smoothly according to
the decision.

Actually, my SKKU team have already been considering how to use the concept
of the object-oriented features
for YANG data models.
For the NSF-facing interface data model, we can modify our data model such
that the common variables used by
Event, Condition, and Action clauses will be made into objects and be
shared by them through aggregation.

If you know other object-oriented YANG models other than the SUPA data
model,
please let us know them to refer to them.

Thanks for your considerate analysis and contribution to our I2NSF WG.

Best Regards,
Paul

On Thu, Nov 2, 2017 at 2:08 PM, John Strassner <[email-masked]

> Third, we need to think about how we want to author data models. You have
> adopted a perfectly reasonable style, which is similar to how many YANG
> models are built. This is not object-oriented. However, the info model is
> in fact object-oriented, and so the question arises: do we follow existing
> style, or do we try and build YANG modules that are more object-oriented. I
> personally vote for the latter (see the SUPA data models for an example),
> but this should be decided by the WG. Until that is decided, I suggest that
> any data model is not ready for adoption.
>
>
>
> Regards,
>
> John
>
>
>
> *From:* I2nsf [mailto:[email-masked]] *On Behalf Of *Mr. Jaehoon
> Paul Jeong
> *Sent:* Tuesday, October 31, 2017 6:14 PM
> *To:* John Strassner <[email-masked]>
> *Cc:* [email-masked]; SecCurator_Team <skku_secu-brain_all@googlegro
> ups.com>; Yoav Nir <[email-masked]>; Linda Dunbar <
> [email-masked]>
> On Wed, Nov 1, 2017 at 2:26 AM, John Strassner <[email-masked]> wrote:
>
> Wouldn't it be ore prudent to first have the design team meet to discuss
> alignment issues, and then proceed from the results of that?
>
>
>
> regards,
>
> John
>
>
>
> On Tue, Oct 31, 2017 at 9:22 AM, Linda Dunbar <[email-masked]>
> wrote:
>
> Paul,
>
>
>
> Got your request.
>
>
>
> draft-kumar-i2nsf-client-facing-interface-im-04. Do you think
> draft-kumar-i2nsf-client-facing-interface-im-04 is ready?
>
>
>
> Linda
>
>
>
>
>
> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
> *Sent:* Monday, October 30, 2017 8:24 PM
> *To:* Linda Dunbar <[email-masked]>; Yoav Nir <
> [email-masked]>
> *Cc:* [email-masked]; SecCurator_Team <skku_secu-brain_all@googlegro
> ups.com>; Mr. Jaehoon Paul Jeong <[email-masked]>
> *Subject:* Request for WG Adoption Call for I2NSF Data Model Drafts
>
>
>
> Dear Linda and Yoav,
>
> Office: +82-31-299-4957 <+82%2031-299-4957>
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
>
>
>
> [email-masked]
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: John Strassner <[email-masked]>
Date: Sat, 4 Nov 2017 14:33:52 -0700

Hi Paul,

thanks for your kind note. I am happy to work closely with you and your
team.

The "object-oriented" YANG approach is currently being used by Ericsson and
parts of Huawei - others are looking at it. I do NOT think that it is
required that I2NSF use it (though of course I would like to see us use
it), and you are absolutely right - the WG needs to decide which approach
to use.

If we decide to use the traditional approach, then there are some elements
from the OO approach (e.g., identities defined in groupings) that I think
we should add to the traditional approach.

I believe that there is good work within draft-kumar, but we:
   1) need to treat it as a requirements for adding to our info model work
(we do not want competing info models!), and
   2) translate the requirements into an OO info model approach.

I hope that you and part of your team will go to Singapore - if you are,
please let me know and let's set up some side meetings to explore the above
further.

best regards,
John

On Fri, Nov 3, 2017 at 9:26 PM, Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

> Actually, my SKKU team have already been considering how to use the
> concept of the object-oriented features
> for YANG data models.
> On Thu, Nov 2, 2017 at 2:08 PM, John Strassner <
> [email-masked]> wrote:
>
>> Hi Paul,
>>
>>
>>

-- 
regards,
John