Subject: [I2nsf] Side Meeting for I2NSF WG

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 21 Nov 2019 11:01:11 +0800

Hi I2NSF WG,
There will be a side meeting for I2NSF WG's next steps from 6PM to 7PM
today at Bras Basah.
https://datatracker.ietf.org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center

* Agenda for I2NSF Side Meeting
- I2NSF Hackathon Project Report (Jaehoon Paul Jeong, 5 min)
- I2NSF Data Model Drafts Update (Jaehoon Paul Jeong, 10 min)
  . I2NSF Capability YANG Data Model
  . I2NSF Consumer-Facing Interface YANG Data Model
  . I2NSF Network Security Function-Facing Interface YANG Data Model
  . I2NSF Registration Interface YANG Data Model
  . I2NSF NSF Monitoring YANG Data Model
- Security Policy Translator Draft Update (Chaehong Chung, 5 min)
- Open Discussion: Possible Work Items for I2NSF Rechartering (30 min)

I will report the progress of data model drafts.
I would like to discuss the rechartering of I2NSF WG with you.

I suggest four work items as the 2nd phase I2NSF.
1. YANG data model of the interface between I2NSF Security Controller and
SDN Switch Controller
2. YANG data model of the interface between I2NSF Security Controller and
SFC Classifier
3. Configuration of Advanced Security Functions with I2NSF Security
Controller
4.  Policy Object for Interface to Network Security Functions (I2NSF)

Let me explain why each of them is important for I2NSF.

1.  YANG data model of the interface between I2NSF Security Controller and
SDN Switch Controller
According to the I2NSF Applicability Draft and I2NSF Hackathon Project,
the SDN switches can perform simple packet filtering and the firewall NSF
can perform complicated packet filtering.
For this two separated packet filtering, the security policy about a
traffic flow should be delivered to an SDN Switch Controller.
For the delivery of a security policy to the SDN network, the interface
between the I2NSF Security Controller and
the SDN Switch Controller is needed.

2.  YANG data model of the interface between I2NSF Security Controller and
SFC Classifier
According to the I2NSF Applicability Draft and I2NSF Hackathon Project,
a security policy (e.g., time-based web filtering) requires a Service
Function Chaining (SFC) such as
firewall and web filter.
For this SFC path specification of a security policy, a security about a
traffic flow should be delivered to an SFC Classifier.
For the delivery of a security policy to specify the service function path
in the SFC Classifier, the interface between
the I2NSF Security Controller and the SFC Classifier is needed.

3. Configuration of Advanced Security Functions with I2NSF Security
Controller
    (https://tools.ietf.org/html/draft-dong-i2nsf-asf-config-01)
With the current NSF-Facing Interface, we can configure basic security
functions, such as firewall, deep packet inspection, and
DDoS attack mitigator. For rich network security functions,  the YANG data
model of advanced security services needs to be
developed.

4. Policy Object for Interface to Network Security Functions (I2NSF)
    (https://tools.ietf.org/html/draft-xia-i2nsf-security-policy-object-01)
Policy objects for I2NSF security policy rules can provide the I2NSF system
with reusability for security policy construction
by defining essential attributes for each policy object. This will be
useful for security policy rule generation in the I2NSF system.

Welcome your feedback.

Thanks.

Best Regards,
Paul

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 21 Nov 2019 03:50:05 +0000

Hi Paul,

Just to frame today’s discussion, let me remark I find especially interesting points (3) and (4), that I believe can only happen within I2NSF. We can connect (3) with the ECA discussions happening in OPSAWG and NMRG, and I see (4) as an interesting opportunity for consolidating and achieving the full potential of the capability model.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 21/11/2019, 11:02, "I2nsf on behalf of Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi I2NSF WG,
There will be a side meeting for I2NSF WG's next steps from 6PM to 7PM today at Bras Basah.
https://datatracker.ietf.org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center

I suggest four work items as the 2nd phase I2NSF.
1. YANG data model of the interface between I2NSF Security Controller and SDN Switch Controller
2. YANG data model of the interface between I2NSF Security Controller and SFC Classifier
3. Configuration of Advanced Security Functions with I2NSF Security Controller
4.  Policy Object for Interface to Network Security Functions (I2NSF)

1.  YANG data model of the interface between I2NSF Security Controller and SDN Switch Controller
According to the I2NSF Applicability Draft and I2NSF Hackathon Project,
the SDN switches can perform simple packet filtering and the firewall NSF can perform complicated packet filtering.
For this two separated packet filtering, the security policy about a traffic flow should be delivered to an SDN Switch Controller.
For the delivery of a security policy to the SDN network, the interface between the I2NSF Security Controller and
the SDN Switch Controller is needed.

2.  YANG data model of the interface between I2NSF Security Controller and SFC Classifier
According to the I2NSF Applicability Draft and I2NSF Hackathon Project,
a security policy (e.g., time-based web filtering) requires a Service Function Chaining (SFC) such as
firewall and web filter.
For this SFC path specification of a security policy, a security about a traffic flow should be delivered to an SFC Classifier.
For the delivery of a security policy to specify the service function path in the SFC Classifier, the interface between
the I2NSF Security Controller and the SFC Classifier is needed.

3. Configuration of Advanced Security Functions with I2NSF Security Controller
    (https://tools.ietf.org/html/draft-dong-i2nsf-asf-config-01)
With the current NSF-Facing Interface, we can configure basic security functions, such as firewall, deep packet inspection, and
DDoS attack mitigator. For rich network security functions,  the YANG data model of advanced security services needs to be
developed.

4. Policy Object for Interface to Network Security Functions (I2NSF)
    (https://tools.ietf.org/html/draft-xia-i2nsf-security-policy-object-01)
Policy objects for I2NSF security policy rules can provide the I2NSF system with reusability for security policy construction
by defining essential attributes for each policy object. This will be useful for security policy rule generation in the I2NSF system.

Welcome your feedback.

Thanks.

Best Regards,
Paul

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 21 Nov 2019 12:02:59 +0800

Diego,
I agree with you at the remark on points 3 and 4.
However, for points 1 and 2, we need to bridge I2NSF and SFC (or SDN).
At least, we can work for the interface with SFC within IETF.

Thanks.

Paul

On Thu, Nov 21, 2019 at 11:50 AM Diego R. Lopez <
[email-masked]> wrote:

> Hi Paul,
>
>
>
> Just to frame today’s discussion, let me remark I find especially
> interesting points (3) and (4), that I believe can only happen within
> I2NSF. We can connect (3) with the ECA discussions happening in OPSAWG and
> NMRG, and I see (4) as an interesting opportunity for consolidating and
> achieving the full potential of the capability model.
>
>
>
> Be goode,
>
>
>
> --
>
> e-mail: [email-masked]
>
> Tel:         +34 913 129 041
>
> Mobile:  +34 682 051 091
>
> On 21/11/2019, 11:02, "I2nsf on behalf of Mr. Jaehoon Paul Jeong" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
> Hi I2NSF WG,
>
> Policy objects for I2NSF security policy rules can provide the I2NSF
> system with reusability for security policy construction
>
> ------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 21 Nov 2019 19:02:35 +0900

Hi I2NSF WG,
Here are the slides for today's side meeting.

Thanks.

Paul

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 21 Nov 2019 10:59:18 +0000

Paul,

I am so sorry that the BGP session running longer than expected. I will come to you in 5 minutes.

Lina

From: I2nsf <[email-masked]> On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Thursday, November 21, 2019 12:03 PM
To: Diego R. Lopez <[email-masked]>
Cc: Roman Danyliw <[email-masked]>; Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]>; [email-masked]; Jérôme François <[email-masked]>; skku-iotlab-members <[email-masked]>; Qin Wu <[email-masked]>
Subject: Re: [I2nsf] Side Meeting for I2NSF WG

Diego,

Thanks.

Paul

On Thu, Nov 21, 2019 at 11:50 AM Diego R. Lopez <[email-masked]<mailto:[email-masked]>> wrote:
Hi Paul,

Be goode,

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fdr2lopez%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cf32f76b00e044df072f108d76e37cd88%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637099058286888316&sdata=DJFirAO8fH8P1%2BCnztRwWqhJqaK0%2BbzOHrBYa44XdLs%3D&reserved=0>

Hi I2NSF WG,
There will be a side meeting for I2NSF WG's next steps from 6PM to 7PM today at Bras Basah.
https://datatracker.ietf.org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F106%2Ffloor-plan%3Froom%3Dbras-basah%23raffles-city-convention-center&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cf32f76b00e044df072f108d76e37cd88%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637099058286898310&sdata=fnFdVTUhRutSKYd0wWkCKHaHR%2ForE26ch8UuksQFyY0%3D&reserved=0>

3. Configuration of Advanced Security Functions with I2NSF Security Controller
    (https://tools.ietf.org/html/draft-dong-i2nsf-asf-config-01<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-dong-i2nsf-asf-config-01&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cf32f76b00e044df072f108d76e37cd88%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637099058286898310&sdata=kKg1vrUCsGmWcS3T%2F83oLrg9jTJ0q8tQb7uiMhDYDRg%3D&reserved=0>)
With the current NSF-Facing Interface, we can configure basic security functions, such as firewall, deep packet inspection, and
DDoS attack mitigator. For rich network security functions,  the YANG data model of advanced security services needs to be
developed.

4. Policy Object for Interface to Network Security Functions (I2NSF)
    (https://tools.ietf.org/html/draft-xia-i2nsf-security-policy-object-01<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-xia-i2nsf-security-policy-object-01&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cf32f76b00e044df072f108d76e37cd88%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637099058286908306&sdata=wnEg%2BjZTZYdB83PPl0TSzT%2BuOH0qlguDFv1sTSVkGNU%3D&reserved=0>)
Policy objects for I2NSF security policy rules can provide the I2NSF system with reusability for security policy construction
by defining essential attributes for each policy object. This will be useful for security policy rule generation in the I2NSF system.

Welcome your feedback.

Thanks.

Best Regards,
Paul

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<https://nam03.safelinks.protection.outlook.com/?url=http%3A%2F%2Fcpslab.skku.edu%2Fpeople-jaehoon-jeong.php&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cf32f76b00e044df072f108d76e37cd88%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637099058286908306&sdata=TpvqnAJKfeQ8o2ZjNI%2Fl0hNzjKKQ0BsRD2YQgGjqX08%3D&reserved=0>