Subject: Re: [I2nsf] Yangdoctors last call review of draft-ietf-i2nsf-registration-interface-dm-04

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 6 Nov 2019 11:01:46 +0900

Hi Reshad,
I believe that I have addressed your comments on I2NSF Registration
Interface Data Model:
https://tools.ietf.org/html/draft-ietf-i2nsf-registration-interface-dm-05

If you are satisfied with the revision, could you update the Review result
in the following page?
https://datatracker.ietf.org/doc/review-ietf-i2nsf-registration-interface-dm-04-yangdoctors-lc-rahman-2019-06-28/

Thanks.

Best Regards,
Paul

On Thu, Jul 25, 2019 at 11:23 PM Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

> Hi Reshad,
> Here is the revision letter for the revised draft, reflecting your
> comments along with the revised draft:
> https://tools.ietf.org/html/draft-ietf-i2nsf-registration-interface-dm-05
>
> If you have further comments and questions, please let me know.
>
> Thanks.
>
> Best Regards,
> Paul
>
> On Fri, Jun 28, 2019 at 5:17 PM Reshad Rahman via Datatracker <
> [email-masked]> wrote:
>
>> Reviewer: Reshad Rahman
>> Review result: On the Right Track
>>
>> YANG Doctor review of draft-ietf-i2nsf-registration-interface-dm-04 (by
>> Reshad
>> Rahman)
>>
>> Major comments:
>> - Look at appendix B of RFC8407 for an example of how a YANG module
>> should be
>> structured. This document does not abide to that. - Poor descriptions e.g.
>> "nsf-name" for leaf "nsf-name" etc - prefix "iiregi" doesn't seem right.
>> What
>> about "nsfreg"? Probably needs coordination with the other I2NSF YANG
>> modules
>> to have consistency between the prefixes. I see that YD Acee suggested
>> "nsfintf" for draft-ietf-i2nsf-nsf-facing-interface-dm-06 - No unit
>> specified
>> for bandwidth, processing (performance) - nsf-address is IPv4 specific -
>> Security considerations should list the nodes as per section 3.7 of
>> RFC8407. -
>> Should this document be informational since 8329 is informational? -
>> Section 2
>> should use RFC8174 also - Refer to RFC8407 instead of 6807 (YANG
>> Guidelines) -
>> Examples should use IPv6 as examples (use the range from RFC3849). Kudos
>> for
>> all the examples.
>>
>> Minor comments and questions:
>> - The YANG trees such as Figure 6, 7 etc don't show the contents of the
>> groupings. So they don't help much. - nsf-port-address should be
>> nsf-port? -
>> Section 4, last bullet. I am not an expert on I2NSF so not clear to me
>> why this
>> query is needed, is it because NSF may not re-register after their
>> capabilities
>> have been updated? Might be worth adding some explanation. - Have the
>> examples
>> been validated?
>>
>> _______________________________________________
>> I2nsf mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i2nsf
>>
>
>
> --
> ===========================
> Mr. Jaehoon (Paul) Jeong, Ph.D.
> Associate Professor
> Department of Software
> Sungkyunkwan University
> Office: +82-31-299-4957
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 6 Nov 2019 13:31:48 +0000

Hi Paul,

I have started looking at the recent revision of the draft but haven’t managed to do a formal re-review yet. I will do one as soon as possible.

Apologies for the delay.

Regards,
Reshad.

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tuesday, November 5, 2019 at 9:02 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: YANG Doctors <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Sangwon Hyun <[email-masked]>, "[email-masked]" <[email-masked]>, "Mr. Jaehoon Paul Jeong" <[email-masked]>
Subject: Re: [I2nsf] Yangdoctors last call review of draft-ietf-i2nsf-registration-interface-dm-04

Hi Reshad,
I believe that I have addressed your comments on I2NSF Registration Interface Data Model:
https://tools.ietf.org/html/draft-ietf-i2nsf-registration-interface-dm-05

If you are satisfied with the revision, could you update the Review result in the following page?
https://datatracker.ietf.org/doc/review-ietf-i2nsf-registration-interface-dm-04-yangdoctors-lc-rahman-2019-06-28/

Thanks.

Best Regards,
Paul

On Thu, Jul 25, 2019 at 11:23 PM Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>> wrote:
Hi Reshad,
Here is the revision letter for the revised draft, reflecting your comments along with the revised draft:
https://tools.ietf.org/html/draft-ietf-i2nsf-registration-interface-dm-05

Thanks.

Best Regards,
Paul

On Fri, Jun 28, 2019 at 5:17 PM Reshad Rahman via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Reviewer: Reshad Rahman
Review result: On the Right Track

YANG Doctor review of draft-ietf-i2nsf-registration-interface-dm-04 (by Reshad
Rahman)

Major comments:
- Look at appendix B of RFC8407 for an example of how a YANG module should be
structured. This document does not abide to that. - Poor descriptions e.g.
"nsf-name" for leaf "nsf-name" etc - prefix "iiregi" doesn't seem right. What
about "nsfreg"? Probably needs coordination with the other I2NSF YANG modules
to have consistency between the prefixes. I see that YD Acee suggested
"nsfintf" for draft-ietf-i2nsf-nsf-facing-interface-dm-06 - No unit specified
for bandwidth, processing (performance) - nsf-address is IPv4 specific -
Security considerations should list the nodes as per section 3.7 of RFC8407. -
Should this document be informational since 8329 is informational? - Section 2
should use RFC8174 also - Refer to RFC8407 instead of 6807 (YANG Guidelines) -
Examples should use IPv6 as examples (use the range from RFC3849). Kudos for
all the examples.

Minor comments and questions:
- The YANG trees such as Figure 6, 7 etc don't show the contents of the
groupings. So they don't help much. - nsf-port-address should be nsf-port? -
Section 4, last bullet. I am not an expert on I2NSF so not clear to me why this
query is needed, is it because NSF may not re-register after their capabilities
have been updated? Might be worth adding some explanation. - Have the examples
been validated?

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 11 Nov 2019 16:58:01 +0000

Hi Paul,

I have done another review (I don’t think an automated email got sent out).
https://datatracker.ietf.org/doc/review-ietf-i2nsf-registration-interface-dm-04-yangdoctors-lc-rahman-2019-06-28/

YANG Doctor review of draft-ietf-i2nsf-registration-interface-dm-05 (by Reshad Rahman)

Thank you for addressing comments from my earlier review @ https://datatracker.ietf.org/doc/review-ietf-i2nsf-registration-interface-dm-04-yangdoctors-lc-rahman-2019-06-28/

Major comments/questions:
- There is a YANG warning on the datatracker page:
[email-masked]:54: warning: RFC 8407: 3.1: The IETF Trust Copyright statement seems to be missing (see pyang --ietf-help for details).
To fix this, in the YANG module remove the <> around 2019: Copyright (c) <2019>

- For contact in YANG module, please remove WG chair info (see RFC8407 appendix B for an example)

- For the revision in YANg module, put "Initial version" (even though it's the 5th revision)

- Why define a union of ipv4-address and ipv6-address in typedef nsf-address, why not reuse existing ip-address type from RFC6021?

- For bandwidth, is there a reason why it's limited to uint16? Even though 65Tbps is a lot, I wouldn't limit it to uint16. And aren't there any use-cases for bandwidth smaller than 1 Gbps? If yes, use e.g Mbps as unit and use uint32 instead of uint16? Please use units statement.
- It is not clear to me what’s the distinction between nsf-name and nsf-instance-name. In Examples 4 and 5, they have the same value, but not in Example 3.  Might be worth clarifying or giving the same name.

- Having nsf or i2nsf in many node names is redundant, since NSF or I2NSF is in the higher level container name.  e.g, in NSF Capability Registration all nodes seem to have i2nsf or nsf in their name.

- There seems to be some indentation issues in the YANG  module (e.g. P16)

- Abide by order in RFC8407 Appendix B. e.g. RPC statements should be after groupings.

Nits:

- Appendix B: Managmenet -> Management

- Section 6.2: capailities -> capabilities

- Example 5: space in "http_and_h ttps_flood_mitigation_capability"

Regards,
Reshad.

Regards,
Reshad.

Hi Reshad,

Thanks.

Best Regards,
Paul

Thanks.

Best Regards,
Paul

Major comments:

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 26 Nov 2019 21:57:00 +0900

Hi Reshad,
Thanks for your valuable review on the I2NSF Registration Interface.

We authors will revise our draft according to your review comments.

Thanks.

Best Regards,
Paul

On Tue, Nov 12, 2019 at 1:58 AM Reshad Rahman (rrahman) <[email-masked]>
wrote:

> Thank you for addressing comments from my earlier review @
> [email-masked]:54: warning: RFC 8407: 3.1: The
> IETF Trust Copyright statement seems to be missing (see pyang --ietf-help
> for details).
>
> - Why define a union of ipv4-address and ipv6-address in typedef
> nsf-address, why not reuse existing ip-address type from RFC6021?
>
>
>
> - For bandwidth, is there a reason why it's limited to uint16? Even though
> 65Tbps is a lot, I wouldn't limit it to uint16. And aren't there any
> use-cases for bandwidth smaller than 1 Gbps? If yes, use e.g Mbps as unit
> and use uint32 instead of uint16? Please use units statement.
>
> - It is not clear to me what’s the distinction between nsf-name and
> nsf-instance-name. In Examples 4 and 5, they have the same value, but not
> in Example 3.  Might be worth clarifying or giving the same name.
>
>
>
> - Having nsf or i2nsf in many node names is redundant, since NSF or I2NSF
> is in the higher level container name.  e.g, in NSF Capability Registration
> all nodes seem to have i2nsf or nsf in their name.
>
>
>
> *From: *"Mr. Jaehoon Paul Jeong" <[email-masked]>
> *Date: *Tuesday, November 5, 2019 at 9:02 PM
> *To: *"Reshad Rahman (rrahman)" <[email-masked]>
> *Cc: *YANG Doctors <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]"
> <[email-masked]>, Sangwon Hyun <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "Mr. Jaehoon Paul Jeong" <
> [email-masked]>
> *Subject: *Re: [I2nsf] Yangdoctors last call review of
> draft-ietf-i2nsf-registration-interface-dm-04
>
>
>
> Hi Reshad,