Subject: Re: [I2nsf] FW: virtual hackathon for IETF 108

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 4 Jun 2020 10:49:39 +0900

Hi Laurent,
I am willing to join the NMRG hackathon project in IETF 108.

My students and I at SKKU are working for the security policy translator
for the I2NSF framework.
My group work about I2NSF-based IBN security services is published in IEEE
Communications Magazine:

"IBCS: Intent-Based Cloud Services for Security Applications"
http://iotlab.skku.edu/publications/international-journal/IBCS-Communications-Magazine-2020.pdf

My team will be able to present our progress the security policy translator
for I2NSF in terms of
the automatic mapping of a high-level YANG module attributes (called
Consumer-Facing Interface)
into a low-level YANG module attributes (called NSF-Facing Interface).

I CC I2NSF WG for the information of our collaboration in IBN stuff.

Thanks.

Best Regards,
Paul

On Wed, Jun 3, 2020 at 6:57 PM Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
<[email-masked]> wrote:

> Hello,
>
> I'd like to discuss with you (and anyone interested) about a potential
> NMRG IBN project for IETF 108 virtual hackathon.
>
> Would you be interested to participate? If yes, what would you be
> interested in?
>
> I can think about a few points to clarify:
>  - doodle polls for participation and planning (which days of week 20-24
> would be most efficient/practical)
>  - setting-up dedicated hackathon space on NMRG GitHub (code repositories,
> general guidance/instructions/documentation, (shared) development
> environment requirements/tools, etc.)
>  - setting-up dedicated support for virtual team collaboration (e.g. Slack)
>  - project brief: scope, objectives, technical topics, etc.
>  - plan some dedicated on-line meetings before week 20-24 July to
> organize/start the project
>
> In terms of "content":
>  - Walter and Barbara have a plan for a common work.
>  - We could have presentation/discussion on new/evolved demos/PoC,
> similarly to what we did at NoF (Roma, October 2019).
>         . Luis, Panagiotis: what about slice intent?
>         . Navid, Ferhat: what about NS design automation?
>         . Lisandro: what about Arthur work on the intent assistant?
>         . Amina: what about NS automation?
>         . Imen: what about VNF/NS descriptors automation?
>         . Paul: what about I2NSF policy translation?
>
>  - We could also continue the mapping work with the classification (Olga)
>  - ... other suggestions?
>
> I will share a doodle poll on the NMRG mailing list for a first discussion
> meeting in the coming weeks.
>
> Please let me know your views.
>
> Thanks!
>
> Best regards, Laurent.
>
>
>
> -----Original Message-----
> From: nmrg <[email-masked]> On Behalf Of Ciavaglia, Laurent (Nokia
> - FR/Paris-Saclay)
> Sent: Wednesday, June 3, 2020 11:09
> To: [email-masked]
> Subject: [nmrg] FW: virtual hackathon for IETF 108
>
> Hello NMRG,
>
> FYI, about the virtual hackathon for IETF 108.
>
> As discussed in our last meeting, we can set-up plans for a NMRG IBN
> hackathon project.
> If you are interested, please send an email to the list or to the chairs.
>
> I think it could be a good opportunity to use the IETF 108 virtual
> hackathon week as a milestone to bring together practitioners involved in
> IBN implementations and work together.
>
> Best regards, Laurent.
>
>
> -----Original Message-----
> From: hackathon <[email-masked]> On Behalf Of Charles Eckel
> (eckelcu)
> Sent: Tuesday, June 2, 2020 21:17
> To: [email-masked]
> Subject: [hackathon] virtual hackathon for IETF 108
>
> Hi Folks,
>
> We have what I hope will come as good news to all of you. There will be a
> virtual IETF hackathon as part of IETF 108.
> We are still working out some details but want to share what we do know
> now so you can plan accordingly.
>
> The virtual hackathon will run the week before the IETF meeting, July
> 20-24.
> Kickoff via Meetecho, Monday 1400 UTC.
> Closing, Friday 1400 UTC.
> Project presentations will be either during the closing or during the IETF
> meeting, July 27-31.
>
> Registration will be required but free. There will not be hackathon
> t-shirts.
> Champions post projects to the wiki and lead these projects as usual. How
> and when they meet throughout the week is up to them.
> We are in the process of building out the wiki and registration system
> with the goal of being available when IETF registration opens on June 8.
> We plan to use Meetecho for the Hackathon overall, and if possible,
> provide Meetecho sessions for individual teams that want them as well.
> More details will follow.
>
> Cheers,
> Charles
>
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg
>

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Lisandro Zambenedetti Granville <[email-masked]>
Date: Thu, 4 Jun 2020 07:24:59 -0300

Hello all, Laurent

Let me check with Arthur. He’s about to return from Princeton and the logistics may impacto, but I’ll let you know.

Best regards,

Lisandro

> Em 3 de jun de 2020, à(s) 22:49, Mr. Jaehoon Paul Jeong <[email-masked]> escreveu:
> 
> Hi Laurent,
> My students and I at SKKU are working for the security policy translator for the I2NSF framework.
> My group work about I2NSF-based IBN security services is published in IEEE Communications Magazine:
> 
> http://iotlab.skku.edu/publications/international-journal/IBCS-Communications-Magazine-2020.pdf <http://iotlab.skku.edu/publications/international-journal/IBCS-Communications-Magazine-2020.pdf>
> 
> My team will be able to present our progress the security policy translator for I2NSF in terms of 
> the automatic mapping of a high-level YANG module attributes (called Consumer-Facing Interface)
> On Wed, Jun 3, 2020 at 6:57 PM Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> 
> I'd like to discuss with you (and anyone interested) about a potential NMRG IBN project for IETF 108 virtual hackathon.
> 
> Would you be interested to participate? If yes, what would you be interested in?
> 
>  - doodle polls for participation and planning (which days of week 20-24 would be most efficient/practical)
>  - setting-up dedicated hackathon space on NMRG GitHub (code repositories, general guidance/instructions/documentation, (shared) development environment requirements/tools, etc.)
>  - plan some dedicated on-line meetings before week 20-24 July to organize/start the project
> 
> In terms of "content":
>  - We could have presentation/discussion on new/evolved demos/PoC, similarly to what we did at NoF (Roma, October 2019). 
> I will share a doodle poll on the NMRG mailing list for a first discussion meeting in the coming weeks.
> 
> From: nmrg <[email-masked] <mailto:[email-masked]>> On Behalf Of Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> To: [email-masked] <mailto:[email-masked]>
> As discussed in our last meeting, we can set-up plans for a NMRG IBN hackathon project.
> I think it could be a good opportunity to use the IETF 108 virtual hackathon week as a milestone to bring together practitioners involved in IBN implementations and work together.
> 
> Best regards, Laurent.
> 
> 
> From: hackathon <[email-masked] <mailto:[email-masked]>> On Behalf Of Charles Eckel (eckelcu)
> To: [email-masked] <mailto:[email-masked]>
> We have what I hope will come as good news to all of you. There will be a virtual IETF hackathon as part of IETF 108. 
> We are still working out some details but want to share what we do know now so you can plan accordingly.
> 
> The virtual hackathon will run the week before the IETF meeting, July 20-24.
> Project presentations will be either during the closing or during the IETF meeting, July 27-31.
> 
> Registration will be required but free. There will not be hackathon t-shirts.
> Champions post projects to the wiki and lead these projects as usual. How and when they meet throughout the week is up to them.
> We are in the process of building out the wiki and registration system with the goal of being available when IETF registration opens on June 8.
> We plan to use Meetecho for the Hackathon overall, and if possible, provide Meetecho sessions for individual teams that want them as well.
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/hackathon <https://www.ietf.org/mailman/listinfo/hackathon>
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/nmrg <https://www.irtf.org/mailman/listinfo/nmrg>
> 
> 
> -- 
> Email: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <http://cpslab.skku.edu/people-jaehoon-jeong.php>