Subject: [I2nsf] Request for Resolving

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 16 Jul 2020 12:10:40 +0900

Hi RFC Editor,

Our draft is in the state of MISSREF with the five drafts.
(https://www.rfc-editor.org/cluster_info.php?cid=C405)
----------------------------------------------------------------------------
 draft-ietf-i2nsf-consumer-facing-interface-dm   NOT-RECEIVED
 draft-ietf-dots-architecture   RFC-EDITOR
 draft-ietf-i2nsf-nsf-facing-interface-dm   NOT-RECEIVED
 draft-ietf-i2nsf-nsf-monitoring-data-model   NOT-RECEIVED
 draft-ietf-i2nsf-registration-interface-dm   NOT-RECEIVED
----------------------------------------------------------------------------

Except for draft-ietf-dots-architecture, other drafts will take more time
until they are approved as RFCs by IESG.

Could you use the latest versions of the I2NSF-relevant drafts for the
publication of our draft?
----------------------------------------------------------------------------
[consumer-facing-inf-dm]
    Jeong, J., Chung, C., Ahn, T., Kumar, R., and S. Hares,
    "I2NSF Consumer-Facing Interface YANG Data Model", draft-
    ietf-i2nsf-consumer-facing-interface-dm-09 (work in
    progress), July 2020.

[nsf-facing-inf-dm]
    Kim, J., Jeong, J., Park, J., Hares, S., and Q. Lin,
    "I2NSF Network Security Function-Facing Interface YANG
    Data Model", draft-ietf-i2nsf-nsf-facing-interface-dm-09
    (work in progress), May 2020.

[nsf-monitoring-dm]
    Jeong, J., Chung, C., Hares, S., Xia, L., and H. Birkholz,
    "I2NSF NSF Monitoring YANG Data Model", draft-ietf-i2nsf-
    nsf-monitoring-data-model-03 (work in progress), May 2020.

[registration-inf-dm]
    Hyun, S., Jeong, J., Roh, T., Wi, S., and J. Park, "I2NSF
    Registration Interface YANG Data Model", draft-ietf-i2nsf-
    registration-interface-dm-08 (work in progress), March
    2020.
----------------------------------------------------------------------------

There are version-ups for the following drafts.
Could you use the latest versions of them?
----------------------------------------------------------------------------
[dots-architecture]
    Mortensen, A., Reddy, T., Andreasen, F., Teague, N., and
    R. Compton, "Distributed-Denial-of-Service Open Threat
    Signaling (DOTS) Architecture", draft-ietf-dots-
    architecture-18 (work in progress), March 2020.

[policy-translation]
    Jeong, J., Yang, J., Chung, C., and J. Kim, "Security
    Policy Translation in Interface to Network Security
    Functions", draft-yang-i2nsf-security-policy-
    translation-06 (work in progress), May 2020.

[tls-esni]
    Rescorla, E., Oku, K., Sullivan, N., and C. Wood, "TLS
    Encrypted Client Hello", draft-ietf-tls-esni-07 (work in
    progress), June 2020.
----------------------------------------------------------------------------

Also, I2NSF Terminology Draft[i2nsf-terminology] expired, so I would like to
replace [i2nsf-terminology] with [RFC8329], and remove [i2nsf-terminology]
as
citations in the text and its reference paragraph from the text.
----------------------------------------------------------------------------
[i2nsf-terminology]
    Hares, S., Strassner, J., Lopez, D., Xia, L., and H.
    Birkholz, "Interface to Network Security Functions (I2NSF)
    Terminology", draft-ietf-i2nsf-terminology-08 (work in
    progress), July 2019.

[RFC8329]  Lopez, D., Lopez, E., Dunbar, L., Strassner, J., and R.
    Kumar, "Framework for Interface to Network Security
    Functions", RFC 8329, February 2018.
----------------------------------------------------------------------------

There is the addition of IANA Considerations Section as follows.
Could you include this new section?
----------------------------------------------------------------------------
10. IANA Considerations
This document does not require any IANA actions.
----------------------------------------------------------------------------

I attach the revised draft's xml and pdf files with the above changes.

Could you move this draft forward to publish it as an RFC?

Thanks.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: RFC Editor <[email-masked]>
Date: Thu, 16 Jul 2020 11:52:16 -0700

Greetings,

We will update the document as requested, but please note that the
changes described below do not remove the normative reference holds on
this document.  The following Internet-Drafts are listed as normative
references; this document cannot move forward in the publication
process until these documents are also approved for publication:  

   draft-ietf-i2nsf-consumer-facing-interface-dm
   draft-ietf-dots-architecture
   draft-ietf-i2nsf-nsf-facing-interface-dm
   draft-ietf-i2nsf-nsf-monitoring-data-model
   draft-ietf-i2nsf-registration-interface-dm

Note that you do not need to send us an updated XML file as these I-Ds
are updated.  We will update these entries to refer to the RFC numbers
as part of our publication process. 

Please let us know if you have any questions.

Thank you,
RFC Editor/sg

On Thu, Jul 16, 2020 at 12:10:40PM +0900, Mr. Jaehoon Paul Jeong wrote:
> (https://www.rfc-editor.org/cluster_info.php?cid=C405 <https://www.rfc-editor.org/cluster_info.php?cid=C405>)
> Could you use the latest versions of the I2NSF-relevant drafts for the publication of our draft?
> replace [i2nsf-terminology] with [RFC8329], and remove [i2nsf-terminology] as 
> Email: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 17 Jul 2020 08:40:50 +0900

Hi RFC Editor,
If we move those references to Informative References
because our  I2NSF Applicability Draft will be an Informational RFC.
Could you publish our I2NSF Applicability Draft?

I CC the Security Area AD, Roman Danyliw for his opinion.

Roman,
Could you say your opinion on this reference issue?

Thanks.

Best Regards,
Paul

On Fri, Jul 17, 2020 at 3:52 AM RFC Editor <[email-masked]>
wrote:

> > (https://www.rfc-editor.org/cluster_info.php?cid=C405 <
> https://www.rfc-editor.org/cluster_info.php?cid=C405>)
> >
> > Email: [email-masked] <mailto:[email-masked]>,
> [email-masked] <mailto:[email-masked]>
> > Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <
> http://cpslab.skku.edu/people-jaehoon-jeong.php>
>

---

From: RFC Editor <[email-masked]>
Date: Tue, 21 Jul 2020 15:39:46 -0700

Hi Roman,

We're hoping you can provide some input here.  Moving references into
or out of the Normative section requires AD approval.

Thank you,
Sandy

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 22 Jul 2020 08:26:13 +0900

Hi Sandy,
we need to remove Normative References as our Applicability draft is
Informational.
I would like to ask the RFC editor to consolidate the current two
References (i.e., Normative and Informative References) into Informative
References through our AD Roman's permission.

Thanks.

Best Regards,
Paul

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 23 Jul 2020 21:05:21 +0000

Hi Paul!

I'm not so sure we can do that.  By my read, the intent of this document is to show how I2NSF can be used (i.e., it's an applicability statement).  Using the shorthand from [1], the core I2NSF YANG drafts "must be read to understand the technology".  If that's the case, then they have to be normative.   Does that make sense?  

Regards,
Roman

[1] https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/

> -----Original Message-----
> From: I2nsf <[email-masked]> On Behalf Of RFC Editor
> Sent: Tuesday, July 21, 2020 6:40 PM
> To: Roman Danyliw <[email-masked]>; Mr. Jaehoon Paul Jeong
> <[email-masked]>
> Cc: [email-masked]; skku-iotlab-members <skku-iotlab-
> [email-masked]>; RFC Editor <[email-masked]>
> Subject: [I2nsf] [Roman] Re: Request for Resolving <draft-ietf-i2nsf-
> applicability>
> 
> Hi Roman,
> 
> We're hoping you can provide some input here.  Moving references into or out
> of the Normative section requires AD approval.
> 
> Thank you,
> Sandy
> 
> 
> > If we move those references to Informative References because our
> > I2NSF Applicability Draft will be an Informational RFC.
> > > changes described below do not remove the normative reference holds
> > > on this document.  The following Internet-Drafts are listed as
> > > normative references; this document cannot move forward in the
> > > publication process until these documents are also approved for
> publication:
> > >
> > > Note that you do not need to send us an updated XML file as these
> > > I-Ds are updated.  We will update these entries to refer to the RFC
> > > numbers as part of our publication process.
> > >
> > > > Except for draft-ietf-dots-architecture, other drafts will take
> > > > more time until they are approved as RFCs by IESG.
> > > >
> > > > Also, I2NSF Terminology Draft[i2nsf-terminology] expired, so I
> > > > would
> > > like to
> > > > Department of Computer Science and Engineering Sungkyunkwan
> > > > University
> > > > Office: +82-31-299-4957
> > > > <
> > Department of Computer Science and Engineering Sungkyunkwan University
> > Office: +82-31-299-4957
> > Email: [email-masked], [email-masked] Personal Homepage:
> > http://iotlab.skku.edu/people-jaehoon-jeong.php
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 24 Jul 2020 10:18:32 +0900

Hi Roman,
You are right since those YANG data model drafts need to be read.
However, as long as I know, because an Informational RFC does not have
Normative References usually,
I think they can be cited as Informative References.

Linda,
Could you share your opinion with us?

Thanks.

Best Regards,
Paul

2020년 7월 24일 (금) 오전 6:05, Roman Danyliw <[email-masked]>님이 작성:

> Hi Paul!
>
> I'm not so sure we can do that.  By my read, the intent of this document
> is to show how I2NSF can be used (i.e., it's an applicability statement).
> Using the shorthand from [1], the core I2NSF YANG drafts "must be read to
> understand the technology".  If that's the case, then they have to be
> normative.   Does that make sense?
>
> Regards,
> Roman
>
> [1]
> https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 24 Jul 2020 23:56:30 +0900

Roman,
I discussed this Normative reference issue with Linda.
Okay, I will follow your guidance.
Please let my SKKU team work for moving the following I2NSF YANG data model
drafts into RFCs:
- I2NSF Capability YANG Data Model Draft
- I2NSF Consumer-Facing Interface YANG Data Model Draft
- I2NSF NSF-Facing Interface YANG Data Model Draft
- I2NSF Registration Interface YANG Data Model Draft
- I2NSF NSF Monitoring YANG Data Model Draft

For the I2NSF Capability YANG Data Model Draft, I sent you the revision
letter and revised draft on July 13, 2020.
https://tools.ietf.org/html/draft-ietf-i2nsf-capability-data-model-06

Could you help us move this draft forward to the IESG evaluation?

Thanks.

Best Regards,
Paul

On Fri, Jul 24, 2020 at 10:18 AM Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

>> or out
>> > > On Fri, Jul 17, 2020 at 3:52 AM RFC Editor <[email-masked]
>> >
>> > > wrote:
>> > >
>> > > > Greetings,
>> > > >
>> > > > > Personal Homepage: