Subject: [I2nsf] [IANA #1217705] Expert Review for draft-ietf-i2nsf-nsf-monitoring-data-model-12 (xml-registry)

From: "Amanda Baber via RT" <[email-masked]>
Date: Fri, 17 Dec 2021 00:25:55 +0000

Hi Tim and Martin (cc: i2nsf WG),

Have you had a chance to review the XML registration in this document?

https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-model/

thanks,
Amanda

On Tue Nov 30 21:38:22 2021, michelle.cotton wrote:
> Dear Tim and Martin,
> (cc to i2nsf WG)
> 
> As the designated experts for the ns IETF xml registry, can you review
> the proposed registration in draft-ietf-i2nsf-nsf-monitoring-data-
> model-12 for us? Please see
> 
> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-
> model/
> 
> If this is OK, when the IESG approves the document for publication,
> we'll make the registration at
> 
> https://www.iana.org/assignments/xml-registry
> 
> The IESG has asked us to set a two-week deadline for registration
> reviews. The due date for this request is 14 December 2021.
> 
> Thank you,
> 
> Michelle Cotton
> IANA Services

---

From: Tim Bray <[email-masked]>
Date: Thu, 16 Dec 2021 19:03:11 -0800

Sorry, but this has the same problem in figure 11.1 that we've just been
discussing with Ian.

For it to work, (a) the prefix in the alarm-category element MUST be the
same as the namespace prefix for
urn:ietf:params:xml:ns:yang:ietf-i2nsf-nsf-monitoring, which means that XML
software MUST be chosen that makes the namespace prefix information
available.  I don't think it's OK for the draft not to say those thigns.

<alarm-category
           xmlns:nsfmi="urn:ietf:params:xml:ns:yang:\
                      ietf-i2nsf-nsf-monitoring">
           nsfmi:memory-alarm
         </alarm-category>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Tue, 28 Dec 2021 02:23:05 +0000

Dear Authors,

Is there anything you'd like us to send back to the XML reviewers at this point? If you have any questions you'd like us to forward, just let us know.

thanks,

Amanda Baber
IANA Operations Manager

On Fri Dec 17 18:41:40 2021, amanda.baber wrote:
> Dear Authors,
> 
> The XML registry expert has identified an issue with the registration
> in this document:
> 
> ===
> 
> For it to work, (a) the prefix in the alarm-category element MUST be
> the same as the namespace prefix for urn:ietf:params:xml:ns:yang:ietf-
> i2nsf-nsf-monitoring, which means that XML software MUST be chosen
> that makes the namespace prefix information available.  I don't think
> it's OK for the draft not to say those things.
> 
> <alarm-category
> ===
> Best regards,
> Amanda Baber
> IANA Operations Manager