Subject: [I2nsf] comments to draft-jeong-i2nsf-security-management-automation-03

From: Linda Dunbar <[email-masked]>
Date: Mon, 4 Apr 2022 21:37:16 +0000

Paul, Patrick, Jung-Soo,

Since you listed draft-jeong-i2nsf-security-management-automation as one of the area for I2NSF Rechartering work item, I am curious what kind of information need to be exchanged between "Security Controller" and the "Security Audit System"?

Does the "Security Audit System" need to change information between NSFs?  What kind of information needs to be exchanged if Yes?

Linda

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 6 Apr 2022 01:04:26 +0900

Hi Linda,

On Tue, Apr 5, 2022 at 6:37 AM Linda Dunbar <[email-masked]>
wrote:

> Paul, Patrick, Jung-Soo,
>
>
>
> Since you listed draft-jeong-i2nsf-security-management-automation as one
> of the area for I2NSF Rechartering work item, I am curious what kind of
> information need to be exchanged between “Security Controller” and the
> “Security Audit System”?
>
  => [Paul] The information from Security Controller to Security Audit
System is an audit policy for a given security policy and the corresponding
NSF to check whether
       the NSF correctly works for the given security policy or not.
       The information from Security Audit System is an audit report that
an NSF does not work correctly according to the intended security policy
because of
       either malfunction or security compromise. With this information,
Security Controller can take an action to prevent a security problem
related to the reported NSF
       from existing further.

>
>
> Does the “Security Audit System” need to change information between NSFs?
> What kind of information needs to be exchanged if Yes?
>
 => Security Audit System collects NSF monitoring data from the NSFs and
stores them into either a centralized database or a decentralized database
(e.g., DLR).
      Then, it  analyzes the behavior of each NSF in terms of a configured
security policy to each NSF.  I2NSF Analyzer can play a role of the
analysis for
      the Security Audit System with a database.

      Thanks.

      Best Regards,
      Paul

>
>
> Linda
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>