Subject: [I2nsf] Questions to draft-lingga-i2nsf-application-interface-dm-02

From: Linda Dunbar <[email-masked]>
Date: Mon, 4 Apr 2022 22:03:06 +0000

Patrick, Paul, and Yunchul,

Based on the Figure 1, the "Application Interface" is for exchanging information between the Security Controller and the I2NSF Analyzer.  Then the Figure 2 shows that the Application Interface has "Policy Reconfiguration" from NSF name, Problem, and solution. Can you give some examples of the "problem or issues in the NSF"?

Isn't "Policy Reconfiguration" same as different sequences of the commends to the NSFs (Section 3.1)?

"Policy reconfiguration" works together with the three I2NSF interfaces defined for the I2NSF Framework

Thank you
Linda

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 6 Apr 2022 01:17:11 +0900

Hi Linda,

On Tue, Apr 5, 2022 at 7:06 AM Linda Dunbar <[email-masked]>
wrote:

> Based on the Figure 1, the “Application Interface” is for exchanging
> information between the Security Controller and the I2NSF Analyzer.  Then
> the Figure 2 shows that the Application Interface has “Policy
> Reconfiguration” from NSF name, Problem, and solution. Can you give some
> examples of the “problem or issues in the NSF”?
>
  => [Paul] The following I-D for Application Interface has two XML
configuration examples such as DDoS-attack detection and
       Overloaded NSF detection:

https://datatracker.ietf.org/doc/html/draft-lingga-i2nsf-application-interface-dm-02#page-23

>
>
> Isn’t “Policy Reconfiguration” same as different sequences of the commends
> to the NSFs (Section 3.1)?
>
>
>
> *“Policy reconfiguration” works together with the three I2NSF interfaces
> defined for the I2NSF Framework*
>
>
  => [Paul] Policy reconfiguration is performed by a series of actions as
following with three I2NSF interfaces:
      - The delivery of NSF monitoring data collection from an NSF to the
I2NSF Analyzer via Monitoring Interface
      - The analysis of the NSF monitoring data and the generation of a
policy reconfiguration by the I2NSF Analyzer
      - The delivery of the policy reconfiguration from the I2NSF Analyzer
to the Security Controller via Application Interface
      - The translation of the policy reconfiguration into a low-level
security policy by the Security Controller
      - The delivery of the low-level security policy from the Security
Controller to the appropriate NSF

      Thanks.

      Best Regards,
      Paul

>
>
>
>
> Thank you
>
> Linda
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>