Subject: [Iasa20] IAOC committees Re: IAOC -- looking for committee volunteers

From: "Leslie Daigle" <[email-masked]>
Date: Tue, 11 Apr 2017 16:03:09 -0400

A personal observation on committees and their accountability.

The committees, as they exist today, are very much a useful tool for 
IAOC *and* the IAD.  Done right, they can provide the information needed 
by the IAOC to be comfortable in its oversight role, even as they are 
providing additional support to the IAD in ensuring decisions are 
considered in the light of IETF culture and reality.

As for accountability — committees don’t make decisions, the IAOC 
does (or the IAD, as appropriate).  So, established accountability of 
appointments is preserved.

While I have, elsewhere, observed that the IAOC can be a “thick” 
(engaged in the operations) or “thin” (strictly oversight) model, 
and IASA 2.0 needs to chew on that, I don’t believe the existence of 
committees today is somehow proof that things are off the rails of 
appropriateness in the IETF model.

Inviting community members to volunteer for the committees is as much 
about providing more people the opportunity to see some of the sausage 
being made and (potentially :-) ) increase their likelihood to volunteer 
for the IAOC itself, as it is for moving the IAOC work forward.

Leslie.

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises LLC
[email-masked]
-------------------------------------------------------------------

On 10 Apr 2017, at 16:07, Brian E Carpenter wrote:

> Jordi,
>
> On 11/04/2017 06:27, JORDI PALET MARTINEZ wrote:
>> Once more, as I indicated in November last year. I fail to see ANY 
>> RFC that confirms that the IAOC itself is empowered by the community 
>> to select more committee members in a very obscure way, and as Leslie 
>> indicated based on “personell decisions”. Clearly not transparent 
>> at all.
>>
>> Why, if committees need more participants, which I understand because 
>> the increase of the workload, and knowing already since several 
>> months ago that this is a thread, and that the NomCom have candidates 
>> to participate.
>>
>> We have got an opportunity to ask the NomCom to work on extra 
>> candidates since some people was appointed already in November.
>>
>> If there is no RFC allowing it, clearly this is a decision that MUST 
>> be appealed, as it is totally against the IETF spirit.
>
> I disagree, but let me explain why, because I agree that there's a
> problem, just not the one that you state.
>
> And I suggest that we follow up on the appropriate list for the point 
> I'm
> going to make (hence the way this message is addressed, with a Bcc to 
> the
> ietf list).
>
> Firstly, we gave the administrative job to IASA some years ago. IASA, 
> whose
> head is the IAD, is IMHO completely entitled to do its job how it 
> pleases,
> for example by negotiating resources with ISOC or by calling for 
> community
> volunteers and organising them in committees.
>
> Secondly, we created the IAOC to oversee IASA and the IAD. That's what
> the "O" in IAOC stands for, and it was not a casual choice.
>
> These two separate consensus decisions have got very mixed up since 
> 2005.
> The IAOC is evidently not just overseeing IASA - it's doing a large 
> part of
> the work of IASA itself. That's the problem that needs fixing - either 
> by
> changing the rules in RFC 4071 to describe reality, or by changing 
> reality
> to follow the rules.
>
> Not everyone agrees with my analysis, but I think we have the IASA 2.0
> discussion for a reason.
>
>    Brian
>
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 11 Apr 2017 23:41:28 +0200

Hi Leslie,

I fully agree with your view about how useful can be the committees, and how they support the oversight function of the IAOC/IAD.

What I’m very disappointed and as I talked with many community members they are as well, is the lack of a clear and transparent process in how volunteers are selected, outside of any RFC documented process and in general the lack of timely transparency of the IAOC work.

When I discovered the lack of “any” document supporting that process (I was expecting that is done by the NomCom set of volunteers that have not been selected each year, or something similar), and questioned that last November, I got, in my opinion, the worst kind of answer that I could ever expect:

“The IAOC’s Committees are populated by and work at the pleasure of the IAOC, which decides who makes sense to put on them, what expertise and experience is important at a moment in time, and how best to put people together that they believe will work well together” … “We have not published detailed review our our decision process about composing the committees — these are intimately tied to the details of how we get our work done and they are, frankly, personnel decisions.”

I’m sure there is nothing personal in that answer, but frankly speaking, it sounds like that, and moreover I feel that is demonstrating that this way of doing it is plain wrong and broken. In my opinion, anyone willing to represent the community and providing this kind of answer must step down, because this is against the community spirit and is a subjective way of working with the community, which should not be for a representative. And believe me, is nothing personal against you: I will have the same opinion even if my best friend has a representative position in any community and provides this kind of answer.

I’m not in the IETF to make friends neither to expect that people is willing to work with me because any kind of “personnel decisions” or they believe will work well together. This is ridiculous. We all have imperfections, we all do things well and others not so well, but if anyone is volunteering for something, lending his hand to anyone that may need it, contributing not just to technical work, but also administrative one (which most of that participants I believe in general will run away from it), etc., and the response is basically “we choose at our discretion those that we work better/know better, this is a personal decision”, for a non-native-English speaker at least, it means “friends”.

What that means: Instead trusting the IAOC and getting more and more volunteers for helping with the work, you will get less and less, and more and more people very disappointed not trusting you anymore. This is sad, very sad.

This is what you got at least in my own case: since I got that response in November, I started considering and actually took a very serious decision about it, that I’m not going to volunteer for anything else, until there is a transparent model.

Up to now, I think I’ve been very supportive for any task that I was asked for and I don’t recall anything I’ve rejected, I liked it or not. I’ve helped every time I was asked for, and not just in the scope of the IETF, the RIRs, ICANN and ISOC, but also doing trainings and speaking about IPv6 in more than 110 countries (when I counted them a few years ago) and in all those trainings/talks I always took the opportunity to explain how IETF works and the many good things of our model, and I always defended it in several mailing lists where IETF was being attacked, as seriously I was trusting in that.

Now I seriously believe that we have many broken things and is going worst and worst and we can’t trust at all the IAOC and the work being done.

When Brian was IETF chair, he asked me to work on several things, including the first document about the venue-selection-criteria and also another one on the technical requirements, and I did that, no question. Then it seems that those documents have been ignored, fine, not nice, but fine. I think is a matter of respect, not friendship, if there is already a document as a starting point for something, the minimum that I MUST do is talk to the original author(s) to work on that or ask them pass the baton if they can’t or don’t want to contribute.

And don't understand me, I’m not saying that I don’t want to make friends at IETF, but is not my main priority, and in fact I believe I’m very friendly and kind with anyone and actually did a lot of friends. However, I’m not establishing my work or contributions, technical or not, based on personal preferences.

A couple of additional examples from the lack of performance and accountability of the IAOC:

1) Since August 2015 I’m still waiting for a response from the IAOC. They told me they will come back with something regarding the anti-spam configuration of the IETF, the frequent bounces, etc. Do you think is right over 3 years without a response that was committed to be provided?
2) Since the end of the last Chicago meeting, we started wasting our time to discuss about the possibility to cancel SF meetings because the US immigration situation. I’ve made specific questions to the IAOC already twice about that. I got no answer at all. Do you think this is reasonable? If there is a “secret” on that, there is ALWAYS ways to say something, but AGAIN “no answer” at all, means that I will need to wait also 3 years as in 1) ??? It means that you’re ignoring the community and asking them to debate without information that is key for that debate to make sense, so you simple DON’T CARE the wasted time of the participants.

I’m sorry, but I can’t believe that you don’t provide answers at all, and in a matter of hours, days as maximum. I will ask any elected position in ANY community to step down if they perform this way. Not getting paid for doing the work don’t means you have not obligation to provide answers. If you don’t want to provide them, the IAOC must resign and ask the NomCom to choose some others that are willing to be transparent.

May be not all what I’m saying here is directly related to the IASA 2.0, I know, but I think it makes sense to put in on the table in this thread, as in my opinion the basis of it, is the selection process of the volunteers, and the poor performance and timely transparency, of the IAOC.

Regards,
Jordi

-----Mensaje original-----
De: Leslie Daigle <[email-masked]>
Responder a: <[email-masked]>
Fecha: martes, 11 de abril de 2017, 22:03
Para: Brian E Carpenter <[email-masked]>
CC: JORDI PALET MARTINEZ <[email-masked]>, <[email-masked]>
Asunto: IAOC committees Re: [Iasa20] IAOC -- looking for committee volunteers

    

    
    Leslie.

    
    > Not everyone agrees with my analysis, but I think we have the IASA 2.0

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Apr 2017 14:17:37 +1200

Jordi,

I see one possible source of confusion in what you wrote.

"they are, frankly, personnel decisions." (which you quoted)

vs

"this is a personal decision." (which you wrote)

These are *very* different**. "Personnel decisions" means decisions about personnel,
more or less the same as "HR decisions" - which are generally treated as confidential
matters. Whether it concerns volunteers or paid staff, there are expectations of
privacy about such discussions. "Personal decisions" means decisions made personally
by individuals. Certainly "I don't want X in my committee" (a personal statement)
is very different from "X and Y don't seem to work well together" (part of an HR
or personnel discussion).

Whoever forms a committee wants to choose people who work well together.

** Of course, this is a feature of the English language. I don't know
Spanish or Catalan, but in French 'personnel' has both meanings, so they
must be distinguished by context.

    Brian

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 12 Apr 2017 10:50:01 +0200

Hi Brian,

Below, in-line.

Regards,
Jordi

-----Mensaje original-----
De: iasa20 <[email-masked]> en nombre de Brian E Carpenter <[email-masked]>
Organización: University of Auckland
Responder a: <[email-masked]>
Fecha: miércoles, 12 de abril de 2017, 4:17
Para: JORDI PALET MARTINEZ <[email-masked]>
CC: <[email-masked]>
Asunto: Re: [Iasa20] IAOC committees Re: IAOC -- looking for committee volunteers

    Jordi,

    
    vs

[Jordi] Yes, I understand that. In Spanish we have “decisions del personal” vs “decisiones personales”

[Jordi] And I see your point, but that was just a mistake about what I’ve written, same is wrongly written “And don’t understand me” while I was “thinking” (typing to fast and not reading twice before sending …) “And don’t misunderstand me”. The full point here is that Leslie/the IAOC is still telling us that they do at their pleasure and who work well together. This is “friends” not professional work. This is WRONG. This is not the SPIRIT of the IETF. This is NOT THE INCLUSION that we spend hours and hours talking about. This is discriminating people. This practically means that we are LYING all the time when we use those nice wording.

    
[Jordi] And besides that, what is the explanation for not answering in almost two years? What is the explanation about keeping the secret about the terms (event if not all the details are disclosed) about the SF contract?

[Jordi] The IAOC, instead of helping is forcing the people into WASTE OT TIME in a debate which is completely useless with the info in our time.

[Jordi] I’m starting to believe that the IETF should be incorporated. This way we can ask for civil and penal damages to the elected positions that not even have the education and respect to respond to the community.

[Jordi] Very sad and unfortunate and I think we will need to repeat all this until they respond, so hopefully they do quickly.

[Jordi] I think we need to have a procedure to recall the IAOC members if they don’t step down by themselves. Do we have that?

        Brian

---

From: Randy Bush <[email-masked]>
Date: Thu, 13 Apr 2017 10:14:39 +0900

> As for accountability ― committees don’t make decisions, the IAOC does
> (or the IAD, as appropriate).

my experience with the meetings committee in particular is that the
decision is far down the road before it gets to the iaoc.  if this has
changed in the last few years, great!

randy