Subject: [Iasa20] IASA 2.0 outcome properties

From: Alissa Cooper <[email-masked]>
Date: Wed, 19 Apr 2017 11:39:21 -0400

As noted at IETF 98, it seems that one reasonable next step here is to articulate some properties of the desirable end state of this work -- what Jonne called the target. What are the properties of the outcome that we want? I've put together the list below, reflecting the discussion in Chicago, the drafts that were written beforehand, and some material from BCP 101.

I don't think we need to nitpick on the details or wordsmith this per se, but it would be good to get a general sense of whether this captures the properties of the outcome that we're collectively looking for here. So please send feedback on whether you think the list below meets that bar. If we get to a place where there seems to be some agreement about a list of this sort, it will make it easier to start discussing solution options for the present set of problems. 

Below the list, I've included a couple of notes (just from my individual perspective) to try to provide a little more context.

== List ==

Administration

1. For each of the following functions, it should be clearly defined and documented who is responsible for executing the functions and who is responsible for overseeing those that do the execution. In cases where execution or oversight are done by paid staff, contractors, ISOC, or any paid entity, the mechanisms for obtaining community input and involvement should be clearly defined and documented.  

- Administrative support
- Budgeting
- Contracting
- Accounting
- Development (including fundraising)
- Meeting planning
- Legal support
- Communications
- Outreach
- IT support

(In the rest of this list, I refer to these functions and those executing them collectively as "administration" for short.)

2. Administration should have no influence over the technical decisions of the IETF or over the technical contents of IETF work. (By implication, suggestions for changes to standards development processes, technical leadership, technical leadership appointments, open participation, etc., are out of scope for this discussion.)

3. Administration should operate transparently, within the limits of business confidentiality. Budgets should be transparent.

4. Administration should be able to incorporate participation from community volunteers, but its functioning should not be dependent on community volunteers. In other words, the number of paid staff and contractors should be able to dynamically grow and shrink to suit the administrative needs of the IETF, including by accommodating those needs entirely with paid staff if volunteers are not available.

Oversight

1. Oversight over administration should be community-led. 

2. Oversight should be conducted transparently, within the limits of business confidentiality.

3. For personnel who are dedicated full-time or nearly full-time to IETF administration, the oversight function should include hiring and firing the personnel, reviewing the performance of the personnel, and setting the compensation of the personnel. (Text inspired by https://tools.ietf.org/html/bcp101#section-3). 

4. For personnel whose employment responsibilities include IETF administration as well as contractors, the oversight function should include reviewing the performance of those personnel and contractors. 

Funding

1. IETF funds should reside in their own independent financial account(s) with independent governance.

2. An organization that funds the IETF should have no more influence over IETF standards development outcomes than any other organization.

3. Funding for IETF operations should be derived from multiple sources.

4. The IETF funding strategy should incorporate both short-term/just-in-time and long-term fundraising vehicles. 

5. Long-term funding vehicles should have greater emphasis than short-term ones to reduce the overhead associated with obtaining sponsorships meeting-by-meeting and to allow for experimentation with new initiatives within the IETF.

== Discussion ==

Out of the list above, I think we do not currently meet the following ones, or we at least have room for improvement: administration #1, 3, and 4; oversight #2, 3 and 4, and funding #1, 4, and 5. Most of the rest were mentioned at IETF 98 or in the drafts and seem like things that people wanted to document to make sure they won't change going forward. 

Regarding oversight #3 and 4, the point here is to align individuals' employment objectives with the administrative objectives of the IETF. If we have administrative roles designed for people to be spending their paid work time on IETF administration, it makes sense that people from the IETF community would have some role in reviewing their performance. This is not the case today for a number of ISOC staff who provide administrative support to the IETF. And for individuals who spend the majority of their work time on IETF administration, it makes sense that people from the IETF community would have some additional role in selecting those individuals and setting their compensation (or that community participants would be able to choose to delegate those tasks, at least). Our documented process establishes that this is what we should be doing for the IAD and for contractors (assuming that establishing contract values and selecting firms are the equivalent steps for contractors) already. But this is not what we are doing for communications or fundraising.

Alissa

---

From: Ted Hardie <[email-masked]>
Date: Wed, 19 Apr 2017 12:03:44 -0700

Thanks for starting the thread.  Some thoughts below.

On Wed, Apr 19, 2017 at 8:39 AM, Alissa Cooper <[email-masked]> wrote:

> As noted at IETF 98, it seems that one reasonable next step here is to
> articulate some properties of the desirable end state of this work -- what
> Jonne called the target. What are the properties of the outcome that we
> want? I've put together the list below, reflecting the discussion in
> Chicago, the drafts that were written beforehand, and some material from
> BCP 101.
>
> I don't think we need to nitpick on the details or wordsmith this per se,
> but it would be good to get a general sense of whether this captures the
> properties of the outcome that we're collectively looking for here. So
> please send feedback on whether you think the list below meets that bar. If
> we get to a place where there seems to be some agreement about a list of
> this sort, it will make it easier to start discussing solution options for
> the present set of problems.
>
> Below the list, I've included a couple of notes (just from my individual
> perspective) to try to provide a little more context.
>
> == List ==
>
> Administration
>
> 1. For each of the following functions, it should be clearly defined and
> documented who is responsible for executing the functions and who is
> responsible for overseeing those that do the execution. In cases where
> execution or oversight are done by paid staff, contractors, ISOC, or any
> paid entity, the mechanisms for obtaining community input and involvement
> should be clearly defined and documented.
>
> - Administrative support
> - Budgeting
> - Contracting
> - Accounting
> (In the rest of this list, I refer to these functions and those executing
> them collectively as "administration" for short.)
>

You have a separate line below for funding.  It seems to me that
"Development (including fundraising)" needs to go into that bucket, as it
has different transparency properties and may need to respond to goals set
by different parts of the community than would oversee other parts of the
administration.  I'm also a little unclear what you mean by outreach here,
and for some versions of it I would take it out of administration/IASA
entirely.

> 2. Administration should have no influence over the technical decisions of
> the IETF or over the technical contents of IETF work. (By implication,
> suggestions for changes to standards development processes, technical
> leadership, technical leadership appointments, open participation, etc.,
> are out of scope for this discussion.)
>
> 3. Administration should operate transparently, within the limits of
> business confidentiality. Budgets should be transparent.
>
> 4. Administration should be able to incorporate participation from
> community volunteers, but its functioning should not be dependent on
> community volunteers. In other words, the number of paid staff and
> contractors should be able to dynamically grow and shrink to suit the
> administrative needs of the IETF, including by accommodating those needs
> entirely with paid staff if volunteers are not available.
>
>
> Oversight
>

I know you don't want wordsmithing, but point 1 seems far too vague;
oversight isn't defined and community-led isn't either.  Between the two,
there's no way to tell if two random IETFers agree that some particular
system fits this or not.  Can we say something more direct like "IETF
Participants will select those overseeing this activity and will have
access to the information relevant to that oversight within the limits of
business confidentiality" to subsume this and point 2?

> 3. For personnel who are dedicated full-time or nearly full-time to IETF
> administration, the oversight function should include hiring and firing the
> personnel, reviewing the performance of the personnel, and setting the
> compensation of the personnel. (Text inspired by
> https://tools.ietf.org/html/bcp101#section-3).
>
> 4. For personnel whose employment responsibilities include IETF
> administration as well as contractors, the oversight function should
> include reviewing the performance of those personnel and contractors.
>
>
> Funding
>
> 2. An organization that funds the IETF should have no more influence over
> IETF standards development outcomes than any other organization.
>
> 4. The IETF funding strategy should incorporate both
> short-term/just-in-time and long-term fundraising vehicles.
>
>
I am not sure why we want to describe the timelines of the funding strategy
in detail.  I think this might be a proxy for something about the output of
the IETF, specifically that its output can be seen to be sufficiently
useful when the users of that output fund it.  If that is correct, it seems
to implicitly contravene point 2; if it is not correct, I don't understand
it.

> 5. Long-term funding vehicles should have greater emphasis than short-term
> ones to reduce the overhead associated with obtaining sponsorships
> meeting-by-meeting and to allow for experimentation with new initiatives
> within the IETF.
>
>
> == Discussion ==
>
> Out of the list above, I think we do not currently meet the following
> ones, or we at least have room for improvement: administration #1, 3, and
> 4; oversight #2, 3 and 4, and funding #1, 4, and 5. Most of the rest were
> mentioned at IETF 98 or in the drafts and seem like things that people
> wanted to document to make sure they won't change going forward.
>
> Regarding oversight #3 and 4, the point here is to align individuals'
> employment objectives with the administrative objectives of the IETF. If we
> have administrative roles designed for people to be spending their paid
> work time on IETF administration, it makes sense that people from the IETF
> community would have some role in reviewing their performance. This is not
> the case today for a number of ISOC staff who provide administrative
> support to the IETF. And for individuals who spend the majority of their
> work time on IETF administration, it makes sense that people from the IETF
> community would have some additional role in selecting those individuals
> and setting their compensation (or that community participants would be
> able to choose to delegate those tasks, at least). Our documented process
> establishes that this is what we should be doing for the IAD and for
> contractors (assuming that establishing contract values and selecting firms
> are the equivalent steps for contractors) already
>  . But this is not what we are doing for communications or fundraising.
>
>
Given that this involves compensation and hiring, I think we have to shift
"people from the IETF community" to "selected by the IETF participants to
oversee this function." or we can't meet the normal business
confidentiality rules.

Thanks again for starting this conversation,

Ted

> Alissa
>
>
>
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20
>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 19 Apr 2017 20:43:36 +0100

Hiya,

Thanks for that good summary. I do think it sets out issues in
a useful way. Two things though, hopefully one easy, but one
maybe less easy...

- I think some form of "default to open" principle needs to be
stated as "business confidentiality" can be used (even by good
actors) to justify being extremely non-open. That mostly affects
your administration point 3 but I hope this is nearly wordsmithing
(if so, sorry:-) as the topic has been discussed quite a bit already.
(And to be clear I do not mean to ask that everything be open, but
that the default be that things are handled openly, except where
there's a justification and community acceptance that being open
is a bad plan for a set of identified cases/topics.)

- I'm not clear that the IETF community is, or should be, setup
to oversee someone's salary and/or bonus and I'd be concerned
that an ability to do that might end up forcing us to incorporate
and have members. I'm not saying I'm definitely against that kind
of management, though I'm pretty sure I'm against incorporating and
having members. In any case, such a change would be a serious enough
concern that I don't think we ought start out assuming that the
community exercises that kind of control over paid staffers. I do
agree though that the topic warrants discussion, as we don't have
much visibility, never mind oversight, of a bunch of the important
tasks carried out by staffers. To put this another way, I think your
oversight points 3 and 4 stray too far towards specifying a solution
already. I'm fine that solutions in that space be investigated, but
I'd not like to see the community or nomcom appointees commit now to
hiring and firing and setting bonuses, which I think may be implied
in your wording below. It may be possible to handle this for now
by making such things examples of possible outcomes in your
description text below, not sure.

Cheers,
S.

On 19/04/17 16:39, Alissa Cooper wrote:
> As noted at IETF 98, it seems that one reasonable next step here is
> to articulate some properties of the desirable end state of this work
> -- what Jonne called the target. What are the properties of the
> outcome that we want? I've put together the list below, reflecting
> the discussion in Chicago, the drafts that were written beforehand,
> and some material from BCP 101.
> 
> I don't think we need to nitpick on the details or wordsmith this per
> se, but it would be good to get a general sense of whether this
> captures the properties of the outcome that we're collectively
> looking for here. So please send feedback on whether you think the
> list below meets that bar. If we get to a place where there seems to
> be some agreement about a list of this sort, it will make it easier
> to start discussing solution options for the present set of problems.
> 
> 
> Below the list, I've included a couple of notes (just from my
> individual perspective) to try to provide a little more context.
> 
> == List ==
> 
> Administration
> 
> 1. For each of the following functions, it should be clearly defined
> and documented who is responsible for executing the functions and who
> is responsible for overseeing those that do the execution. In cases
> where execution or oversight are done by paid staff, contractors,
> ISOC, or any paid entity, the mechanisms for obtaining community
> input and involvement should be clearly defined and documented.
> 
> - Administrative support - Budgeting - Contracting - Accounting -
> Development (including fundraising) - Meeting planning - Legal
> support - Communications - Outreach - IT support
> 
> (In the rest of this list, I refer to these functions and those
> executing them collectively as "administration" for short.)
> 
> 2. Administration should have no influence over the technical
> decisions of the IETF or over the technical contents of IETF work.
> (By implication, suggestions for changes to standards development
> processes, technical leadership, technical leadership appointments,
> open participation, etc., are out of scope for this discussion.)
> 
> administrative needs of the IETF, including by accommodating those
> needs entirely with paid staff if volunteers are not available.
> 
> 
> Oversight
> 
> 3. For personnel who are dedicated full-time or nearly full-time to
> IETF administration, the oversight function should include hiring and
> firing the personnel, reviewing the performance of the personnel, and
> setting the compensation of the personnel. (Text inspired by
> 2. An organization that funds the IETF should have no more influence
> over IETF standards development outcomes than any other
> organization.
> 
> 5. Long-term funding vehicles should have greater emphasis than
> short-term ones to reduce the overhead associated with obtaining
> sponsorships meeting-by-meeting and to allow for experimentation with
> new initiatives within the IETF.
> 
> 
> == Discussion ==
> 
> ones, or we at least have room for improvement: administration #1, 3,
> and 4; oversight #2, 3 and 4, and funding #1, 4, and 5. Most of the
> rest were mentioned at IETF 98 or in the drafts and seem like things
> that people wanted to document to make sure they won't change going
> forward.
> 
> employment objectives with the administrative objectives of the IETF.
> If we have administrative roles designed for people to be spending
> their paid work time on IETF administration, it makes sense that
> people from the IETF community would have some role in reviewing
> their performance. This is not the case today for a number of ISOC
> staff who provide administrative support to the IETF. And for
> individuals who spend the majority of their work time on IETF
> administration, it makes sense that people from the IETF community
> would have some additional role in selecting those individuals and
> setting their compensation (or that community participants would be
> able to choose to delegate those tasks, at least). Our documented
> process establishes that this is what we should be doing for the IAD
> and for contractors (assuming that establishing contract values and
> selecting firms are the equivalent steps for contractors) already .
> But this is not what we are doing for communications or fundraising.
> 
> Alissa
> 
> 
> 
> _______________________________________________ iasa20 mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/iasa20
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 20 Apr 2017 11:07:30 +0900

< rant >

> 1. ... In cases where execution or oversight are done by paid staff,
>    contractors, ISOC, or any paid entity
> ...
> 4. In other words, the number of paid staff and contractors should be
>    able to dynamically grow and shrink to suit the administrative
>    needs of the IETF, including by accommodating those needs entirely
>    with paid staff if volunteers are not available.

i am very uncomfortable with 'paid staff' if you mean ietf employees
paid by the ietf.  handling money and employees will change the tenor
of organization greatly.  this is a very slippery slope.

>    IETF administration, the oversight function should include hiring
>    and firing the personnel, reviewing the performance of the
>    personnel, and setting the compensation of the personnel.

i did not think i could become more uncomfortable, but i just did.  same
reasons.  do we want to be the ieee or itu (a line from pogo comes to
mind)?  this path creates empire and ossification.

imiho, there are two major factors keeping the ietf from becoming just
another hidebound sdo.

one is the nomcom process instead of a popularity election process.
while not perfect (what is?), we actually have a somewhat fair method of
selecting for merit and quality.  though, in an organization run by paid
bureaucrats, the quality of the ostensible leadership maybe be less of
an issue.

the second is being arm's length from money, HR, ...  yes, we need to
have oversight and authority; but the level of indirection through the
secretariat, rfc, isoc, ... keeps us out of some very serious mud.  some
of these, namely the relationship with the isoc, we need to manage
better.  i think the ietf's relationships to the rfc process and the
secretariat show that we can do this quite well; we just have to apply
it.

in a sense, the isoc is an example of the path of employees and money.
i, for one, do not think we should go there.

but the cloudiness and poor coordination of the ietf/isoc relationship
lies as much, or more, on our doorstep as isoc's.  we give them no good
guidance, express our expectations in a <deleted> manner, ...  if we can
not manage this well, the mind boggles at how we will manage a growing
internal bureaucracy (and yes it will grow; bureaucracies always do).

rather, or alongside, a discussion of how we can become more hidebound
and bureaucratic, i would feel a lot better with a discussion of how we
can become more dynamic, forward thinking, and less of a technical
embellishment <tm>.

we are no longer actually safe in our homes and cars; and we, the ietf,
are partly responsible for this.  if ameliorating this is a goal, is
building an (more?) internal bureaucracy going to help?

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 20 Apr 2017 15:10:21 +1200

My thanks also for attempting this analysis.

I do share Randy's concern. We need to stay a mile away from
contributor-influenced decision taking. Some comments in line:

On 20/04/2017 03:39, Alissa Cooper wrote:

...

> - Accounting
* - Development (including fundraising)
> - Legal support
* - Communications
* - Outreach
> 2. Administration should have no influence over the technical decisions of the IETF or over the technical contents of IETF work. (By implication, suggestions for changes to standards development pr…

Right. But we have to be aware of indirect effects; that is the risk of creating a direct relationship between sponsors and IETF budget lines. So I think that whatever else happens, money that goes into the IETF account must not carry any tag more detailed than "IETF".

> 4. Administration should be able to incorporate participation from community volunteers, but its functioning should not be dependent on community volunteers. In other words, the number of paid staf…

Sure. But please be explicit that this is distinct from oversight and that there is no presumption that one who volunteers for oversight is also volunteering to help administer (or vice versa).

> 4. For personnel whose employment responsibilities include IETF administration as well as contractors, the oversight function should include reviewing the performance of those personnel and contrac…

Can't quite parse that. Can you unravel it and explain who does what to whom?
 
> 1. IETF funds should reside in their own independent financial account(s) with independent governance.

Note that this doesn't prevent the account being held by ISOC (which already has non-profit status).
 
> 2. An organization that funds the IETF should have no more influence over IETF standards development outcomes than any other organization.

And that has the corollary I mentioned above: IETF funds must not be tagged for specific purposes by the donor.

> Out of the list above, I think we do not currently meet the following ones, or we at least have room for improvement: administration #1, 3, and 4; oversight #2, 3 and 4, and funding #1, 4, and 5. M…

I'm not sure I agree with all those assessments, but my main question is: which of the shortfalls are due to mistakes in BCP 101, and which of them are due to mistakes in implementing BCP 101? Because it seems that we need two very different action plans (fixing BCP 101 itself, and fixing the implementation errors).

Regards
    Brian

> 
> Regarding oversight #3 and 4, the point here is to align individuals' employment objectives with the administrative objectives of the IETF. If we have administrative roles designed for people to be spending their paid work time on IETF administration, it makes sense that people from the IETF community would have some role in reviewing their performance. This is not the case today for a number of ISOC staff who provide administrative support to the IETF. And for individuals who spend the majority of their work time on IETF administration, it makes sense that people from the IETF community would have some additional role in selecting those individuals and setting their compensation (or that community participants would be able to choose to delegate those tasks, at least). Our documented process establishes that this is what we should be doing for the IAD and for contractors (assuming that establishing contract values and selecting firms are the equivalent steps for contractors) already
> .

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 21 Apr 2017 07:09:41 -0400

Hi Stephen,

> On Apr 19, 2017, at 3:43 PM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 

Sure, I think a re-phrase could make this clear.

> community exercises that kind of control over paid staffers.

Note that this is not actually a change from what we have specified today. BCP 101 specifies the following:

"Although the IAD is an ISOC employee, he or she works under the
   direction of the IAOC.  A committee of the IAOC is responsible for
   hiring and firing the IAD, for reviewing the IAD's performance, and
   for setting the compensation of the IAD.  The members of this
   committee are appointed by the IAOC and consist at minimum of the
   ISOC President, the IETF Chair, and one of the Nomcom-appointed IAOC
   members.”

The point I was trying to express in oversight #3 was that the same standard should apply to anyone who is working full-time or near-full-time doing administration for the IETF. For contractors we get at this by setting the value of the contracts, but for “employees" the oversight levers should be equivalent for people whose job/career outcomes are equivalently affected by how the IETF community views them to be performing, or how their performance affects the administration of the IETF. 

Alissa

> I do

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 21 Apr 2017 12:27:12 +0100

Hiya,

On 21/04/17 12:09, Alissa Cooper wrote:
> The point I was trying to express in oversight #3 was that the same
> standard should apply to anyone who is working full-time or
> near-full-time doing administration for the IETF. For contractors we
> get at this by setting the value of the contracts, but for
> “employees" the oversight levers should be equivalent for people
> whose job/career outcomes are equivalently affected by how the IETF
> community views them to be performing, or how their performance
> affects the administration of the IETF.

That's not unreasonable. However, I do think there's a significant
difference between an IAOC ctte managing one person in that way,
vs. doing the same for maybe 20 people (how many are involved now
btw? I do recall you saying it was more than you'd until recently
imagined.) So I still think your current wording goes too much
towards specific solutions - and extrapolating from one instance
(IAOC managing IAD) to handling 20 folks the same way seems to me
to be only one specific solution. And I also continue to think
that that specific solution ends up with (or significantly moves
us towards) what I would call the major downside of incorporation
and membership.

Cheers,
S.

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 21 Apr 2017 07:34:20 -0400

> On Apr 19, 2017, at 10:07 PM, Randy Bush <[email-masked]> wrote:
> 
> < rant >
> 

At the level of generality at which these outcome properties are written, this point is purposefully left unspecified. What you are pointing to would be a question of solution design.

I would be interested to know how you would currently characterize the IAD role, though. Is that a paid staff position, given that the IAD salary is a line item in the IETF budget and the IAD is overseen by the IAOC? Or would you not consider it a paid staff position?

> mind)?  this path creates empire and ossification.

As I pointed out in my mail to Stephen, BCP 101 is already specified along the lines of the above vis a vis the IAD role. But there are other folks working 70% of their time or more on IETF administrative matters (communications, fundraising) for whom the same standard does not apply. So is your point that we started down the path to ossification when we published BCP 101? Or just that if we expanded the current model to apply to all of the people dedicating the majority of their time to IETF admin, that would be the ossification point?

> i, for one, do not think we should go there.

I guess from where I sit (this is a personal view only), we already are there, since our entire administrative structure is reliant on ISOC. On one side we have a group of volunteer engineers, out of which a dwindling number can be enticed to lend a dwindling amount of time to the growing task of administrative oversight of the IETF. On the other we have a $40m+ organization with its own internal bureaucracy that lends a good chunk of its staff and resources to the administration of the IETF, and that the dwindling pool of volunteer overseers has little time or ability to properly oversee or even penetrate. To my eye the level of indirection just causes us to sit in someone else’s mud (and watch it grow as the organization grows) instead of our own.

Alissa

---

From: Jari Arkko <[email-masked]>
Date: Fri, 21 Apr 2017 15:47:09 +0200

> So I still think your current wording goes too much

I think we can keep incorporation & membership and supervision
of workers doing things for IETF as separate items, I don’t think
they are connected at that level.

We could have an interesting discussion, I think, about the numbers,
how many people need to be involved or for what purpose. Or
exactly what the structure is for arranging their oversight. But I think
we reasonably need to conclude that if people do work for IETF’s
benefit, then there needs to be some oversight. Regardless of
whether those workers get paid by IETF or ISOC.

(And I wouldn’t say there is no oversight today, but I do believe
that it can be significantly improved.)

Also I’m not sure the employee / employee of ISOC / contractor
distinction is all that important. Think legal services, for instance,
regardless of how we’ve organised it today (contracted), it is easy
to imagine we might have had a different structure. But no
matter what the structure is, I think it would be clear that the IAOC
should be ultimately in charge of the oversight of the people
doing work for that function.

Jari

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 21 Apr 2017 13:45:32 -0400

> On Apr 19, 2017, at 11:10 PM, Brian E Carpenter <[email-masked]> wrote:
> 

I agree. The fact that they are delegated to IASA does not mean that the clarity that is called for above exists, though.

> Right. But we have to be aware of indirect effects; that is the risk of creating a direct relationship between sponsors and IETF budget lines. So I think that whatever else happens, money that goes into the IETF account must not carry any tag more detailed than "IETF”.

Maybe I’m misunderstanding, but what you are suggesting would be a pretty big departure from how we allocate sponsorship money today. E.g., we have many sponsorships that are specifically for a particular meeting, or a particular event at a meeting. I am personally certainly open to the idea that sponsorship models of a more general nature could be valuable, but I wouldn’t want to rule out more focused sponsorship opportunities since we’ve relied on them heavily.

> Can't quite parse that. Can you unravel it and explain who does what to whom?

Reading #3 and #4 together, the goal is to align the employment goals with the folks employed to do IETF admin work (regardless of who employs them) with the goals of the IETF, and to make sure that the IETF community has the authority it needs to oversee such folks to make that happen. For full-time or near-full-time people, the suggestion is that oversight should include hiring and firing, reviewing performance, and setting compensation. Because if someone is spending the majority of their work time working on IETF admin, the community should be able to select those people (or at least delegate the selection task to a paid person whom it did select), decide by what criteria their performance will be evaluated, review their performance against those criteria, and craft a compensation structure that incentivizes them properly. For people who are employed part-time on IETF admin work, or for contractors, the oversight function should at a minimum include the performance review piece. 

> Note that this doesn't prevent the account being held by ISOC (which already has non-profit status).

This is a solution detail, but I am honestly not sure. Under the current structure, the entire ISOC budget is governed by the ISOC Board of Trustees, on which the IETF community seats a minority of members. So even with separate financial accounts (which we also do not have right now, as far as I understand), I would not consider there to be independent governance. This is one of the issues that has been flagged in the workshop report and Leslie’s draft in the context of the IETF Endowment, for example. It may be possible to craft arrangements that do provide independent governance (e.g., a subsidiary or an affiliate) — this is to be explored as part of solution development, if we agree that independent governance is desirable.

> I'm not sure I agree with all those assessments, but my main question is: which of the shortfalls are due to mistakes in BCP 101, and which of them are due to mistakes in implementing BCP 101? Beca…

Folks could go through each item point-by-point to answer this, but this is not really how I would frame the question. BCP 101 was written at a particular time in the face of particular circumstances. Those circumstances included judgments about the administrative workload, concerns arising from what was in place before IASA, and an ISOC organization of a particular size and scope. Many of those circumstances have undergone significant change: the nature and breadth of the administrative workload, the extent to which the concerns of 2003/4/5 still exist, and the size and scope of ISOC. This is natural given how much time has elapsed. The structures put in place under BCP 101 served us very well for a long time, so rather than focusing on “mistakes” and how to fix them, I think we should focus on the needs of the IETF now and in the future, given what we know about how things have changed.

Alissa

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 22 Apr 2017 08:37:52 +1200

> I agree. The fact that they are delegated to IASA does not mean that the clarity that is called for above exists, though.

Agreed.

> Maybe I’m misunderstanding, but what you are suggesting would be a pretty big departure from how we allocate sponsorship money today. E.g., we have many sponsorships that are specifically for a par…

Yes, let me slightly modify my comment. As I just said in reply to Jari, we must never accept money that is earmarked for specific working groups or work items. And even if we accept money that is earmarked for specific general activities (such as the hackathon), that needs to be limited to a fairly small fraction of the total budget. Otherwise the fact that the money is earmarked will interfere with our decision processes. Also, earmarked money normally conveys "naming rights" and we don't want vendor logos over every meeting room door.
 
> Reading #3 and #4 together, the goal is to align the employment goals with the folks employed to do IETF admin work (regardless of who employs them) with the goals of the IETF, and to make sure tha…

Here I think we are entering dangerous territory. Yes, the IAOC hires and fires the IAD. But "D" means Director. To me than means that the IAD should hire and fire the rest of IASA staff. If she does it wrong, the IAOC can fire her. So to me, your "(or at least...)" parenthesis is is the only solution. Otherwise you're asking for the whole IAOC to consist of experienced and competent people managers, and although we have some of them in the IETF, I'm not sure we can persuade enough of them to volunteer for the IAOC.

> This is a solution detail, but I am honestly not sure. Under the current structure, the entire ISOC budget is governed by the ISOC Board of Trustees, on which the IETF community seats a minority of…

I'm pretty sure, because when I was in the ISOC Board, I saw enough of the issues involved in obtaining and maintaining 501(c)(3) status to persuade me that all we could achieve would be creating ISOC2. Much better to get a suitable structure set up inside ISOC1. This was definitely a fail in the original IASA setup.

> Folks could go through each item point-by-point to answer this, but this is not really how I would frame the question. BCP 101 was written at a particular time in the face of particular circumstanc…

Well, yes, that is certainly the first stage. But I think the second stage will definitely split into the two aspects I mentioned, and we'll need to be clear-headed about them, since things must continue to work meantime. We operated on very thin ice in 2004-2006 or thereabouts, and I wouldn't want to see that again.

    Brian

---

From: "Eggert, Lars" <[email-masked]>
Date: Sat, 22 Apr 2017 11:11:04 +0000

Hi,

> Maybe I’m misunderstanding, but what you are suggesting would be a pretty big departure from how we allocate sponsorship money today. E.g., we have many sponsorships that are specifically for a par…

how much hassle is it to offer these more focused sponsorship opportunities, esp. in-kind ones? Do we have sponsors that actually want all those choices?

SIGCOMM, for example, is pretty much following the approach Brian outlined: You pay at a certain level, and with it come certain perks (see http://conferences.sigcomm.org/sigcomm/2017/supporters.html for what these year's levels entail). Beyond that, a sponsor has no ability to influence where there contribution goes. They can make requests, for example, having their logo shop up for the lunch on a certain day, but their money all goes into a big pool out of which all expenses are paid.

At least within the SIG, I have never heard that this simple approach caused unhappiness with the sponsors.

Lars

---

From: Jari Arkko <[email-masked]>
Date: Sat, 22 Apr 2017 13:58:16 +0200

> how much hassle is it to offer these more focused sponsorship opportunities, esp. in-kind ones? Do we have sponsors that actually want all those choices?

I won’t comment at the moment on the focused vs. unfocused sponsorship models. There’s some pros and cons. 

But, I wanted to comment on your point about in-kind contributions above. Those definitely are very specific today. We have companies that have and can donate a circuit for instance, or who are willing to donate their valuable employee’s time to do a major task in the NOC or tools, for instance. I don’t think these in-kind sponsors would be easily able to switch to donating just money, if that’s what you meant. Nor would we necessarily want them to, because we actually want that specific circuit or person.

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 23 Apr 2017 08:25:27 +1200

> But, I wanted to comment on your point about in-kind contributions above. Those definitely are very specific today. We have companies that have and can donate a circuit for instance, or who are wil…

And that all seems fine, since the examples you give are neutral with respect to the IETF's work program. My worry is about sponsorship of specific work items.

     Brian

---

From: Alissa Cooper <[email-masked]>
Date: Sun, 23 Apr 2017 21:08:20 -0400

Hi Ted,

> On Apr 19, 2017, at 3:03 PM, Ted Hardie <[email-masked]> wrote:
> 
> On Wed, Apr 19, 2017 at 8:39 AM, Alissa Cooper <[email-masked] <mailto:[email-masked]>> wrote:
> You have a separate line below for funding.  It seems to me that "Development (including fundraising)" needs to go into that bucket, as it has different transparency properties and may need to respond to goals set by different parts of the community than would oversee other parts of the administration. 

Perhaps you could expand a bit by what you mean by “into that bucket” because it’s not quite clear to me. Are you saying that you think development needs to be administered differently than the other functions? Or overseen by different people? 

> I'm also a little unclear what you mean by outreach here, and for some versions of it I would take it out of administration/IASA entirely. 

I would put the kinds of things that Olaf presented in Chicago <https://www.ietf.org/proceedings/98/slides/slides-98-iasa20-isoc-contributions-00.pdf <https://www.ietf.org/proceedings/98/slides/slides-98-iasa20-isoc-contributions-00.pdf>>, in his slides #5-8, in that bucket. 

> I know you don't want wordsmithing, but point 1 seems far too vague; oversight isn't defined and community-led isn't either.  Between the two, there's no way to tell if two random IETFers agree that some particular system fits this or not.  Can we say something more direct like "IETF Participants will select those overseeing this activity and will have access to the information relevant to that oversight within the limits of business confidentiality" to subsume this and point 2?

This is indeed hard to specify in the abstract, but I thought what I was hearing in Chicago was that folks wanted to maintain the idea that volunteers from the community continue to be the primary people conducting the oversight of IETF administrative activity. Community-led is perhaps a poor way to phrase that, but that’s what I was going for, which is a little stronger than saying that those doing oversight will be selected by the community. 

> 3. For personnel who are dedicated full-time or nearly full-time to IETF administration, the oversight function should include hiring and firing the personnel, reviewing the performance of the personnel, and setting the compensation of the personnel. (Text inspired by https://tools.ietf.org/html/bcp101#section-3 <https://tools.ietf.org/html/bcp101#section-3>).
> 
> I am not sure why we want to describe the timelines of the funding strategy in detail.  I think this might be a proxy for something about the output of the IETF, specifically that its output can be seen to be sufficiently useful when the users of that output fund it.  If that is correct, it seems to implicitly contravene point 2; if it is not correct, I don't understand it.

This is drawn from Jari’s draft. My understanding is that historically, there has been a preference to raise money over short cycles, e.g., to obtain sponsorships for the next few meetings, but not to do much in the way of longer term fundraising sustainability. With the introduction of the global host program and the endowment that has changed somewhat, and the point of stating this as a objective would be to capture that shift in strategy explicitly, rather than sliding into it implicitly. 

> Given that this involves compensation and hiring, I think we have to shift "people from the IETF community" to "selected by the IETF participants to oversee this function." or we can't meet the normal business confidentiality rules.

Fair enough.

Thanks,
Alissa

> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/iasa20 <https://www.ietf.org/mailman/listinfo/iasa20>
>

---

From: Alissa Cooper <[email-masked]>
Date: Sun, 23 Apr 2017 21:18:33 -0400

> On Apr 21, 2017, at 7:27 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
> to be only one specific solution.

This is part of the reason why I differentiated between full-time/near-full-time and part-time/contractors. Out of the couple dozen ISOC folks who spend time on IETF admin, my sense is that there are two roles (comms and fundraising) that would meet the full-time/near-full-time threshold right now (not including the IAD role). But I think it’s a fair point that even with a handful of full-time/near-full-time folks, the way oversight #3 is phrased is probably too prescriptive and needs to be able to accommodate, e.g., some delegation of oversight or hierarchy of staffing.

> And I also continue to think

One observation about your formulation here, since you’ve used it a couple of times: incorporation is distinct from membership. That is, there are a number of models in which an organization can incorporate that do not involve membership of any sort; a membership corporation is just one of many kinds of corporate structure. I appreciate that people see downsides (and upsides) to both incorporation and membership, but I think in this discussion it would be useful to treat them separately, since we may end up drawing different conclusions about each.

Alissa

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 24 Apr 2017 04:55:57 +0100

On 24/04/17 02:18, Alissa Cooper wrote:
> One observation about your formulation here, since you’ve used it a
> couple of times: incorporation is distinct from membership. That is,
> there are a number of models in which an organization can incorporate
> that do not involve membership of any sort; a membership corporation
> is just one of many kinds of corporate structure. I appreciate that
> people see downsides (and upsides) to both incorporation and
> membership, but I think in this discussion it would be useful to
> treat them separately, since we may end up drawing different
> conclusions about each.

Agreed - as we tease out these issues, incorporation and membership
are separate things. However, there are roads we might follow that
lead to one or both of those happening without them being "the plan"
and I do think we ought avoid such roads except where we've put up
very large and glaring signposts ahead of time, and where the
community have clearly consciously chosen to take that danger-sign
laden road.

Cheers,
S.

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 25 Apr 2017 00:38:29 +0000

Randy – I think you make 2 good points below. The nomcom process is a key differentiator, and we don’t have company-designated representatives as in some other SDOs (nor voting or weighted voting by membership contribution). And the arms-length separation of financial support from the standards process is also a differentiator.

    another hidebound sdo.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Apr 2017 10:50:46 -0400

> where execution or oversight are done by paid staff, contractors, ISOC,
    > or any paid entity, the mechanisms for obtaining community input and
    > involvement should be clearly defined and documented.

...

    > 2. Administration should have no influence over the technical decisions
    > of the IETF or over the technical contents of IETF work. (By
    > implication, suggestions for changes to standards development

As written these distinctions are relatively clear.

There are some bits which I think are missing, and it relates to how we make
choices of tools, particularly communication tools.

**I think that we need to say something about dogfood**

I think that there are decisions which in other organizations would be
considered entirely administrative, which for the IETF are political.
(I say political in positive sense, and also more in the french sense of
involving policies.)

Some examples (my pet peeves) that I want to point to are:
     1) lock in to certain platforms via proprietary communication tools
        (somehow, my decade long screams about webex-windows are less
        seriously taken than when IE6-locked-in-users complain about JITSI...)
        Much of this is driven by an "in-kind" donation for which we have
        no SLA, and no support agreement.  How did that decision occur?
        I got a lot of push-back from a number of IESG members when I
        suggested they dogfood a webrtc solution.

     2) IPv6, DNSSEC, Javascript and anonymous access to the ietf.org web
        sites.  Thank god I never had to add ECN to that list.
     3) DMARC vs IETF mailing lists (4.5 year to get somewhere...)
     4) widespread abuse of text/plain to imply format=flowed in MLs.

My goal is not to rehash the above discussions (so please take them offlist),
just to put my point in context.  My goal here is to point out that in other
organizations these would be decisions made by "IT" management people who
report to CIOs or CFOs, and they would impose their decision upon the rest of
the workers (for good or bad).

Right now some of this decision making ability seems to rest in the IESG,
with implementation occuring via IAOC management of Secretariat and other
contractors.   I'm not clear that the IESG really has the bandwidth to deal
with these things in a timely fashion.

To the above list, I could add many other in-person meeting hassles from size
and frequency of cookies to temperature of meeting rooms.   Somehow, the
people writing the (hotel in this case) contracts need to be more visibly
accountable to the community and/or nomcom.

(Note: I said, "visibly". I think the much of the accountability is there,
but perhaps it is not visible enough to the community.)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-