Subject: [Iasa20] Comments on <draft-haberman-iasa20dt-recs-01>

From: Bob Hinden <[email-masked]>
Date: Tue, 7 Nov 2017 16:51:07 -0800

Hi,

Thanks for putting this together, I think it is an improvement over the earlier version.

I have a lot of comments, but will stick with what I see is the high level issue.

I think the basic conflict in the document is that it wants to not make any change in how the IETF’s standardization works, but at the same time wants to make the IETF more independent and in control of what it does.  I don’t think this is possible.  We currently have a model where financial decisions are kept very separate from the standardization activities.  When, for example, the IESG decides it wants the IETF to do something it hasn’t done before, there is never a discussion about how much does this cost and does it fit within the budget.  I use the IESG as an example, but it the same for the IAB, IRTF, and RFC-Editor.  We have the luxury of operating this way because we know that ISOC will pick up the extra costs.  To make a very rough analogy, we are the teenagers still living at home, but wanting complete independence and a bigger allowance.  Are we willing to move out, get a job, pay for an apartment, etc. and become independent of our parents?   I read a lot of things in this document wanting to have it both ways.

If we want to be more independent (especially in the Subsidiary and Independent models), I think this way of operating will need to change.  The IETF will have to become like an conventional organization where finance is part of most decisions.  For example, if the IESG decides to add a new area, add ADs, add working groups, new tools, have an interim meeting, or something else, it will need to know this fits in the current budget.  The IESG will need to have a budget, and live within it’s budget.  It will need to make the tradeoff between something new and stopping some existing activity, or defer the new work until more funding can be found.  The IETFAdminOrg (staff and board) won’t be able to do this because they don’t have enough information to make good tradeoffs.  More importantly, we will get better decisions by having the IESG making these decisions.

If we don’t do something like this where finance is part of what the IESG, IAB, RFC-Editor, and IRTF do, I don’t think we will be able to move away from model where ISOC is the financial backstop with everything else that comes along with this.    Otherwise we will continue to live in the world where we pretend that money doesn’t exist.  We can’t really become independent if we continue to live in this world.

I think this will be necessary if we want to become an ISOC Subsidiary or Independent organization.  If we don’t want to do this, then we should focus on improving and clarifying our relationship with ISOC.  Something like the IASA++ model.

I am not against the IETF becoming an ISOC Subsidiary (complete Independence is not practical as far as I can tell), but think we need to be realistic about what it means to do this.  I don’t think the changes can be limited to a separate IETFAdminOrg if we want it to work.

Thanks,
Bob

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 10 Nov 2017 11:15:48 +0800

Hi Bob,

> On Nov 8, 2017, at 8:51 AM, Bob Hinden <[email-masked]> wrote:
> 
> Hi,
> 
> I think the basic conflict in the document is that it wants to not make any change in how the IETF’s standardization works, but at the same time wants to make the IETF more independent and in control of what it does.  I don’t think this is possible.  We currently have a model where financial decisions are kept very separate from the standardization activities.  When, for example, the IESG decides it wants the IETF to do something it hasn’t done before, there is never a discussion about how much does this cost and does it fit within the budget.  I use the IESG as an example, but it the same for the IAB, IRTF, and RFC-Editor.  

This doesn’t really match my experience. It’s true that the budget is crafted and managed by different people than those who make strategic decisions about standardization, architecture, and research activities in the IETF/IRTF. But the IESG, and certainly the IETF Chair, considers how much things cost all the time. For example, last week I had a conversation with the secretariat about expenses related to having multiple screens in the IETF meeting rooms. Within the last couple of months the IESG had discussions about new MeetEcho features we’d like to see, and the subject of cost came up both in our conversation and as a gating factor requiring expenditure approval before we could move forward. I personally think there are some tools projects that I’d love to see done in the near term, but since I know the tools budget is maxed out with the RFC format changes, I haven’t initiated those conversations yet. Perhaps these are smaller in value/cost than what you are thinking about (e.g., it’s not like we cancel a meeting when we can’t find a host), but I don’t think any of the leadership bodies operates as if there is a bottomless well of money that can be spent if we so choose.

It is of course true that we don’t take strict measures to stay within the bounds of what we budget each year. But I think the IETF leadership already takes costs into consideration more often than you suggest.

Alissa

> We have the luxury of operating this way because we know that ISOC will pick up the extra costs.  To make a very rough analogy, we are the teenagers still living at home, but wanting complete independence and a bigger allowance.  Are we willing to move out, get a job, pay for an apartment, etc. and become independent of our parents?   I read a lot of things in this document wanting to have it both ways.
> 
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: Jari Arkko <[email-masked]>
Date: Sat, 11 Nov 2017 01:08:03 +0800

Thanks for your input, Bob!

(FWIW, I personally do agree with Alissa’s point of view that the leadership entities even outside IAOC do take cost into account. But I would characterise our current system as not having the processes around this particularly formalised, and there’s usually quite a bit of back-and-forth and cross-posting emails when something is discussed. This might or might not be a problem, depending on your point of view.)

Jari

---

From: Bob Hinden <[email-masked]>
Date: Sat, 11 Nov 2017 15:56:57 +0800

H Alissa,

> On Nov 10, 2017, at 11:15 AM, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Bob,
> 

That all good to hear, but I suspect that isn’t the case for the other parts of the IETF like the IAB, RFC-Editor, and IRTF.  I also think that it wasn’t the case earlier.  We tried pretty hard to keep these things separate.

> It is of course true that we don’t take strict measures to stay within the bounds of what we budget each year. But I think the IETF leadership already takes costs into consideration more often than…

My point is that if we want to be “independent” in either model we will need to live within a real budget where we have to make tradeoffs where to spend the money and to have the revenue and expenses match.  We have had the luxury to not have to do this until now.  It will require us to change how we operate.   It will require changes to how IETF standards operate in the operational sense, I would like to the document make that clearer.  As it is written that doesn’t appear to be the case.

Thanks,
Bob

---

From: Andrew Sullivan <[email-masked]>
Date: Sat, 11 Nov 2017 03:50:17 -0500

On Sat, Nov 11, 2017 at 03:56:57PM +0800, Bob Hinden wrote:

> My point is that if we want to be “independent” in either model we will need to live within a real budget where we have to make tradeoffs where to spend the money and to have the revenue and expenses match.  We have had the luxury to not have to do this until now.
>

I think that's probably true in a strict sense, but it seems to me
that ought to be something to want _anyway_.

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 13 Nov 2017 14:07:16 +0000

You make a good point, Bob. In a model where, for example, the IETF has annual revenues of $3M then the organization must create a realistic and achievable budget and live within that $3M. Trade-offs must necessarily be made and relative priorities set, as neither time nor money are unlimited. I think the IETF is ready to do that. We may have to learn a little bit about the financial impact of the decisions we make but that seems a natural part of the learning process and the development / maturation of the IETF’s administration.

- Jason

On 11/11/17, 2:57 AM, "iasa20 on behalf of Bob Hinden" <[email-masked] on behalf of [email-masked]> wrote:
> My point is that if we want to be “independent” in either model we will need to live within a real budget where we have to make tradeoffs where to spend the money and to have the revenue and expenses match.  We have had the luxury to not have to do this until now.  It will require us to change how we operate.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Nov 2017 22:30:09 +0800

Bob,

One more follow-up:

> My point is that if we want to be “independent” in either model we will need to live within a real budget where we have to make tradeoffs where to spend the money and to have the revenue and expenses match.

I’m not disagreeing, but I’ll point out what many have already said: the options form a spectrum. It is true that for complete independence one wants one’s own funding, everything under your own control.  And you could also imagine organisations where you have a fixed budget, even if you shared employees with another entity.

But I would hope that there are ways to improve organisation even (if) its financial model stays the largely the same, or changes in smaller degrees than going to full own funding. Our R&D department at the office can reorganise itself even when the external funding situation stays the same. I think the same applies to IETF. We’ve experienced some pain in our current arrangements, at least in my experience. It would be good to arrange our setup in the way that it works best for us.

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 14 Nov 2017 12:18:26 +1300

> You make a good point, Bob. In a model where, for example, the IETF has annual revenues of $3M then the organization must create a realistic and achievable budget and live within that $3M. Trade-of…

Right, but all that requires is a well-defined cost centre to which all
IETF costs are assigned. It's a bit disappointing if that isn't already
the case; since the IASA has been providing budget numbers to the community
since 2006, I'm wondering what we are actually missing at the moment.
Are we missing indirect costs that ISOC pays but doesn't charge back
to the IETF budget?

What is lacking at https://iaoc.ietf.org/budget-and-finance.html ?

    Brian