Subject: Re: [Iasa20] I-D Action: draft-haberman-iasa20dt-recs-01.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 8 Nov 2017 14:55:00 +1300

Hi,

Thanks for the work on this version. I find it much improved; my comments
on the text follow. I'll send a separate message on my overall opinion.

> 3.1.3.  Authority
...
>    For example, due to IETF's lack of legal status, contractual
>    agreements must be signed by ISOC on behalf of the IETF.  There are
>    occasions when a decision that is right for the IETF and desired by
>    IETF leadership cannot be executed due to constraints posed by what
>    ISOC can and cannot agree to itself.  For example, when IETF sought
>    to acquire a recent piece of software for business purposes, ISOC
>    would initially not agree to entering into an agreement with the
>    software provider.
Without asking for details, can somebody explain that a bit more? Was
it due to legal or financial doubts, or was there something else
going on?

> 3.1.4.  Oversight

All the points in this section are valid, but I think an important
issue is still missing: it doesn't capture the conflict of interest
when overseers (members of the IAOC) are also volunteer workers
for the IASA. I believe that conflict is real and has caused
confusion and failures of oversight in the past.

> 3.2.1.  Volunteers
...
>    IETFAdminOrg must rely less on volunteers or be better assured of
>    engagement of willing and capable volunteers.

I think this needs to be more explicit, e.g.

   IETFAdminOrg must rely less on volunteers or be better assured of
   engagement and formal commitments of willing and capable volunteers.

I believe somebody mentioned a while back that other professional
bodies get their volunteers to sign a formal agreement. That may not
be IETF-style but there's nothing worse than a vanishing volunteer...

> 3.3.  Lack of Transparency
...
>    Work to increase transparency has made progress, but we must continue
>    to address and improve this.  At the same time, a balance must be
>    struck to reach the right level of transparency, so that certain
>    aspects of contracts, business terms, and negotiations can remain
>    confidential, according to legal and business practice norms. 

That's good but I would add a final argument to the last sentence:

   , and to preserve IASA's negotiating position.

There's nothing worse in negotiation than giving away your bottom
line in advance.

> 4.  Goals
...
>    o  Clarify Overall Roles and Responsibilities: Ensure that all staff,
>       contractor, and volunteer roles are clearly documented. 

Yes, but the list should *star*t with oversight roles.

> 5.1.  Overall Structure
> 5.1.1.  IASA++

All the points are valid but I think a few are missing:

o Precise definitions of terms and conditions for volunteers

o Separate IAOC and Trust memberships

o Improve NomCom criteria accordingly

(These points really apply to all three models, of course.)

> 5.5.  Staff Structure
...
>    o  Executive Director.  The person in this role is in charge of the
>       overall IASA effort, but can rely on other staff members below as
>       well as contractors.  The Executive Director is accountable to the
>       Board.

Since this applies to all three models, it should say

       The Executive Director is accountable to the
       IAOC or Board.

...
>    Note: The Executive Director likely needs to be a full-time employee,
>    as is likely the case for the other Director-level positions.

I object pretty strongly to the notion that we need a full time Director
of Communications. In fact I don't understand why it would be designated
as a Directorship at all. A fulltime webmaster, perhaps. But we aren't
in the communications business, except as an adjunct to fund-raising.

> 6.1.  Comparison to Goals
...
>       In IASA++, leaving the responsibility for sponsorship fundraising
>       up to ISOC, as BCP 101 does, means we will always be constrained
>       by however ISOC is willing to staff and support IETF-specific
>       fundraising. 

But as I understand the IASA++ proposal, that is not proposed, except
that the Director of Fundraising would be an ISOC employee. So this
is an unfair characterisation of the IASA++ model.

...>       In the IASA++ option, there is limited improvement on clarity of
>       the financial arrangements.

Again, unfair. Whether the financial arrangements are clear is 100%
dependent on the clarity of accounting. Once we correct the error
of ISOC staff working for the IETF without their time being paid
by the IETF budget, this problem goes away in all three models.

...
>       However, in IASA++, some of lack of clarity may remain, as lack of
>       clarity inherent in two organizations controlling resources may
>       remain. 

Again, unfair. If we do it right - charge staff time to the IETF budget -
there will be no issue. We also need to clarify volunteer commitments,
of course, but that goes for all three models too.

...
>  o  Improve Transparency:
...
>       ...  The IAOC and committees have been operating with
>       their current structure, and, in some cases, current volunteers/
>       personnel, for a long time.  It will be harder for them to change
>       than to make staff-driven changes in an org with new staff.

There's some truth in that, but with a new broom (a new Director)
in place, clarification of volunteer roles, and some very clear
direction from the community to the IAOC, I don't see it as
insurmountable.

Regards
   Brian Carpenter

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 10 Nov 2017 11:26:59 +0800

Hi Brian,

I wanted to respond to a couple of your points in various mails to provide some details of what I’ve observed lately. I will try not to opine. :-)

> On Nov 8, 2017, at 9:55 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

I’m aware of one recent example, although I’m not sure if it’s the one referenced in the draft. In that case, the objection had nothing to do with legal or financial doubts. ISOC staff had used the software and didn’t like it, so objected to it being used for IETF purposes.

Alissa

---

From: Jari Arkko <[email-masked]>
Date: Sat, 11 Nov 2017 00:28:59 +0800

> confusion and failures of oversight in the past.

Ack, and agreed.

> be IETF-style but there's nothing worse than a vanishing volunteer…

… except perhaps a volunteer that vanishes when you show the agreement :-)

Anyway, more seriously, do you have pointers to other organisations that do this? Sorry, I don’t recall the previous discussion.

> There's nothing worse in negotiation than giving away your bottom

Indeed. Good addition.

> Yes, but the list should *star*t with oversight roles.

Yes. An omission.

> (These points really apply to all three models, of course.)

Ack, and noted.

As a personal comment, I am eager to learn more about item 1, but (hopefully healthily) somewhat sceptical. Tell me more! I do agree with item 2. And I like item 3, but not sure that is going to improve our pool when it is quite limited for administrative tasks at the moment.

>       The Executive Director is accountable to the

Yes. Thanks.

> in the communications business, except as an adjunct to fund-raising.

Noted. 

(Information from the last couple of years is that we’ve used a communications professional quite a lot, on varying communications tasks that included helping with press discussions, blogs and videos, the website design, etc. We could argue how critical this is, but it has been much beyond fund-raising.)

> is an unfair characterisation of the IASA++ model.

Ack.

So the point is that under IASA++, if we together with ISOC implement the new directors (even if they are ISOC employees) then from that perspective there is no change. Agreed. There may be of course be some other differences wrt funding and the options, but that we can discuss separately...

> by the IETF budget, this problem goes away in all three models.

Comment acknowledged. (Here we might find some disagreement though.)

> of course, but that goes for all three models too.

Ack, and see above. Although here your earlier comment that IASA++ would also need an agreement re: funding with ISOC may help things.

> direction from the community to the IAOC, I don't see it as

Ack. 

(Nothing is unsurmountable; we have a working system but there are people wishing to improve how it operates, and sometimes, at least in my experience, some pain in the current system.)

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 Nov 2017 08:14:55 +1300

Thanks Jari.

> Anyway, more seriously, do you have pointers to other organisations that do this? Sorry, I don’t recall the previous discussion.

I'm off to the airport shortly but I will look for this when I get the
chance.

    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 13 Nov 2017 19:59:59 +1300

Jari,

...>>> 3.2.1.  Volunteers
> Anyway, more seriously, do you have pointers to other organisations that do this? Sorry, I don’t recall the previous discussion.

I couldn't find the previous discussion, but Google found this which
explains the concept. We might not need all the points, of course:

https://knowhownonprofit.org/people/volunteers/keeping/volunteer-agreements#

   Brian